LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2005, 06:22 PM   #1
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Rep: Reputation: 0
opening port 433


I have a dedicated server with Plesk 7.5.4 on CentOS 3.3 and I need to be able to serve secure pages. When I contacted Plesk about a similar problem (getting the web stats to work) they said I need to open port 433 to do this. How can I do this with either Plesk or through SSH?
 
Old 09-09-2005, 06:30 PM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
I've never used centos, but i have heard it has a pretty extensive firewall. If you have this enabled and want to continue using the one with centos, you may want to find some docs. Otherwhise you can disable the firewall and use some other that may be a little easier for you to config.

Are you using a router? you will need to open the port for the server ip on that as well.
 
Old 09-09-2005, 06:33 PM   #3
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I don't know anything about the physical network setup of this server - its a dedicated server I bought from Layered Technologies.
 
Old 09-09-2005, 06:56 PM   #4
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
ok, then i would read this http://www.centos.org/docs/4/html/rh...-firewall.html then ssh into the server and open port 443. After looking thru that page, it's just the basic redhat firewall. For some reason I thought they used something else.
 
Old 09-09-2005, 07:23 PM   #5
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I read through that page but system-config-securitylevel gives a command not found error and /etc/sysconfig/system-config-securitylevel doesn't exist.
 
Old 09-09-2005, 07:38 PM   #6
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
if thats the case try looking at /etc/sysconfig/iptables. Open it up in a editor (vi, vim, emacs, nano<easier>) and type
ctrl+w (with nano)
then type
iptables -A INPUT -p

You will want to add something like below to that file. Then you will want to restart iptables.
iptables -A INPUT -p tcp -s 0/0 -d 0/0 --destination-port 443 --syn -j ACCEPT

I would do a quick search for howto iptables if you've never worked with them.



To configure the set of iptables rules:
/etc/rc.d/init.d/iptables stop


To save the current set of iptables rules for use at next reboot:
/etc/sysconfig/iptables

To dynamically restart iptables after modifying /etc/sysconfig/iptables:
/etc/rc.d/init.d/iptables restart

Last edited by bosewicht; 09-09-2005 at 07:41 PM.
 
Old 09-09-2005, 07:48 PM   #7
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I tried that and it didn't work....but even with iptables off it doesn't work, so doesn't that mean the problem is elsewhere?
 
Old 09-09-2005, 07:50 PM   #8
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
have you tried running nmap?
 
Old 09-09-2005, 07:54 PM   #9
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
No but the Plesk person I talked to did...


nmap 72.36.168.10 -p433

Starting nmap V. 3.00 ( www.insecure.org/nmap/ )
The 1 scanned port on servidor1.sdmservidores.com (72.36.168.10) is: closed

Nmap run completed -- 1 IP address (1 host up) scanned in 2 seconds

This causes the problem. You should open port 433 to enable SSL and access stats.
 
Old 09-09-2005, 08:03 PM   #10
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
try running in why you are ssh'ed into the machine.
 
Old 09-09-2005, 08:07 PM   #11
thekidder
LQ Newbie
 
Registered: Sep 2005
Posts: 8

Original Poster
Rep: Reputation: 0
nmap - command not found. I'd install it but I'm going to request an OS reload on the server anyway, there are a ton of problems with it. I'll try and fix this if it's still a problem after the reload.
 
Old 09-09-2005, 08:13 PM   #12
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
ok, good luck. If you're uncomfortable at the command line, you can use X thru ssh as well.

Noobs like X

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening Port steve007 Linux - Newbie 5 07-23-2005 02:05 PM
opening a port Robin01 Linux - General 3 11-17-2004 11:40 PM
Opening a Port gpamkenny Linux - Networking 3 11-04-2004 03:51 PM
Opening port 80 nmoog Linux - Newbie 4 02-01-2004 05:00 PM
Question on opening up a port cagspy Linux - Security 3 07-03-2002 08:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration