Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-10-2005, 01:08 AM   #1
LQ Newbie
Registered: Feb 2005
Location: Miramar
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
Angry NVIDIA and Fedora Core 3

I installed Fedora Core 3. Then I installed the NVIDIA drivers for the OS. When I do anything that requires OpenGL however the X server freezes. I am then forced to reboot.

I ran glx gears. The output was about 700 fps for about 10 lines. Then it starts outputting about 2800 fps for 10 lines. Then it switches back to 700, back to 2800, flip flopping in speed. My guess is that this is happening because the integrated video card and the nVidia video card are both being used by linux at the same time.(just my guess, but I'm a newb so what do I know)

I went to my BIOS and it said that the default video card is PCI and not AGP/On Board(But if my hunch is correct, Linux isn't respecting that). I have googled around for quite a while with no answers. So I'm here now. If anyone knows how to fix this problem please tell me? Just to help here is my etc/X11/xorg.conf file:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "COMPAQ 7550"
DisplaySize 360 270
HorizSync 30.0 - 86.0
VertRefresh 50.0 - 140.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"

Option "NvAGP" "0"
Option "NoLogo" "true"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

# Section "DRI"
# Group 0
# Mode 0666
# EndSection
Old 02-10-2005, 01:19 AM   #2
Registered: Jan 2004
Location: USA
Distribution: macOS, OpenBSD
Posts: 669

Rep: Reputation: 34
Can you not change the BIOS so that the onboard video card is disabled and any AGP cards are used instead?
Old 02-10-2005, 05:05 AM   #3
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
the 6629 driver of nvidia is buggy, try using the old 6111 driver or wait for next release, this could help...
(there was a thread on this some weeks ago, try searching this.
in the nvidia forums you'll also find tons about these problems...
Old 02-10-2005, 07:37 PM   #4
LQ Newbie
Registered: Feb 2005
Location: Miramar
Distribution: Fedora Core 3
Posts: 13

Original Poster
Rep: Reputation: 0
The video card I have is PCI. I went to my BIOS and my bios has the PCI card selected as default. The AGP/Onboard card is turned off already. That didn't fix it. Maybe I will just downgrade.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver and Fedora Core 2 j0Vian Linux - Newbie 2 11-15-2004 05:18 PM
colordepth on fedora core 2 and nvidia nsX Linux - General 5 06-22-2004 10:59 AM
fedora core 2 nvidia drivers cprogrck Linux - Hardware 21 06-16-2004 12:50 PM
fedora core +nvidia mortal Linux - Newbie 1 03-17-2004 07:37 PM
Nvidia drivers with Fedora core 1 doralsoral Linux - Software 5 12-24-2003 06:56 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration