Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-23-2009, 12:09 AM   #1
LQ Newbie
Registered: Dec 2004
Location: Raleigh, NC USA
Distribution: CentOS 5, RHEL 5, Ubuntu
Posts: 19

Rep: Reputation: 0
Fedora 10 won't remember DNS settings on reboot

Just set up Fedora 10 on one of my PCs and I want to use it as a web server behind my router. In the interests of full disclosure, I am a n00b.

I gave the Fedora box a static IP outside the DHCP range of my router. I then assigned the DNS servers and search path values to those I found in the status section of my router admin table. So, I am pointing to my ISP's name servers.

The settings from system-config-network are the following:

*Statically set IP addresses:
Subnet Mask:
Default gateway address:

On the DNS tab:

Hostname: <>
Primary DNS: <Roadrunner DNS server 1>
Secondary DNS: <Roadrunner DNS server 2>
Search Path: <Roadrunner domain>

Using these settings I can browse the interwebs just fine, and I can access my box from outside as well. However, when I reboot, I notice that all the info on my DNS tab in the network config panel has been erased and I have to enter the DNS servers in again to be able to access the interwebs. Any ideas why this is happening? Searching around, I have heard that DHCP is resetting things somehow, but I can't find a setting which would correspond to that. Another idea to is to set /etc/resolv.conf to read-only.

Any ideas? Thanks!

Last edited by Laserjock; 03-23-2009 at 12:12 AM.
Old 03-23-2009, 12:26 AM   #2
LQ Newbie
Registered: Mar 2009
Posts: 23

Rep: Reputation: 17
Not sure why your DNS is resetting on reboot.

You can try to set the mode on the file, to ready only.

chmod a-w /etc/resolv.conf
Old 03-23-2009, 05:48 PM   #3
Registered: Mar 2009
Distribution: Fedora, Slackware
Posts: 104

Rep: Reputation: 21
The default installation of Fedora 10 has a buggy GUI tool for networking. It mixes up the gateway and the netmask and in the end making all networking useless. You MUST update your F10 installation with the default Fedora package updater. Note that the default installation has some problems with yum repository settings, so if you prefer to update with yum, then you must first update that one as well.

I don't know if this is in any way related to your DNS problem, but an update on all tools is suggested anyway.

Linux Archive

Last edited by JaksoDebr; 04-02-2009 at 06:02 AM.
Old 03-24-2009, 09:33 AM   #4
LQ Newbie
Registered: Dec 2004
Location: Raleigh, NC USA
Distribution: CentOS 5, RHEL 5, Ubuntu
Posts: 19

Original Poster
Rep: Reputation: 0
NetworkManager to blame

Thanks for both recommendations, unfortunately neither one worked.

Setting resolv.conf to read-only didn't last; on reboot the write bit was flipped and the DNS values were wiped out like always.

I updated everything through yum and rebooted but nothing changed.

Looks like the NetworkManager is the guilty party - simply bouncing it without rebooting the machine results in the values in resolv.conf getting wiped out. I'd like to just disable it at this point and move on with my life. Unchecking the "Controlled by NetworkManager" box just kills my network connection completely.

Anyone have a guide to disabling NetworkMangler on Fed 10 and configuring static IP manually?
Old 03-24-2009, 10:23 AM   #5
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 299

Rep: Reputation: 62
Run chkconfig --list. You should see the network service off and the NetworkManager service on. If this is the case, you just need to turn off NetworkManager and turn on network.
Old 03-24-2009, 05:45 PM   #6
Registered: Mar 2009
Distribution: Fedora, Slackware
Posts: 104

Rep: Reputation: 21
On RedHat or similar systems you can modify network settings manually by editing file /etc/sysconfig/network-scripts/ifcfg-eth0 (or any other ifcfg-ethN files, if you have more network cards).
Old 03-31-2009, 10:29 AM   #7
LQ Newbie
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0

Hi guys!
In my /etc/resolv.conf file, is typing

# Generated by NetworkManager

# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:

So... to do this work, edit your ifcfg-ethX (X number of device), adding and lines...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 8.10 doesnt remember my settings after reboot bipolar420 Linux - Newbie 2 01-07-2009 03:55 PM
Fedore Core 7 Forgets Its DNS Settings on Reboot kaplan71 Linux - Networking 4 11-30-2007 11:01 AM
SuSe 10 forgets DNS settings on reboot IglooGuy SUSE / openSUSE 1 01-06-2006 03:45 PM
KDE does not remember settings mooreted Linux - Software 0 02-16-2004 04:53 PM
can't make SUSE remember IP settings after reboot...#$% roflash Linux - Networking 0 05-27-2002 10:18 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration