Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-12-2005, 12:31 PM   #1
Registered: Sep 2004
Location: Seattle
Distribution: Ubuntu
Posts: 51

Rep: Reputation: 15

I'm trying to install the latest version of Kino, but am making the newbie realization that the "tree" of dependencies can be very large, especially when your ISP access is dial-up. Is there any database out the that tracks the dependencies of mainstream applications and could give me an idea of how many days of dial-up downloading I have ahead?

Maybe my problem is that I have SUSE personal, rather than a more robust pro. distro?

On another note, when I do a ./configure and see a required package, should I worry about downloading a version that is too new compared to the required version listed?
Old 01-12-2005, 01:08 PM   #2
Senior Member
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
On the kino site or in the source directory in the README there should be something stating what it needs dependency wise. You can then match that up with whats on your system to see what you need.
Running suse though, make sure you have the corresponding -devel packages installed to whatever libraries it needs.

As far as too new of libraries, (generally speaking) as long as you are in the same major version (for example it needs gtkhtml-2.2 and you have gtkhtml-2.4 (but not gtkhtml-3.x.x)) you should be alright
Old 02-04-2005, 12:35 PM   #3
Registered: Nov 2004
Location: Hellas
Distribution: Zenwalk 6.4
Posts: 337
Blog Entries: 4

Rep: Reputation: 30
i have an installation problem too with kino
after installing all the depedencies and running ./configure it printed this message

checking for pkg-config... /usr/local/bin/pkg-config
checking for libglade-2.0 libgnomeui-2.0 >= 1.110.0... Package libglade-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libglade-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libglade-2.0' found

configure: error: Library requirements (libglade-2.0 libgnomeui-2.0 >= 1.110.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

i have installed both libglade-2.0 and libgnomeui-2.0
i tried changing the environment variable PGK_CONFIG_PATH to the directory which the libglade-2.0.pc is under with:

export PKG_CONFIG_PATH=/usr/lib/pkgconfig

but again when i try ./configure it prints the same error. is there anything else i can do about it?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dependencies!! xian67 Linux - Distributions 6 08-03-2004 08:44 PM
need help w/dependencies pfaendtner Linux - Newbie 1 07-29-2004 10:36 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM
dependencies tincat2 Linux - Software 3 06-27-2002 11:16 PM
dependencies vanhalen Linux - Newbie 1 06-12-2002 08:32 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration