LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2002, 06:43 PM   #1
groovin
Member
 
Registered: Oct 2002
Distribution: RH 8
Posts: 83

Rep: Reputation: 15
cant change permissions on a mounted windows partition


ok, heres the deal... i have a windows partition i mount in /etc/fstab with the following line:

/dev/hda5 /mnt/storage vfat auto,owner,users,umask=000 0 0

it mounts fine, but when i log in as a user, i cant write to it. i get an access denied. ls -l /mnt shows that the dir storage has permissions drwxr-wr-w.

i try to chmod 777 /mnt/storage and i get an error saying changing permission is not permitted (0777 requested, 0755 actual)

so i guess my question is, how the heck do i change permissions so i can write to this drive?

distribution is RH8

thanks, any help is appreciated!!
 
Old 10-21-2002, 06:44 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
tried setting the dir permissions without it being mounted?
 
Old 10-21-2002, 07:01 PM   #3
zovres
Member
 
Registered: Sep 2002
Posts: 184

Rep: Reputation: 30
Good idea, worth a try !
 
Old 10-21-2002, 07:11 PM   #4
groovin
Member
 
Registered: Oct 2002
Distribution: RH 8
Posts: 83

Original Poster
Rep: Reputation: 15
yes, i can change permissions to drwxrwxrwx for /mnt/storage before mount, but then i mount with mount -t vfat /dev/hda5 /mnt/storage and it sets the permissions back to drwxr-xr-x
 
Old 10-21-2002, 07:11 PM   #5
zovres
Member
 
Registered: Sep 2002
Posts: 184

Rep: Reputation: 30
It doesnt work :|
 
Old 10-21-2002, 07:22 PM   #6
groovin
Member
 
Registered: Oct 2002
Distribution: RH 8
Posts: 83

Original Poster
Rep: Reputation: 15
zovres r u having the same problem?
 
Old 10-21-2002, 07:31 PM   #7
zovres
Member
 
Registered: Sep 2002
Posts: 184

Rep: Reputation: 30
yep
 
Old 10-30-2002, 08:06 PM   #8
quzax
LQ Newbie
 
Registered: Oct 2002
Posts: 5

Rep: Reputation: 0
Hey guys I was having the same problem, I read around a bit & found a solution (well almost).

In your /etc/fstab do an entry like:

/dev/hda1 /mnt/Win_C vfat defaults,gid=501,umask=002 0 0

where
"/dev/hda1" is the partition name
"/mnt/Win_C" is your mount point
"vfat" is the partition type
"defaults,gid=501,umask=002" are your options
"0" is I don't remember what (do man fstab to find out)
"0" is the order in which to mount the drive.

in your options "gid" needs to be set to the group # you want to have access to the drive. And the "umask" modifies the permissions (002 will give you 775 permissions)

That should do it, you do have to restart.

I say it mostly works because some folders are my windows partition are still read only but I haven't figured out why.

quzax
 
Old 10-31-2002, 03:38 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,429

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
My fstab that allows any user to write is:
/dev/hda5 /mnt/storage vfat auto,user,umask=000 0 0
 
Old 10-31-2002, 07:31 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Actually I don't think you have to "restart". This is linux after all

You would have to remount the drives, and to do that:
mount -a -o remount

This will remount the drives, with the changes you have made to fstab.

Cool
 
Old 11-02-2002, 08:15 PM   #11
MgF
LQ Newbie
 
Registered: Nov 2002
Location: Central QLD Australia
Distribution: RH7.3
Posts: 13

Rep: Reputation: 0
/dev/hda5 /mnt/storage vfat user,gid=99,uid=99 0 0

gid=99 99 is the group ID for "nobody" so u can change that to any group ID that u want

uid=99 99 is the user ID for "nobody" so u can change that to any user ID that u want

Michael
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change permissions on mounted partition OlRoy Linux - General 2 09-24-2004 03:22 AM
How to change permissions of a mounted partition seran Linux - General 2 08-13-2004 02:43 AM
How do I change permissions for my windows partition? cereal83 Slackware 9 07-15-2004 03:06 PM
Can't change permissions for mounted windows partition shara Linux - Newbie 6 03-24-2004 07:31 PM
Windows partition - cannot change permissions elitecodex Linux - Newbie 1 02-02-2004 06:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration