LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cant change permissions on a mounted windows partition (https://www.linuxquestions.org/questions/linux-newbie-8/cant-change-permissions-on-a-mounted-windows-partition-33388/)

groovin 10-21-2002 06:43 PM

cant change permissions on a mounted windows partition
 
ok, heres the deal... i have a windows partition i mount in /etc/fstab with the following line:

/dev/hda5 /mnt/storage vfat auto,owner,users,umask=000 0 0

it mounts fine, but when i log in as a user, i cant write to it. i get an access denied. ls -l /mnt shows that the dir storage has permissions drwxr-wr-w.

i try to chmod 777 /mnt/storage and i get an error saying changing permission is not permitted (0777 requested, 0755 actual)

so i guess my question is, how the heck do i change permissions so i can write to this drive?

distribution is RH8

thanks, any help is appreciated!!

acid_kewpie 10-21-2002 06:44 PM

tried setting the dir permissions without it being mounted?

zovres 10-21-2002 07:01 PM

Good idea, worth a try !

groovin 10-21-2002 07:11 PM

yes, i can change permissions to drwxrwxrwx for /mnt/storage before mount, but then i mount with mount -t vfat /dev/hda5 /mnt/storage and it sets the permissions back to drwxr-xr-x

zovres 10-21-2002 07:11 PM

It doesnt work :|

groovin 10-21-2002 07:22 PM

zovres r u having the same problem?

zovres 10-21-2002 07:31 PM

yep

quzax 10-30-2002 08:06 PM

Hey guys I was having the same problem, I read around a bit & found a solution (well almost).

In your /etc/fstab do an entry like:

/dev/hda1 /mnt/Win_C vfat defaults,gid=501,umask=002 0 0

where
"/dev/hda1" is the partition name
"/mnt/Win_C" is your mount point
"vfat" is the partition type
"defaults,gid=501,umask=002" are your options
"0" is I don't remember what (do man fstab to find out)
"0" is the order in which to mount the drive.

in your options "gid" needs to be set to the group # you want to have access to the drive. And the "umask" modifies the permissions (002 will give you 775 permissions)

That should do it, you do have to restart.

I say it mostly works because some folders are my windows partition are still read only but I haven't figured out why.

quzax

michaelk 10-31-2002 03:38 PM

My fstab that allows any user to write is:
/dev/hda5 /mnt/storage vfat auto,user,umask=000 0 0

MasterC 10-31-2002 07:31 PM

Actually I don't think you have to "restart". This is linux after all ;)

You would have to remount the drives, and to do that:
mount -a -o remount

This will remount the drives, with the changes you have made to fstab.

Cool

MgF 11-02-2002 08:15 PM

/dev/hda5 /mnt/storage vfat user,gid=99,uid=99 0 0

gid=99 99 is the group ID for "nobody" so u can change that to any group ID that u want

uid=99 99 is the user ID for "nobody" so u can change that to any user ID that u want

Michael


All times are GMT -5. The time now is 07:44 AM.