LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-28-2003, 01:28 PM   #1
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
smbmnt must be installed suid root


Hi everyone,

ok, i've been trying these two programs LineNeighborhood and xSMbrowser. Now, samba is running just fine, as root I can mount shares and everything, but when I use these two smb browsers or if I try to mount share as a user I get errors. To make the story short, this is the error message that the two gui smb browsers give me:

smbmnt must be installed suid root for direct user mounts (1000,1000)
smbmnt failed: 1

Now I've try looking info on what the %&^% is the suid stuff, but I don't really understand any of it (man seuid). Heck I'm not really shure if that is the right way to go.
Now what I wanna be able to do, is use LineNeighborhood or xSMBrowser and be able to mount shares into my user directory without having to become root. Is it possible? I guess yes, but I don't know how to do it.
Anyways, if anyone can please help me it will be greatly appreciated.

Thanks
Figa



ps:
Just in case, my distro is Slackware 8.1.
 
Old 02-28-2003, 01:41 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
chmod u+s /path/to/whatever
 
Old 02-28-2003, 02:21 PM   #3
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Original Poster
Rep: Reputation: 30
rshaw, thanks for the quick response but I tried the suggestion

~$ chmod u+s share
~$

and LineNeighborhood still gives me the same error:
"smbmnt must be installed suid root for direct user mounts (1000,1000)
smbmnt failed: 1"

Thaks
Figa
 
Old 02-28-2003, 02:43 PM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
you chmod'ed 'share' you haven't chmod'ed /path/to/smbmnt
 
Old 02-28-2003, 03:18 PM   #5
TruckStuff
Member
 
Registered: Apr 2002
Posts: 498

Rep: Reputation: 30
And just an FYI, SUID means that whenever the script is run, it runs as the script's owner, rather than the standard behavior of running as whoever is trying to run the script. Be careful how you use SUID as, obviously, it can open big security holes on files owned by root.
 
Old 03-01-2003, 12:48 PM   #6
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Original Poster
Rep: Reputation: 30
Quote:
you chmod'ed 'share' you haven't chmod'ed /path/to/smbmnt
I think I may have explain this the wrong way. What I mean is that I created dir called "share" in my /home/figa folder. So I did a chmod u+s /home/figa/share. I didn't actally tried to chmo'ed the dir being shared by the other computer. Now, just to be shure, is this what you meant with <chmod u+s /path/to/whatever>?
Also, just out of curiosity, I tried "chmod +s /usr/bin/smbmount" but I soon found out that smbmount and smbumount will not run with this.

Figa
 
Old 11-05-2003, 08:41 PM   #7
Rico16135
Member
 
Registered: Aug 2003
Location: Texas, USA
Distribution: Slackware 9.1, SuSE 9.1
Posts: 245

Rep: Reputation: 30
what about smbmnt? that is the file that linneighborhood calles on is it not????
 
Old 06-08-2004, 02:39 PM   #8
pandasuit
Member
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
Quote:
Originally posted by rshaw
chmod u+s /path/to/whatever
I am having the same problem as figadiablo. If smbmount is not suid root then it tells me it needs to be:

> smbmount //compy386/home ./tmp/

smbmnt must be installed suid root for direct user mounts (500,500)
smbmnt failed: 1

and if it is then it tells me it cant be:

# chmod u+s ./smbmount
> smbmount //compy386/home ./tmp/

libsmb based programs must *NOT* be setuid root.
8926: Connection to compy386 failed
SMB connection failed

my solution so far has been to use the "mount as root" option in LinNeighborhood but I find this annoying (especially since I dont want to use LinNeighborhood).

I read in another thread that if you chmod 700 smbmount then it will work fine. The problem with that is then I get a permissions error as my user no longer has exec permission on smbmount.

Any help in this area would be great! I am hoping it is just that I am doing it wrong...not a SuSE specific issue. Maybe upgrading to samba 3 would help....


Relevant info:
SuSE 9.0
Samba 2.2.8a-107
 
Old 06-17-2004, 11:29 PM   #9
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Original Poster
Rep: Reputation: 30
try
chmod u+s smbmnt
instead of smbmount

/* Fixed the typo */

Last edited by figadiablo; 06-25-2004 at 02:52 PM.
 
Old 06-18-2004, 03:15 AM   #10
pandasuit
Member
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
Perfect

Perfect! Thank you! That works great. Although I used "u+s". Maybe a typo on your part.
 
Old 06-25-2004, 02:52 PM   #11
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Original Poster
Rep: Reputation: 30
Yes a typo. Glad that it worked out.

Keep using Linux.

Figa
 
Old 08-08-2004, 02:55 AM   #12
Ninaw
Member
 
Registered: Jun 2004
Location: QC, Philippines
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
A more secure way?

Is there a more secure way than this?
 
Old 08-08-2004, 03:18 PM   #13
r0b0
Member
 
Registered: Aug 2004
Location: Europe
Posts: 608

Rep: Reputation: 50
Quote:
Is there a more secure way than this?
Of course. Stop using samba altogether. Use scp or WebDAV.
R.
 
Old 08-30-2004, 08:37 PM   #14
windoze killa
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: FC2
Posts: 81

Rep: Reputation: 15
Quote:
Originally posted by rshaw
chmod u+s /path/to/whatever
I know I have come in on the end of this thread but I feel I must chastise the "moderator". This site i believe is where you come for help. The above quoted statement would mean absolutely nothing to a newbie as can be seen from your follow up comment below.

Quote:
you chmod'ed 'share' you haven't chmod'ed /path/to/smbmnt
Maybe if you had used the word "smbmnt" instead of "whatever" in the first place it may have been more useful.
 
Old 11-13-2004, 02:13 PM   #15
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
Quote:
Originally posted by figadiablo
try
chmod u+s smbmnt
instead of smbmount

/* Fixed the typo */
not working as either:

Code:
[root@raylap root]# chmod u+s smbmnt
chmod: failed to get attributes of `smbmnt': No such file or directory
[root@raylap root]# chmod u+s smbmount
chmod: failed to get attributes of `smbmount': No such file or directory
i am getting the same error as the OP when i try to mount a windows share using smbfs installed on RH9 laptop.

Code:
[ray@raylap ray]$ smbmount //192.168.2.100/movies /home/ray/tmp
Unknown parameter encountered: "ssl CA certFile"
Ignoring unknown parameter "ssl CA certFile"
7475: session request to 192.168.2.100 failed (Called name not present)
7475: session request to 192 failed (Called name not present)
so something is wrong. in Debian i just apt-get install smbclient and smbfs and away i went. RH9 is giving me these fits.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to put artswrapper suid root? jayhel Slackware 2 09-19-2005 08:43 AM
insecurity in suid-to-root prabhatsoni Linux - Security 5 11-13-2004 03:57 AM
Only root can do that! (but i made it SUID root ?) qwijibow Linux - General 4 07-07-2004 10:51 AM
xterm installs suid root? infamous41md Linux - Security 2 01-18-2004 12:08 PM
smbmnt - setuid root harperonline Linux - General 1 11-16-2003 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration