LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-17-2004, 09:43 AM   #16
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45

still looking for some help here please.
 
Old 11-17-2004, 01:48 PM   #17
pandasuit
Member
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
You are going to need to provide the path to smbmnt when you do a chmod. It will not look it up in the path as far as I know. His command works because he was running it from the directory where smbmnt is.

When you run the command smbmnt on the command line it looks it up in the path...but when you are using chmod it just considers it a file and doesnt try looking it up in the path.

Try that. This is based on my experience so I may not be exactly right. I am not sure if it is possible to have it look it up in the path or if some systems are setup to do that already. In my experience it doesnt.

So do this:

chmod u+s /path_to_smbmnt/smbmnt

Where path_to_smbmnt is the full path to the file.

Good luck.
 
Old 11-18-2004, 01:34 AM   #18
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
ok we are getting closer... i was able to chmod u+s /usr/bin/smbmnt and not get an error. now mind you i did that as root... i hope that was correct.

now when i try to mount im still getting an error:

Code:
[ray2@raylap ray2]$ mkdir /home/ray2/tmp
[ray2@raylap ray2]$ smbmnt //192.168.2.100/movies /home/ray2/tmp/
Failed to find real path for mount point
[ray2@raylap ray2]$ smbmnt //192.168.2.100/Movies /home/ray2/tmp/
Failed to find real path for mount point
tried it with cap on M as that is exactly how it is on the XP box...

still dont get why in Debian i can do this with zero issues, yet RH9 gives all kinds of fits for something as simple as mounting a share.

more help would be great. id love to be able to get my laptop to connect to my XP box instead of being forced to use winSCP all the time.
 
Old 11-18-2004, 02:59 AM   #19
urzumph
Member
 
Registered: Jan 2004
Location: Australia
Distribution: Debian
Posts: 168

Rep: Reputation: 30
That error message sounds strange. was the mount point (in your case, /home/ray2/tmp/) created correctly? Try removing the trailing slash from the mount point (/home/ray2/tmp)
 
Old 11-18-2004, 05:03 PM   #20
pandasuit
Member
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
Quote:
Originally posted by Lleb_KCir
now mind you i did that as root... i hope that was correct.
Yes, you would need to have been root to change permissions on smbmnt.


Quote:
Originally posted by urzumph
That error message sounds strange. was the mount point (in your case, /home/ray2/tmp/) created correctly? Try removing the trailing slash from the mount point (/home/ray2/tmp)
Yes, strange.

Even though smbmnt is the file that needs to be +s I seem to remember that you should use smbmount instead of smbmnt directly (smbmount uses smbmnt).

So try:
smbmount //192.168.2.100/Movies /home/ray2/tmp


I am not too familiar with mounting samba shares on the command line as I usually use a graphical prog.
 
Old 11-19-2004, 11:06 AM   #21
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
well 1 step forward, 2 steps back it seems with RH9 and smbmount/smbmnt

Code:
[ray2@raylap ray]$ smbmount //192.168.2.100/Movies /home/ray2/tmp
Unknown parameter encountered: "ssl CA certFile"
Ignoring unknown parameter "ssl CA certFile"
2090: session request to 192.168.2.100 failed (Called name not present)
2090: session request to 192 failed (Called name not present)
Password:
2090: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed
[ray2@raylap ray]$ su -
Password:
[root@raylap root]# smbmount //192.168.2.100/Movies /home/ray2/tmp
Unknown parameter encountered: "ssl CA certFile"
Ignoring unknown parameter "ssl CA certFile"
2143: session request to 192.168.2.100 failed (Called name not present)
2143: session request to 192 failed (Called name not present)
Password:
2143: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed
first attempt as user, second 2 as root. in both cases getting the same error.
 
Old 11-19-2004, 11:23 AM   #22
pandasuit
Member
 
Registered: Jul 2003
Location: Canada
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
I honestly have no idea what is going wrong. Sorry I couldnt be of more help.

In a quick google search I didnt find much other than a reference to commenting some ssl related lines from your samba config file. I would suggest searching around a bit more. Maybe ask on a red hat specific forum.
 
Old 12-08-2004, 10:10 AM   #23
ikenyoung
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Please try this (by root):

#smbmount //remote-folder local-folder -o uid=your-username

this can change the permission by changing the uid of the mounted folder.

good luck.
 
Old 12-16-2004, 03:05 PM   #24
tek_lp
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
scratch this, was replying to an old cache of the forum. sorry...


--------------------------------


notice where you're running the command from:

[root@raylap root]# chmod u+s smbmnt

that's telling chmod to go to work on the smbmnt file in the current directory, which in this case looks like /root. smbmnt almost certainly doesn't live there. try /usr/bin/smbmnt or from / do a "find . -name smbmnt"

hope this helps.

taylor

Last edited by tek_lp; 12-16-2004 at 03:06 PM.
 
Old 12-31-2004, 12:24 PM   #25
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
have you check to see what the share name is on the xp box? the way you stated below
Quote:
Originally posted by Lleb_KCir
tried it with cap on M as that is exactly how it is on the XP box...
it sounds like you are trying to mount a file in the windows filesystem.

incase you don't know:
go into the windows puter and go to the folder you want to share. make sure that there is a hand on the bottom of the folder icon. if not right click on it and chose "properties"
chose the sharing tab and click the radio button to "share this folder" and then look for a listing for "share name" or something like that. then put in Movies (or what ever you want to name the share and what you will be putting in the smbmount command) from this point go back to your linux box and try the command again.

if you know all of this info i am sorry to bore you and to let you know.. it is not to belittle your knowledge. sometimes the simple things get overlooked.
 
Old 03-07-2005, 07:44 PM   #26
Twisted385
LQ Newbie
 
Registered: Feb 2005
Location: White Marsh, Maryland
Distribution: Fedora
Posts: 18

Rep: Reputation: 0
I know I am bringing up an older post, but I was just following the steps of this message and am getting further than I did at my start. I was getting the same error that started this message (except in the parenthese was 500, 500). I did the chmod and was able to mount the share now without any error. The share is mounted to /home/myhomedirectory/mnt/share When I cd to share and then do ls I get a message stating "ls: .: Permission denied" When I go back to the mnt directory and do ls -l this is what I see:

total 0
?--------- ? ? ? ? ? share
I can also tell you I am using the KDE desktop, and when I do this from the terminal window, the share directory is flashing red. Can anyone explain what is wrong? The share I am connecting to is a Windows 2003 Server black ice is also running. The ip and hostname are both allowed on the server and am seeing no errors in black ice (anymore).
 
Old 03-08-2005, 08:54 PM   #27
Twisted385
LQ Newbie
 
Registered: Feb 2005
Location: White Marsh, Maryland
Distribution: Fedora
Posts: 18

Rep: Reputation: 0
any thoughts???
 
Old 03-08-2005, 09:07 PM   #28
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
did you overlook including the rw in the fstab options for the mount? that is the onlything i can think of... to tell you the truth i am having my own smbmount probs. maybe you can take a look and help?

http://www.linuxquestions.org/questi...hreadid=294576
 
Old 03-09-2005, 09:16 AM   #29
Twisted385
LQ Newbie
 
Registered: Feb 2005
Location: White Marsh, Maryland
Distribution: Fedora
Posts: 18

Rep: Reputation: 0
I am not even to the point of trying to set up a persistent connection, I am just trying to do this at the command prompt. I get no errors know (after dealing with the suid issue). I even trying accessing it as root and still get a permission denied message. Everyone has read access to the share so I do not know why I cant at least see whats in the directory???
 
Old 08-09-2007, 11:12 PM   #30
Sister_Clamp
LQ Newbie
 
Registered: Aug 2006
Distribution: Kubunbu 6.06, openSuSE 10.1 [, DSL]
Posts: 7

Rep: Reputation: 0
I have to agree with the earlier poster than the "experienced" Linux users tend towards a patronising attitude more than is useful. I've stuck with Linux despite them, not because of them. No explanations as to why you should use one option over another, ambiguous command fragments which implicitly accuse you of being an idiot if you can't immediately inuit what they mean, no references to any other doco that a newbie can look up, and snarky remarks about how "the doco is there" or "you should take the time", as if we have nothing better to do than spend 8 hours a day trawling through the internet when we have jobs of our own to work and children to look after. Next they'll be saying that you should only use Linux if you're jobless and friendless.

In any case, if there's anyone who's come to this thread looking for answers, this is what worked for me in Kubuntu, although heaven knows WHY!

1) I installed Smb4K, "the SMB/CIFS Share Browser" via Adept

2) I did a "whereis smbmnt" and found that smbmnt lives in /usr/bin/smbmnt

3) I typed in the following: sudo chmod u+s /usr/bin/smbmnt

4) Following on from previous posts, I then typed:

$ mkdir /home/sisterclamp/music
$ smbmnt //999.999.9.999/share /home/sisterclamp/music

where 999.999.9.999 is the IP address of my network share drive

And got the following message:

Failed to find real path for mount point //999.999.9.999/share: No such file or directory

5) Oh crap! So I went to Smb4K anyway and when I clicked on the share drive, it worked!!

A process of elimination tells me that only Steps up to 3 are needed. Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to put artswrapper suid root? jayhel Slackware 2 09-19-2005 08:43 AM
insecurity in suid-to-root prabhatsoni Linux - Security 5 11-13-2004 03:57 AM
Only root can do that! (but i made it SUID root ?) qwijibow Linux - General 4 07-07-2004 10:51 AM
xterm installs suid root? infamous41md Linux - Security 2 01-18-2004 12:08 PM
smbmnt - setuid root harperonline Linux - General 1 11-16-2003 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration