Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 02-12-2003, 07:52 AM   #1
Registered: Feb 2003
Distribution: Redhat
Posts: 30

Rep: Reputation: 15
Security Level just can't be changed in redhat linux...

Hi !
I use redhat linux 8 to connect 2 pcs using realtek ethernet cards. I tried to connect to each computer using the smbclient command but it juz won't work. An error message said that my connection is refused.

After using the 'ps aux | grep smb' command,the output was: ocy 1113 0.0 0.1 3536 628 pts/1 S 20:52 0:00 grep smb to test the smb.conf file. Does the output mean that my smb.conf is correct ?
I also used the ping command and the output seems to indicate connectivity btwn the 2 pcs.

Does my refused connections mean that the firewall rules is too strict ? Another help reply from the net told me that my firewall level is too high.
Hence,I went to redhat desktop and opened the security level program under the systems settings menu.

The default security level is high. So I changed the security level to 'no firewall'. When i clicked the ok button, a msg ' Clicking the yes button will set the security level of the system and override any existing firewall configuration. Are you sure you want to do this?' I clicked yes and exited the prog. However, when i opened the security level program again, the security level is still high.....none of the changes I made are in place. I tried resetting the security level again and got the same mesage but still the security level is still high. I even tried the medium security level or customizing the high level to allow my eth0 card to be trusted but after exiting the prog and returning to it, the security level is always high with no customizations allowed.

I tried the redhat-config-securitylevel command but the same GUI program popped up and the same thing happened...the security level is always set to high no matter what changes i have made.

Do you know how to permanently change the firewall setting in redhat linux 8 ? And does the error message of refused connection mean that my firewall setting is too strict ? Please reply quickly if you can....thanks!! :wink:
Old 02-12-2003, 12:38 PM   #2
Registered: Jan 2003
Location: Finland
Distribution: ElementaryOS Freya as main, every other ubuntu-based as testing
Posts: 124

Rep: Reputation: 15
Well, I personally don't know so much about networking problems (only dialup possible for me...),
but I assume that the problem just *might* go away by putting the *other* computer's IP number into /etc/hosts.allow, and restart the network services.
I mean, *I assume*, I'm not sure... (a-network-newbie..)
It doesn't hurt to try.

Never trust an OS you don't have the sources for...
Registered Linux-user #303866.
Old 02-12-2003, 03:52 PM   #3
LQ Newbie
Registered: Feb 2003
Location: Georgia, USA
Distribution: RedHat 7.3, 8.0
Posts: 2

Rep: Reputation: 0
To turn off all firewalling on your linux machine, you can stop the services:

service ipchains stop (setup when you use the security interface)
service iptables stop

They will remain stopped until you reboot the machine. If you want them to stay stopped, run:

chkconfig --level 123456 ipchains off
chkconfig --level 123456 iptables off

In terms of setting up Samba, that can be more complex. The simplest answer would be to point you to some Samba resources:

Red Hat Samba resource:


Good Luck!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
how do you change the security level? chr3681 Linux - Newbie 0 11-02-2004 02:52 PM
security level legodude Mandriva 0 10-30-2004 05:00 PM
security level problems tscoker79 Linux - Software 1 04-06-2004 10:40 PM
security level fawkes Linux - Newbie 0 02-29-2004 05:40 PM
Redhat 8.0 security level israel Linux - Software 1 03-22-2003 05:46 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:30 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration