LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-06-2004, 05:32 PM   #16
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168

at first glance the only thing isee out of the ordinary is a line for your netbios name. under global settings under your workgroup entry add

netbios name = yournetbiosname

other than that i have some ?'s. let's start at the begining. can you ping from one box to the other, and vice/versa, successfully? if so, what users have you permitted to access the windows shares? have you created samba users? have you restarted the samba daemons? are you running a firewall on either box? can you see either workgroup, from either box, or are the boxes on the same workgroup? that's all a bit to chew on, but, these are some of the most common problems i've seen w/setting up the samba. possibly your answer is in one of those ?'s. i recommend turing of all firewalls, until you get it working.
good luck.
 
Old 04-06-2004, 10:13 PM   #17
robojerk
Member
 
Registered: Jan 2003
Posts: 35

Rep: Reputation: 15
stupid samba

I'm not quite sure why there isn't a wizard to create a home network. how many people have routers with DHCP networks.. the only thing one would need to inout is workgroup....

I'm having problems with my samba setup.. winXP can see my computer but not connect to it. What is especially is that it see my PC twice.
#1 Rob's PC(Rob)
#2 Rob's PC(ROB_LINUX)

I have a simple home network, all Windows boxes except for this machine.. The network is secure so I really prefer to have people be able to connect w/o entering login info...

here's my smb.conf
[global]
workgroup = CREST101
netbios name = ROB_LINUX
netbios aliases = Rob
server string = Rob's PC
security = SHARE
map to guest = Bad User
null passwords = Yes
time server = Yes
socket options = S0_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
os level = 2
ldap ssl = no
veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0640
directory mask = 0750
browseable = No

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

[robojerk]
comment = default
path = /home/robojerk
read only = No
guest ok = Yes
 
Old 04-07-2004, 07:51 AM   #18
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Hello PEACEDOG,
I changed the workgroup name to match the workgroup name on the W2K machine. I altered /etc/HOSTNAME from linux.local to Duquesne.WORKGROUP. In smb.conf I then added the line netbios name = Duquesne. I am the only one using the linux box and have set myself up as a poweruser on the W2k machine. Same login name and password on both machines. I have not added any samba users. ifconfig shows a DHCP assigned IP on the linux machine. I can ping that IP from the W2k box. I can't ping the static IP of the W2k box from linux. I have a kde applet called local networks. It always says it can not find a workgroup. I've started lisa and it still gives the error. How do you restart samba, I just restarted the machine. How do you (and should I) start the lisa at boot time? The route command shows an IP of 192.168.0.0 which I can ping on the linux machine. It shows the IP for the W2k machine as the default gateway. The IP of the linux is 192.168.0.205. Thanks again for the help.
Glenn

Last edited by glennc; 04-07-2004 at 07:54 AM.
 
Old 04-07-2004, 11:43 AM   #19
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
if you can't ping the w2k box, your not going to share anything. do you have a firewall running on the windows machine? if so shut it down. as i had stated in an earlier post, one step at a time. we needto ensure the boxes can communicate first. once we get them pinging back and forth, then we can work on the file sharing, and everything else, but the first step is getting the boxes to talk.
 
Old 04-07-2004, 12:26 PM   #20
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
PEACEDOG,
Yep that did it. I was running norton security. Pings 0% packet loss. Ye ha!
Glenn
 
Old 04-07-2004, 12:29 PM   #21
crunnluadh
LQ Newbie
 
Registered: Apr 2004
Location: Sacramento, CA
Distribution: RHEL 3, Fedora, Slackware (all)
Posts: 7

Rep: Reputation: 1
robojerk,

The reason you see two PC's is because of the following:

netbios name = ROB_LINUX
netbios aliases = Rob

Use one or the other, nothing is wrong with using both. You will see two machine names in your Network though.

Also check your "security = SHARE" part. You might want to set it to "security = user" and then create the appropriate accounts in smbpasswd. Here's a link explaining Samba security levels a bit more:

http://samba.linuxbe.org/en/samba/learn/security.html

Last edited by crunnluadh; 04-07-2004 at 12:33 PM.
 
Old 04-07-2004, 12:32 PM   #22
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
great, the boxes are now talking. keep in mind you'll have to make some provision for this once everything is working. w/that said, you need to add samba users.

smbpasswd -a <username>

use the same username and password you already have. the share on the windows machine must also allow this username, and password. once you've added the samba user/users, then you'll need to restart the daemons.

smbd restart
nmbd restart

once this is done, you may or may not have to restart windows. if you do, be aware of the firewall.
 
Old 04-07-2004, 12:52 PM   #23
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
PEACEDOG,
Using the smbpasswd -a <username (mine)>, I received an unknown parameter encountered "netbios" and Ignoring unknown parameter "netbios", it then prompted for SMB password which I entered and got an Unable to open passdb database and user added. On the smbd and nmbd restart I got bash: commands not found. I'm in as a user, using su.
Glenn
 
Old 04-07-2004, 01:28 PM   #24
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
???PEACEDOG
I configured Norton to allow the IP and can still ping the linux machine.
On the linux machine, in the local network applet it showed my workgroup,
W2k machine and then asked for my login. It would not accept my password. I rebooted both machines and now the linux machine shows the workgroup folder but gives an unknown libsmbclient fault, and won't show the machine. So close and they pulled me back in.....
Glenn
 
Old 04-07-2004, 05:52 PM   #25
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
ok configuring norton is what i was refering to earlier, when speaking about making provisions for the network. a firewall doesn't see a local area network any different than the internet or wan unless you specify it to. you do have to get the usernames and passwords correct though, as linux and w2k are case sensitive. i feel certain that if the workgroups are showing up, but, you can't connect to the shares, it's a user problem. why not check your windows shares, and the permissions on the same. you could even try setting them to allow the guest account, just be sure to configure a password for it. then when asked about the username and password, enter Guest, and the password you created. for the restarts instead of

smbd restart
nmbd restart

try

service smbd stop
service nmbd stop

service smbd start
service nmbd start

i'm not at all familiar w/suse, so the commands may be a little different, have a look at your help section for samba, and the documentation that comes w/suse to get the correct set of commands. the other thing to try would be instead of

su

try

su -

it may be a path problem. post any success/failure. again, check the permissions on the shares, i can't stress that enough.
good luck.
 
Old 04-08-2004, 08:06 AM   #26
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Hello PEACEDOG,
I've found out that I can only access my W2k box with the applet, logged in as root. I added Administrator and another smbuser. When it asks for user and password, I can use any of the above users. My W2k box shows the TEMP directory as shared, and I also made it a share as that user, but when logged into linux, I see SHARE= on the smb login, and it will not let me log in? I also can not see the linux box from Network Neighborhood. Whats next? And again thanks.
Glenn
 
Old 04-08-2004, 10:43 AM   #27
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Hello again PEACEDOG,
I figured out the permissions on the W2k box and my user can see the folder I have shared under the computername under the workgroup. Still can't see the linux machine from the W2k. Oh the linux also sees the printer on the W2k. What's next ??????????????.............................
Glenn
 
Old 04-08-2004, 11:35 AM   #28
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
can you see the linux machine from windows w/out the firewall? have you made any changes to your smb.conf? now that you see the printer have you tried configuring cups?
 
Old 04-08-2004, 01:02 PM   #29
glennc
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
PEACEDOG,
With the firewalls off, I can't see the linux machine. Apparently the linux machine defaulted to no firewall, as when I wen't to set it up with the wizard, I lost the ability to see the W2k machine, so I turned it off. I have not altered the smb.conf except as previouly mentioned.
Glenn

Last edited by glennc; 04-08-2004 at 01:05 PM.
 
Old 04-08-2004, 04:28 PM   #30
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
let's try creating a share for windows to look at.

su -
password

cd /home/youruser'shome

mkdir share

exit

once this is done add this to the smb.conf

[share]
comment = share
path = /home/youruser'shome/share
public = yes
browsable = yes
writeable = yes

save, and exit. once this is done you'll need to restart the daemons. you'll probably also have to restart windows. let me know, if it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 05:54 PM
sendmail setup newbie complus Linux - Software 4 11-12-2003 10:07 PM
interesting newbie setup macewan Linux - Newbie 5 05-02-2003 02:23 PM
NEWBIE wants to setup LAN lhoff Linux - Networking 12 03-22-2002 04:21 PM
newbie ipchains setup HELP skittles Linux - Security 5 09-13-2001 03:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration