LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-18-2004, 03:10 AM   #16
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16

Hmmm, that's odd. Try to type this in a terminal window in your fedora box:
Code:
cat /etc/sysconfig/network
 
Old 06-18-2004, 03:14 AM   #17
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Keep in mind I am a linux newbie and dont even know what this command does.
but I input
cat /etc/sysconfig/network
and got back
NETWORKING=yes
HOSTNAME=ATOMICMAIL
GATEWAY=10.1.0.4
[root@ATOMICMAIL root]#

Now, I rebooted the linux box 2 min ago, and need to check if the webmin starts automatically
I did manually start samba though from the command prompt as soon as I logged back on.
 
Old 06-18-2004, 03:18 AM   #18
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
also I made the changes you perscribed, now my smb.conf looks like this.
but after I restarted samba and tried again on the xp laptop, I got the same
error.

________________________
[global]
Netbios name = SMBSERVER
server string = ITSDABOMBMON
workgroup = JAEB.NET
security = user
encrypt passwords = Yes
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
wins support = Yes
smb passwd file = /etc/samba/smbpasswd
logon home = \\netbiosname\%U
passwd program = /usr/bin/passwd %u
logon path = \\SMBSERVER\profiles\%U


;admin users = joncolby




[homes]
comment = Home Directories
browseable = No
writable = yes
valid users = %S
read only = no
create mode = 0600
directory mode = 0700
login home = \\SMBSERVER\%U



[tmp]
comment = Temporary File Location
path = /tmp
read only = no
public = yes

[jon]
create mode = 0600
directory mode = 0700
path = /home/samba/jon/
profile acls = yes
read only = no
writable = yes
valid users = jon daffy
write list = jon daffy

[daffy]
path=/home/daffy
comment = welcome
public = No
create mask = 0640
directory mask = 0750
writeable = Yes
valid users = jon daffy
write list = jon daffy
___________________________________________________---
 
Old 06-18-2004, 03:27 AM   #19
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
i am going to sleep now, be back in 6-7 hours

and at it agiain all day tomorrow.
 
Old 06-18-2004, 03:49 AM   #20
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
OK, looks like that you may need to re-install your fedora.

Before this, does your fedora have internet access? Do you have handy the DNS numbers of your ISP? How do you connect to internet?

In the fedora instalation, make sure that don't select any of the samba packages. Download the latest rpm of samba (found in www.samba.org). Copy the webmin.rpm and the samba.rpm files in your fedora box. Install webmin first. After this, change your subnet mask of your xp box to 255.255.255.0 and then try to connect to your ipcop. Then try to connect to it from your xp box. During the fedora installation (network setup) make sure that you don't set up a firewall! Your hostname should be a name like "fedorabox", your IP should be 10.1.0.112, your subnet musk should be 255.255.255.0 and your gateway and dns should be those numbers your ISP have provided you. If you don't know what this is let me know

If you give me a couple of minutes I could replicate the instalation in a box. I 'll get back to you.

Last edited by dtournas; 06-18-2004 at 03:51 AM.
 
Old 06-18-2004, 04:36 AM   #21
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Just a thought but when you add the samba users you need to use 'smbpasswd -a username' not 'smbpasswd username'. You can check whether you have added samba users successfully by opening /etc/samba/smbpasswd (you need to be root) and seeing if all your users are listed in it - you don't edit this file by the way always use smbpasswd to change it.
 
Old 06-18-2004, 06:54 AM   #22
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
Originally posted by andrewdodsworth
Just a thought but when you add the samba users you need to use 'smbpasswd -a username' not 'smbpasswd username'.
Actually, you need to do smbpasswd -a -e <username> <password> -- the -a switch adds users, but the -e switch enables them.
 
Old 06-18-2004, 07:36 AM   #23
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
Quote:
Originally posted by motub
Actually, you need to do smbpasswd -a -e <username> <password> -- the -a switch adds users, but the -e switch enables them.
Damn, you are right guys! Jon, try to:
Code:
smbpasswd -a -e jon
and try to connect again.
 
Old 06-18-2004, 08:53 AM   #24
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Quote:
Originally posted by motub
Actually, you need to do smbpasswd -a -e <username> <password> -- the -a switch adds users, but the -e switch enables them.
From 'man smbpasswd' - root user options

-a This option specifies that the username following
should be added to the local smbpasswd file, with
the new password typed. This option is ignored if
the username specified already exists in the smb_
passwd file and it is treated like a regular change
password command. Note that the user to be added
must already exist in the system password file
(usually /etc/passwd) else the request to add the
user will fail.

-d This option specifies that the username following
should be disabled in the local smbpasswd file.
This is done by writing a 'D' flag into the account
control space in the smbpasswd file. Once this is
done all attempts to authenticate via SMB using
this username will fail.

-e This option specifies that the username following
should be enabled in the local smbpasswd file, if
the account was previously disabled. If the account
was not disabled this option has no effect. Once
the account is enabled then the user will be able
to authenticate via SMB once again.

Therefore for a new user you don't need the -e switch, you only need it if you've previously used the -d switch to disable an existing user. However, as the man says it doesn't harm and in the case of an existing disabled user then -a -e will get it going again.
 
Old 06-18-2004, 09:21 AM   #25
bmcgregor3
LQ Newbie
 
Registered: Jun 2004
Location: St. Louis, MO
Distribution: SuSE 9.1
Posts: 6

Rep: Reputation: 0
Hi,

I have been reading this thread with interest as I a have the same problem with SuSE 9.1 and XP.

I just wanted to let dtournas know that the Olympic torch passed through St. Louis yesterday and wish the Summer Olympics the best

Bruce
 
Old 06-18-2004, 11:19 AM   #26
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Thumbs up

ok, Im back.
Good Morning from hawaii to you all !
The olympic torch should be passed to dtournas because he has stuck with this for 2 pages now !!!
You all Help him out where ever possible.

Ok, I have used the -a and the -e switches

Ill upload a picture here if it is needed of my directory structure if you want to look thru it

I wonder what is causing my problem ?
is there some case sensitive thing that I could have messed up ?

right now my webmin dosent work either, is there a command you know of that will get me feedback on the inux machine as to
what is happening with the network status ?
maybe something basic is not right. I run a command to disable a firewall but It dosent work, I dont think i have a firewall program / service running
on this linux box.

should I do a "clean install"
if so, can you all give me a good instruction sheet that comes from the refined knoledge of your combined experiences. ?
or maybe not that much but something close .... hehehe

-Jon
 
Old 06-18-2004, 11:38 AM   #27
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
ALSO
i have mandrake 10 official editions cd's
I could install it.
I also have suse 8.??????? all 7 cd's and the dvd aswell

the machine its going on is a compaq presario 5000
512 ram
pentium4 2.4ghz
yadi yadi yadi

its my linux learning machine.
 
Old 06-18-2004, 01:52 PM   #28
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
OK, I re installed the Fedora, Ran the updates but didNOT update to the new kernel 2.6.6-1.427
I installed the webmin and it works !!
and when I was installing fedora i did not check the box for windows file sharing because it contained Samba

Now, I have a fresh version of fedora on my computer. webmin works !
BuT !!! Check this out.
Samba is on anyway !!!!! maybe it came in with the update. ?.?.?
i click the red hat icon and go to system settings then to server settings and samba is there... BUT what is different this time is that it works. If i click on it. it asks me for root password.
I type it in and i can add users and folders and stuff.

I made a share, a folder that I created called /nfs
now, when i try to connect to it, it brings up a login window !!!
I am getting closer !!! HEHEHE
Problem is, the username is arleady filled out with Atomicmailserve\guest and windows wont let me change it.
I can type in a password though.

-Jon
 
Old 06-19-2004, 06:06 AM   #29
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
Hi jon, sorry for being out for a while. It is saturday morning in greece and I just came into a net cafe to say hi!

So, you are really getting closer! There are now two options to configure samba. The easy way and the easiest way

1st: Try the step that you add users to linux by:

useradd user1

and then

smbpasswd -a user1

be sure that in the smb.conf file you have the

security=user

parameter, and then try to connect. If this won't work, try the easiest way: webmin!! Did you like it by the way? Try from the webmin to enter the servers section and then at the bottom there is something that is called:

Samba Windows File Sharing

Well, you may want to try here for your self. You can add users, change the passwds, add or/and remove shares and all of these good stuff!

Let me know how it goes!
 
Old 06-19-2004, 11:25 AM   #30
stocks29
Member
 
Registered: Mar 2004
Distribution: Ubuntu
Posts: 52

Rep: Reputation: 15
I am having the exact same problem. I believe it to be a firewall problem. Mainly because when i stop iptables i can view the shares from my xp machine. I tried opening up the ports 137-139 & 445 for both tcp and udp on my fedora2 machine and it didnt seem to work. But apparently now it does. The only problem remaining for me is that when i click on the share xp tries to login as guest and i want to be able to login as whatever i want to the samba machine. is there any way to change that without trying to map the network drive. (I hope this post helps the thread started with their problem....but i think they will get stuck where i am now...but please help them first.)

Bob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Script] Join Fedora Core2 in Windows 2003 Domain L1nuxbug Linux - Networking 0 11-09-2004 07:26 PM
Help! I've installed Fedora Core2, now I can't boot into Windows! gashead Linux - Newbie 5 10-16-2004 02:38 PM
Fedora Core2 aclarion Fedora 2 08-01-2004 09:19 PM
X windows configuration in fedora core2 nitink Fedora - Installation 1 07-29-2004 01:34 PM
Fedora Core2, SAMBA and Windows XP pro joncolby Linux - Networking 1 06-19-2004 06:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration