LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-18-2004, 12:42 AM   #1
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Rep: Reputation: 15
Fedora Core2 SAMBA and Windows XP


Hey all. I am a newbie. Hehe, Just what the world needs.

My windows XP Pro tells me "\\Smbserver is not accessible. You might not have permission to use this network resource. Contact LINUXQUESTIONS.ORG and seek help there because microsoft made me and I am dumb like you."

this is some settings I got from off the internet (Google)
and some from a Spidertools Book.

What I am looking for is to have a couple of shared folders available on the LAN
that can be accessed from any computer but ask you for a username and password to open them. that way I can have one with my stuff in it, that only I know the username and password, and my friend has a different one that his username and password opens.
Can I even do that anymore ?
should I just use a computer with windows98 on it to "host" these folders ?
Id like to think that these great new linux cd's will give me more power than that.
-thanks for all the help.


here is my smb.conf

global]
Netbios name = SMBSERVER
server string = ITSDABOMBMON
workgroup = MONKEY.NET
security = user
encrypt passwords = Yes
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
wins support = Yes
smb passwd file = /etc/samba/smbpasswd
valid users = %S
logon home = \\netbiosname\%U
passwd program = /usr/bin/passwd %u
logon path = \\SMBSERVER\profiles\%U





[homes]
comment = Home Directories
browseable = No
writable = yes
valid users = %S
read only = no
create mode = 0600
directory mode = 0700
login home = \\SMBSERVER\%U



[tmp]
comment = Temporary File Location
path = /tmp
read only = no
public = yes

[jon]
create mode = 0600
directory mode = 0700
path = /home/samba/jon/
profile acls = yes
read only = no
writable = yes

[daffy]
path=/home/daffy
comment = welcome
public = No
create mask = 0640
directory mask = 0750
writeable = Yes
 
Old 06-18-2004, 01:35 AM   #2
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
Hi,

your configuration file looks fine. First, you might want to check if you have added users to your sambaserver. To do this, you have to add a linux user first:

Code:
useradd john
and then convert this user to samba user:

Code:
smbpasswd john
Remember that a linux password is not necessary to access the smb folders but the samba one is. Try this and let me know.

I hope I'll be able to help you out!

PS: Hey, nice message. Look like the developers in Microsoft took it seriously this time!
Quote:
"\\Smbserver is not accessible. You might not have permission to use this network resource. Contact LINUXQUESTIONS.ORG and seek help there because microsoft made me and I am dumb like you."
 
Old 06-18-2004, 02:10 AM   #3
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
I followed the instructions and added the users

I ran this
smbpasswd jon
123456
123456

smbpasswd daffy
123456
123456
then
/etc/rc.d/init.d/smb restart

testparm sees no problems in the smb.conf file either.
My windows xp machine is NOT on a domain and never has been.
it is part of the same workgroup
the user on the laptop is
daffy
and password of 123456


but to no avail.
Stupid windows says the same thing. Heheh :-)
thanks for your efforts, and hopefullly We can get this thing working.
Ive beeen preaching linux for the last 5 years, but now its time I learn how to use it.
-Jon
 
Old 06-18-2004, 02:17 AM   #4
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
OK, let me think.... hmmm Windows XP.... aha! Try this:

Open your registry editor, find this key:
Code:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
and by double clicking the
Code:
"requiresignorseal"
change it from 1 to 0.

Restart and try again. I'll be online for a few hours, so I 'll be waiting news!
 
Old 06-18-2004, 02:37 AM   #5
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
No-Go

You know, This is the most care I have ever recieved from any 'unknown' human.
I apprecieate it tremendously ! You have hit a soft spot in me. This is better than
any religeon I have ever experienced. This form should be awarded for the speed
of the responces. Its almost like instant messaging.

Why do you help people out ? Who are you ? are you alone in your house in greece
and have a desire to help those out that you meet during your form surfing ?
Are you giving back what you once recieved ? Are you a type of "tech Mechanic"

I apprecieate all you have offered me !
-Jon
 
Old 06-18-2004, 02:52 AM   #6
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
First things first!

I need you to give me your IP numbers... i.e.: if your samba server has an IP of 192.168.1.10/255.255.255.0 and your XP Boxes are 192.168.5.20/255.255.255.0 no matter hard we try, this will never be a go! To do so. try from the command line of your XP box this command:
Code:
ipconfig
and form your fedora open a terminal window and type:
Code:
ifconfig eth0
BE AWARE From your fedora box, I need ONLY your inet addr: Don't post anything else.

As long as the other questions, I believe that I am trying to spread penguins all over the world!

Last edited by dtournas; 06-18-2004 at 02:53 AM.
 
Old 06-18-2004, 03:05 AM   #7
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
ok
sure thing, I love networking!!!!

My Linuxbox is static of 10.1.0.112
subnet mask (netmask) of 255.0.0.0
gateway of 10.1.0.4

my windows xp pro is static of
10.1.0.111
subnet mask of 255.0.0.0
gateway of 10.1.0.4

If you would like I could set up a VPN connection for you and you could hop on over and check things out
I can allow you tightVNC or windows RDP access to any of the computers.

-Jon
if you want to do that, post your e-mail on a reply and I will send you the info.
otherwise, we can work via this forum.

from what I have been reading on the other posts, I am concerned that my linux box is not using fat32 or ntfs partitions.
do the folders I want to share on the linux box need to be on a fat partition ?
 
Old 06-18-2004, 03:14 AM   #8
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
Quote:
Originally posted by joncolby
from what I have been reading on the other posts, I am concerned that my linux box is not using fat32 or ntfs partitions.
do the folders I want to share on the linux box need to be on a fat partition ?
No, that is not correct. The main advantage of Samba is that it can share to almost any computer (mac, ibm, linux, unix etc) so we only need to make samba working right. Now, it looks like we are hunting ghosts here.... I assume that you have tried to ping from one box to another, right? Do you have a switch or a hub connecting the boxes? Do you do it with one inverted cable?

As long as the e-mail... remember, we need to help as many as we can. Keep it on the forum!
 
Old 06-18-2004, 03:22 AM   #9
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Yea, they ping eachother.

The windows box sees the "ITSDABOMBMON" (SMBSERVER) under '
my network places' under the workgroup.
if I change the netbios name on the linux box in the smb.conf and restart samba
about 5 min later it shows the change on the windows xp box.
it sees the netbios name change, but it is delayed.
they are pluged into a cisco catalyst 2900XL switch
with regular straight-thru cables.

on another note, if I click the red had in the default GUI, (I believe is GNOME) for fedora, and I go to SYSTEM SETTINGS -> SERVER SETTINGS ->
and click on SAMBA i get nothing.
but I never knew that icon was there untill about 3 min ago.
everything I have done up untill now has been logged on as root and from the command prompt.
I ran all the updates this morning.
I can re install linux if need be. No problem.
I just put it on last night.
 
Old 06-18-2004, 03:27 AM   #10
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
-another note again,


do you have a .conf file that I can use with some instructions you make up ?
just so I can test a setup that is "KNOWN" to work.
even if it allows ANY windows machine to connect. or something like that ?
I would be willing to try to do someone elses setup here and change my usernames
accordingly to see if I can get some communications between the two boxes.
 
Old 06-18-2004, 03:38 AM   #11
chandu
LQ Newbie
 
Registered: May 2004
Posts: 13

Rep: Reputation: 0
Hi,

just now I have configured samba. when I am trying to change the password it giving the following error

[root@mylinux root]# useradd tmp
[root@mylinux root]# smbpasswd tmp
New SMB password:
Retype new SMB password:
Failed to find entry for user tmp.
Failed to modify password entry for user tmp
[root@mylinux root]#

Pls help me !
 
Old 06-18-2004, 03:40 AM   #12
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
OK, here is my(well, not mine actually) contribution to the LINUX WORLD...

GOD BLESS WEBMIN!!!

Download Webmin from http://www.webmin.com Its free and its state of the art!! Install it to your fedora pc using
Code:
rpm -i webmin...etc
and then open your internet expoler on your XP box, and in the address type:
Code:
http://10.1.0.112:10000
. Have a look at this beauty and when you feel ready for the next step (Remote Advanced Linux Administration), let me now to give you instructions.

BUT before this, try to make the following changes to you smb.conf file:

1. Remove the
Code:
valid users = %S
from GLOBAL totaly, and leave nothing there.
2. Replace the
Code:
valid users = %S
from the shares and add
Code:
valid users = jon daffy
in the next line
Code:
write list = jon daffy
and do this to all of your shares. Really try this first! Write list means, that those users can read/write to the shared folder. If you wissh to only add read perms to daffy, then change it to:
Code:
write list = jon
and then add
Code:
read list = daffy

Let me know!
 
Old 06-18-2004, 03:42 AM   #13
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Dude, Make your own post. Dont bust into the middle of this one.
I am in no better position to help you than you are to help me.
Once I get some experience under my belt, I wont care if you bust
into my post, but right now you are going to change the subject and
Ill never get my issue resolved.
 
Old 06-18-2004, 03:49 AM   #14
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
Hey don't worry, I'll help him after I will be sure that you got right and working!
 
Old 06-18-2004, 04:01 AM   #15
joncolby
Member
 
Registered: Feb 2004
Posts: 38

Original Poster
Rep: Reputation: 15
OK, This is great !!!!
We are on to some Feedback
check this out.
From the windows XP box I can ping 10.1.0.112

-=BUT=- I cannot connect to HTTP://10.1.0.112:10000
or HTTP://ATOMICMAIL:10000
or HTTP://ITSDABOMBMON:10000

here is the output of the webmin install:
Webmin install complete. You can now login to http://ATOMICMAIL:10000/
as root with your root password.

now from the windows box i cannot ping 'ATOMICMAIL'
but i can ping 10.1.0.112

in my smb.conf you can see that the netbios name is not 'ATOMICMAIL'
______________________________________________________________
[global]
Netbios name = SMBSERVER
server string = ITSDABOMBMON
workgroup = JAEB.NET
security = user
encrypt passwords = Yes
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
wins support = Yes
smb passwd file = /etc/samba/smbpasswd
valid users = %S
logon home = \\netbiosname\%U
passwd program = /usr/bin/passwd %u
logon path = \\SMBSERVER\profiles\%U
______________________________________________________________

now, I am not sure if any of that will help or not, but I am going to make those changes now you gave me in the last post.
ill be back in 3 to 5 min.

-Jon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Script] Join Fedora Core2 in Windows 2003 Domain L1nuxbug Linux - Networking 0 11-09-2004 08:26 PM
Help! I've installed Fedora Core2, now I can't boot into Windows! gashead Linux - Newbie 5 10-16-2004 03:38 PM
Fedora Core2 aclarion Fedora 2 08-01-2004 10:19 PM
X windows configuration in fedora core2 nitink Fedora - Installation 1 07-29-2004 02:34 PM
Fedora Core2, SAMBA and Windows XP pro joncolby Linux - Networking 1 06-19-2004 07:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration