LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 05-22-2008, 02:38 AM   #1
snoopy1
Member
 
Registered: Jun 2007
Posts: 44

Rep: Reputation: 15
Conflicting Workstations


I'm hoping you can help me with a "small" problem I'm having. I've 10
workstations using the Tulip driver (10Mb/s lan card). DMESG shows the Tulip0 driver loading and then finding the card and assigning eth0 straight afterwards.

Each workstation is identical in terms of software and hardware (clones) and has Slackware 12, 2.6.24 kernel, static I.P 192.168.3.xx
in ./etc/rc.d/rc.inet1.conf and netmask 255.255.255.0

When one workstation is powered on eth0 is setup correctly and is shown in ifconfig. It will contact the server over NIS/YP just fine.

The second workstation will hang for ages as it tries to resolve a connection. Finally NFS, YP etc will all fail and I can log in as root. ifconfig will not show eth0. lspci shows the card and lsmod shows the tulip driver loaded. Again it assigned eth0 in dmesg, but now it's not available/visible.

I'm trying to think what this could be. Each workstation was a different
hostname in /etc/HOSTNAME and the name is changed in /etc/hosts as well.

I haven't set any tulip driver options or haven't over-rided the mac address.

Any ideas? I must have something on the cloned workstations that is
conflicting. Once I shut-down the first workstation and the second booted
fine, so that the first workstation now had the problem.

Many thanks for just reading this! Even more thanks if you have any
suggestions!
 
Old 05-22-2008, 06:04 AM   #2
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 36
Do you have a fully populated /etc/hosts file (all names and associated static xx numbers) on you NFS server? Is that file being served?

If yes to both then next step would be to turn off (chmod -x) rc.nfsd and with the first box booted and connected to NFS server will this box boot and ifconfig show proper static ip xx number?

Come back with answers and we can go from there.

ppd
 
Old 05-23-2008, 03:09 AM   #3
snoopy1
Member
 
Registered: Jun 2007
Posts: 44

Original Poster
Rep: Reputation: 15
I solved it yesterday evening. The card is being registered as eth0 but slackware must have a file somewhere for the network card in the original machine. When it can't find it rc.inet1 shifts the new card to eth1 and I didn't have settings for that.

So I added IFNAME[0]="eth1" to rc.inet1.conf and everything is perfect. I can't locate the file it has for the original card but at least this works.

Andrew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
server runs redhat , workstations win 2k ,workstations cannot connect to internet snkambule Linux - Networking 7 04-27-2005 10:08 AM
Conflicting packages apokryphos Linux - Software 3 10-02-2004 03:20 AM
Unix Workstations? Smokey General 4 07-23-2004 08:09 AM
Windows XP Workstations Leonr01 Linux - Networking 0 02-22-2004 04:58 AM
some prob with m$ workstations Kent Emia Linux - Networking 6 02-02-2004 08:25 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration