LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-15-2003, 04:26 AM   #16
johnleemk
Member
 
Registered: Sep 2003
Location: Malaysia
Distribution: Slackware 9.1
Posts: 145

Original Poster
Rep: Reputation: 15

I've already set Linux to use DHCP.

The hostname in Windows is the same; "John".

It is possible to ping 127.0.0.1 and my static IP if I set one.

Yes, there is an interface I am allowed to access for my network at 192.168.1.1(the router's IP).

I'll try running the script later.
 
Old 11-15-2003, 05:31 AM   #17
johnleemk
Member
 
Registered: Sep 2003
Location: Malaysia
Distribution: Slackware 9.1
Posts: 145

Original Poster
Rep: Reputation: 15
For Patrick, here's the ouput of ifconfig:
Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:08:A1:1B:67:B5
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:5382 (5.2 Kb)
          Interrupt:11 Base address:0x9400

eth0:9    Link encap:Ethernet  HWaddr 00:08:A1:1B:67:B5
          inet addr:169.254.37.28  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:11 Base address:0x9400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:488 errors:0 dropped:0 overruns:0 frame:0
          TX packets:488 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:32312 (31.5 Kb)  TX bytes:32312 (31.5 Kb)
And this is the logged stuff after I ran the first script bin/bash posted:
Code:
tail -f /var/log/messages
Nov 15 18:53:07 John modprobe: modprobe: Can't locate module fddi2
Nov 15 18:53:07 John modprobe: modprobe: Can't locate module fddi3
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/drakconnect_conf to 600
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/drakconnect_conf.default to 600
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/net_up.default to 755
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/net_down.default to 755
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/net_prog.default to 755
Nov 15 18:53:07 John drakconnect[2360]: changed mode of /etc/sysconfig/network-scripts/net_resolv.default to 755
Nov 15 18:56:34 John kernel: ip_tables: (C) 2000-2002 Netfilter core team
Nov 15 18:56:34 John kernel: ip_conntrack version 2.1 (3007 buckets, 24056 max) - 320 bytes per conntrack
 
Old 11-15-2003, 06:08 AM   #18
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Just another shot in the dark, I took a quick look at drakconnect - I take it the when you use it in the what connection do you want to configure bit you are choosing LAN Connection and not anything else, probably are but you never know.
 
Old 11-15-2003, 09:59 AM   #19
Patrick Bulteel
Member
 
Registered: Nov 2003
Location: United Kingdom
Distribution: Mandrake, RedHat, Suse, Ubuntu, Debian
Posts: 37

Rep: Reputation: 15
I see a couple of things that are strange in your message file. Can you grab more information from it?

In another console type

tail -100f /var/log/messages

And then try

ifdown eth0; sleep 3; ifup eth0

The information you got via tcpdump is interesting because it looks like it's trying to find the gateway (ARP requests for the mac for gateway) but isn't getting a response. Can you ping 192.168.1.156?

Try running tcpdump with the -n option (tcpdump -n -i eth0) so that it doesn't try to resolve names.

The fact that you have eth0:9 (a virtual interface) means that you weren't able to get a dhcp address from your network. Very interesting...
 
Old 11-15-2003, 03:52 PM   #20
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
<edit> RE: Post #4 in this thread.

Code:
C:\>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 08 a1 1b 67 b5 ...... CNet PRO200 PCI Fast Ethernet Adapter - Pack
et Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.1.1   192.168.1.212       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0    192.168.1.212   192.168.1.212       20
    192.168.1.212  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.1.255  255.255.255.255    192.168.1.212   192.168.1.212       20
        224.0.0.0        240.0.0.0    192.168.1.212   192.168.1.212       20
  255.255.255.255  255.255.255.255    192.168.1.212   192.168.1.212       1
Default Gateway:       192.168.1.1
===========================================================================
Persistent Routes:
This is your route when you are in windows?
Your ip is 192.168.1.150.
The router is 192.168.1.1.
So what is 192.168.1.212?

It looks to me like maybe your router is really at 192.168.1.212. If that is true then you need to change the GATEWAY=192.168.1.1 to GATEWAY=192.168.1.212.

<edit> Or I think maybe your IP was 192.168.1.212 and not 192.168.1.150?

Last edited by /bin/bash; 11-15-2003 at 03:59 PM.
 
Old 11-15-2003, 04:16 PM   #21
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
The thing is you don't need alot of complicated routing tables to ping that router. If you assign an IP to the NIC that is on the same network you should be able to ping the router.

I stop my network and with no routing table at all, I can assign an IP to my NIC and I can ping my router. Maybe this will help you understand better.

Code:
# service network stop
Shutting down interface eth0:                                   [  OK  ]
Shutting down interface eth1:                                   [  OK  ]
Shutting down loopback interface:                               [  OK  ]
# ifconfig
# ifconfig eth0 192.168.0.2 netmask 255.255.255.0
# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:4F:43:C1:FF:FF
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:67668 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76854 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0
          RX bytes:31980441 (30.4 Mb)  TX bytes:10527149 (10.0 Mb)

# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
# ping -c3 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=1.14 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.787 ms
64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=0.655 ms
I think you need to look at the router configuration carefully. What about the HW address did it somehow get changed. If your router is set to filter based on HW address this could be the problem.
 
Old 11-16-2003, 09:56 AM   #22
johnleemk
Member
 
Registered: Sep 2003
Location: Malaysia
Distribution: Slackware 9.1
Posts: 145

Original Poster
Rep: Reputation: 15
Quote:
Just another shot in the dark, I took a quick look at drakconnect - I take it the when you use it in the what connection do you want to configure bit you are choosing LAN Connection and not anything else, probably are but you never know.
Yep, I'm choosing LAN Connection.

Quote:

This is your route when you are in windows?
Your ip is 192.168.1.150.
The router is 192.168.1.1.
So what is 192.168.1.212?
That was my IP a week or two ago; my DHCP lease changes every three days or so.

Quote:

I think you need to look at the router configuration carefully. What about the HW address did it somehow get changed. If your router is set to filter based on HW address this could be the problem.
I'm setting up my network via the method you use; it doesn't work. I'll try removing an entry I made some time back for my NIC to see if it helps, although I doubt it since that entry was made after the problems started.

Last edited by johnleemk; 11-16-2003 at 10:24 AM.
 
Old 11-16-2003, 01:15 PM   #23
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
Quote:
I'm setting up my network via the method you use; it doesn't work. I'll try removing an entry I made some time back for my NIC to see if it helps, although I doubt it since that entry was made after the problems started.
What does that mean? Exactly what method are you using and what are the results including any error messages.

Try a ping scan of the network:
ifconfig eth0 down
ifconfig eth0 192.168.1.2 netmask 255.255.255.0
nmap -sP 192.168.1.0/24
Does it show any IP's as being up? If so thats probably your router. If not then check your iptables or any other firewall and check the routers configuration.
 
Old 11-16-2003, 09:41 PM   #24
Patrick Bulteel
Member
 
Registered: Nov 2003
Location: United Kingdom
Distribution: Mandrake, RedHat, Suse, Ubuntu, Debian
Posts: 37

Rep: Reputation: 15
Would you mind posting your configs for the network interface? The files in question would be under /etc/sysconfig/network-scripts/

I'd like to see a listing (ls -la) of that directory and if you can list the file (cat ifcfg-eth0) that would be enough for this round... =)

I'm sorry it's taking so long, but hopefully we'll figure it out.
 
Old 11-17-2003, 07:53 AM   #25
johnleemk
Member
 
Registered: Sep 2003
Location: Malaysia
Distribution: Slackware 9.1
Posts: 145

Original Poster
Rep: Reputation: 15
/bin/bash:
Nope, nothing comes up. I've disabled both shorewall and iptables from the Mandrake Control Center.

Patrick:
Code:
ls -la
total 204
drwxr-xr-x    4 root     root         4096 Nov 15 18:53 ./
drwxr-xr-x    7 root     root         4096 Oct  4 13:29 ../
-rw-------    1 root     root            0 Nov 15 18:53 drakconnect_conf
-rw-------    1 root     root            0 Nov 15 18:53 drakconnect_conf.default
-rwxr-xr-x    1 root     root          125 Nov 15 18:51 ifcfg-eth0*
lrwxrwxrwx    1 root     root           22 Oct  3 05:20 ifcfg-lo -> ../networking/ifcfg-lo
lrwxrwxrwx    1 root     root           20 Oct  3 05:20 ifdown -> ../../../sbin/ifdown*
-rwxr-xr-x    1 root     root         1026 Jan 24  2001 ifdown-aliases*
drwxr-xr-x    2 root     root         4096 Mar  1  2003 ifdown.d/
-rwxr-xr-x    1 root     root         4133 Mar  1  2003 ifdown-ipv6*
-rwxr-xr-x    1 root     root         1296 Mar  1  2003 ifdown-post*
-rwxr-xr-x    1 root     root         1092 Mar  1  2003 ifdown-ppp*
-rwxr-xr-x    1 root     root         1863 Mar  1  2003 ifdown-sit*
-rwxr-xr-x    1 root     root          902 Jun 26  2002 ifdown-sl*
lrwxrwxrwx    1 root     root           18 Oct  3 05:20 ifup -> ../../../sbin/ifup*
-rwxr-xr-x    1 root     root        13129 Feb  1  2003 ifup-aliases*
drwxr-xr-x    2 root     root         4096 Mar  1  2003 ifup.d/
-rwxr-xr-x    1 root     root         9667 Mar  1  2003 ifup-ipv6*
-rwxr-xr-x    1 root     root          821 Jun 26  2002 ifup-ipx*
-rwxr-xr-x    1 root     root          689 Jun 26  2002 ifup-plip*
-rwxr-xr-x    1 root     root          926 Jun 26  2002 ifup-plusb*
-rwxr-xr-x    1 root     root         2737 Mar  1  2003 ifup-post*
-rwxr-xr-x    1 root     root         3918 Jan 14  2003 ifup-ppp*
-rwxr-xr-x    1 root     root          868 Nov 12  2002 ifup-routes*
-rwxr-xr-x    1 root     root         3545 Mar  1  2003 ifup-sit*
-rwxr-xr-x    1 root     root         1646 Jun 26  2002 ifup-sl*
-rwxr-xr-x    1 root     root         2821 Jun 28  2002 ifup-wireless*
-rwxr-xr-x    1 root     root         5512 Mar  1  2003 init.ipv6-global*
-rwxr-xr-x    1 root     root          103 Nov 15 18:51 net_cnx_down*
-rwxr-xr-x    1 root     root          122 Nov 15 18:53 net_cnx_pg*
-rwxr-xr-x    1 root     root           92 Nov 15 18:51 net_cnx_up*
-rwxr-xr-x    1 root     root          103 Nov 15 18:53 net_down.default*
-rwxr-xr-x    1 root     root          122 Nov 15 18:53 net_prog.default*
-rwxr-xr-x    1 root     root           62 Nov 15 18:53 net_resolv.default*
-rwxr-xr-x    1 root     root           92 Nov 15 18:53 net_up.default*
-rw-r--r--    1 root     root         4756 Mar  1  2003 network-functions
-rw-r--r--    1 root     root        42053 Mar  1  2003 network-functions-ipv6
-rwxr-xr-x    1 root     root          169 Oct  3 16:10 old.ifcfg-eth0*
Code:
cat ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
ONBOOT=yes
MII_NOT_SUPPORTED=yes
DHCP_HOSTNAME=192.168.1.1
NEEDHOSTNAME=yes
 
Old 11-17-2003, 12:13 PM   #26
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 550

Rep: Reputation: 32
I'm having a similar problem with MNF:

http://www.linuxquestions.org/questi...hreadid=116058

I hope we can figure this out. So frustrating!!!
 
Old 11-17-2003, 12:22 PM   #27
Patrick Bulteel
Member
 
Registered: Nov 2003
Location: United Kingdom
Distribution: Mandrake, RedHat, Suse, Ubuntu, Debian
Posts: 37

Rep: Reputation: 15
The only thing that currently stands out is that DHCP_HOSTNAME should in your case be "john" since that's the name of the machine. Did you set this up via the mandrake control panel?

Try making the change to the file by hand - you could just make it blank.

Type the following:

vi /etc/sysconfig/networking-scripts/ifcfg-eth0
5 j 2 w D A john <esc> : w q

ifdown eth0 ; sleep 3 ; ifup eth0

The 5 j will move you down 5 lines, 2 (w)ords, (D)elete until end, (A)ppend at end of line - john - escape key, colon (w)rite (q)uit.

I doubt that's the problem... but lets try that first and we'll test other items afterwords.
 
Old 11-17-2003, 12:23 PM   #28
Patrick Bulteel
Member
 
Registered: Nov 2003
Location: United Kingdom
Distribution: Mandrake, RedHat, Suse, Ubuntu, Debian
Posts: 37

Rep: Reputation: 15
woops! it's /etc/sysconfig/network-scripts/ not /networking-scripts/
 
Old 11-17-2003, 02:45 PM   #29
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
When you use dhcp you don't get an IP so I would agree you need to change the DHCP_HOSTNAME=
Anytime you make changes and want to see if it helped do this:
service network restart

If the above does't fix the problem could you post both these one more time:
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
 
Old 11-17-2003, 07:41 PM   #30
DogMeat482
LQ Newbie
 
Registered: Nov 2003
Location: West Virginia, USA
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
Quote:
Originally posted by /bin/bash
Could you post these files:

/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0

Mine says:

[DM@linux DM]$ cat /etc/sysconfig/network
HOSTNAME="localhost.localdomain"
NETWORKING=yes
GATEWAY="192.168.1.1"
GATEWAYDEV="eth0"
FORWARD_IPV4="yes"
IPX="no"
IPXINTERNALNETNUM="0"
IPXINTERNALNODENUM="0"
IPXAUTOPRIMARY="on"
IPXAUTOFRAME="on"

[DM@linux DM]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="dhcp"
ONBOOT="yes"
NEEDHOSTNAME=yes
IPADDR="192.168.1.101"
NETMASK="255.255.255.0"
IPXNETNUM_802_2=""
IPXPRIMARY_802_2="no"
IPXACTIVE_802_2="no"
IPXNETNUM_802_3=""
IPXPRIMARY_802_3="no"
IPXACTIVE_802_3="no"
IPXNETNUM_ETHERII=""
IPXPRIMARY_ETHERII="no"
IPXACTIVE_ETHERII="no"
IPXNETNUM_SNAP=""
IPXPRIMARY_SNAP="no"
IPXACTIVE_SNAP="no"


If it matters, my XP machine was not connected to the network at this time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need Network install HELP for Mandrake 9.2! using network.img w/ cable modem physans Mandriva 6 02-25-2004 03:15 PM
Mandrake network legin Linux - Networking 8 10-14-2003 07:27 AM
Network in Mandrake Demon Linux - Hardware 2 02-25-2003 03:28 PM
new network adapter under mandrake single network firewall nerip Linux - Networking 3 08-03-2002 02:13 PM
How to configure a Network everywhere fast network card under Linux Mandrake 7.2 margo256 Linux - Newbie 1 03-12-2001 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration