LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-05-2011, 01:38 AM   #1
rewards
Member
 
Registered: Dec 2010
Posts: 135

Rep: Reputation: 0
Question 530 Login authentication failed pure-ftpd


Hello all,

I am trying to connect to the centos 6.0 server via ftp using Filzilla and I get error message 530 Login authentication failed. The pure-ftpd is configured with TLS. Here is the message I get;

Status: Connecting to 192.168.0.110:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 22:55. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER test
Response: 331 User test OK. Password required
Command: PASS *****
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

Any idea what the problem could be? Thank you all.
 
Old 12-05-2011, 03:35 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,753

Rep: Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839
Hi,

Are you sure that the password you're using is correct? You can also take a look at pure-ftpd logs under /var/log to see if you find anything.

Regarding TLS, I guess you're using the "-Y1" option, as I don't see any AUTH TLS reference in the responses you get from the server. If you used "-Y2", you should see something like the following
Quote:
Command: AUTH TLS
Response: 234 AUTH TLS OK.
Status: Initializing TLS...
Status: Verifying certificate...
Command: USER foo
Status: TLS/SSL connection established.
Response: 331 User foo OK. Password required
Command: PASS ******
Response: 230 OK. Current restricted directory is /
 
Old 12-05-2011, 11:54 AM   #3
rewards
Member
 
Registered: Dec 2010
Posts: 135

Original Poster
Rep: Reputation: 0
Hello,

The user name and password are correct. Cat /var/log/pureftpd.log has no output information. I did this before using purftpd;
vi /etc/pure-ftpd/pure-ftpd.conf and commented out the TLS 1'

# This option can accept three values :
# 0 : disable SSL/TLS encryption layer (default).
# 1 : accept both traditional and encrypted sessions.
# 2 : refuse connections that don't use SSL/TLS security mechanisms,
# including anonymous sessions.
# Do _not_ uncomment this blindly. Be sure that :
# 1) Your server has been compiled with SSL/TLS support (--with-tls),
# 2) A valid certificate is in place,
# 3) Only compatible clients will log in.

TLS 1

I also did this;

mkdir -p /etc/ssl/private/

Then

openssl req -x509 -nodes -days 7300 -newkey rsa:2048 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem

Country Name (2 letter code) [XX]: <-- Enter your Country Name (e.g., "US").
State or Province Name (full name) []: <-- Enter your State or Province Name.
Locality Name (eg, city) [Default City]: <-- Enter your City.
Organization Name (eg, company) [Default Company Ltd]: <-- Enter your Organization Name (e.g., the name of your company).
Organizational Unit Name (eg, section) []: <-- Enter your Organizational Unit Name (e.g. "IT Department").
Common Name (eg, your name or your server's hostname) []: <-- Enter the Fully Qualified Domain Name of the system (e.g. "server1.example.com").
Email Address []: <-- Enter your Email Address.

Change the permissions of the SSL certificate:

chmod 600 /etc/ssl/private/pure-ftpd.pem

/etc/init.d/pure-ftpd restart
 
Old 12-05-2011, 01:01 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,753

Rep: Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839
Hi,

From your 1st post, it's obvious that you don't use TLS in filezilla, as there is no AUTH TLS in pure-ftpd responses. So TLS is not related to your problem and that's why I told you to look at pure-ftpd logs.
BTW, you should look in /var/log/messages and/or /var/log/syslog

Regards
 
1 members found this post helpful.
Old 12-05-2011, 02:15 PM   #5
rewards
Member
 
Registered: Dec 2010
Posts: 135

Original Poster
Rep: Reputation: 0
Hello,

There is no syslog file in /var/log folder.
Here is the output for the cat /var/log/messages command;
I am using Filzilla to connect.


[root@server1 log]# cat messages
Dec 5 12:12:37 server1 pure-ftpd: (?@192.168.0.199) [INFO] New connection from 192.168.0.199
Dec 5 12:12:42 server1 pure-ftpd: (?@192.168.0.199) [WARNING] Authentication failed for user [test]
Dec 5 12:12:42 server1 pure-ftpd: (?@192.168.0.199) [INFO] Logout.

Thank you

Last edited by rewards; 12-05-2011 at 02:18 PM.
 
Old 12-05-2011, 05:00 PM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,753

Rep: Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839
Are you using real or virtual users? Also do you use PAM or Unix authentication?
 
1 members found this post helpful.
Old 12-06-2011, 12:24 PM   #7
rewards
Member
 
Registered: Dec 2010
Posts: 135

Original Poster
Rep: Reputation: 0
This a real user. On Linux I added a user called test with password test1. In fact I created another user called joe with password of joe123 and joe cannot login either;

Status: Connecting to 192.168.0.174:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 10:20. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER joe
Response: 331 User joe OK. Password required
Command: PASS ******
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

And here is the messages;

[root@server1 ~]#cat /var/log/messages

Dec 6 10:20:40 server1 pure-ftpd: (?@192.168.0.199) [INFO] New connection from 192.168.0.199
Dec 6 10:20:44 server1 pure-ftpd: (?@192.168.0.199) [WARNING] Authentication failed for user [joe]
Dec 6 10:20:44 server1 pure-ftpd: (?@192.168.0.199) [INFO] Logout.
Dec 6 10:20:53 server1 pure-ftpd: (?@192.168.0.199) [INFO] New connection from 192.168.0.199
Dec 6 10:20:56 server1 pure-ftpd: (?@192.168.0.199) [WARNING] Authentication failed for user [joe]
Dec 6 10:20:56 server1 pure-ftpd: (?@192.168.0.199) [INFO] Logout.
[root@server1 ~]#
 
Old 12-06-2011, 04:29 PM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,753

Rep: Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839
And what about PAM? Are you using it?
If you use it, change it to unix authentication (i.e. pure-ftpd will use passw/shadow to authenticate users)
 
Old 12-07-2011, 12:37 AM   #9
rewards
Member
 
Registered: Dec 2010
Posts: 135

Original Poster
Rep: Reputation: 0
Hi,

Where can I see PAM information? How do I find about this info and how do I change it to UNIX Authentication? My objective is that this joe user to be able to connect successfully and upload or download files.
 
Old 12-07-2011, 02:08 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,753

Rep: Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839Reputation: 1839
Quote:
Originally Posted by rewards View Post
Hi,

Where can I see PAM information? How do I find about this info and how do I change it to UNIX Authentication? My objective is that this joe user to be able to connect successfully and upload or download files.
If you're using a configuration file (/etc/pure-ftpd.conf), you should check there about the options used to start the server. Else check the server startup script for "-lpam" and change it to "-lunix"

Regards
 
Old 09-13-2012, 10:57 AM   #11
burek
LQ Newbie
 
Registered: Jan 2012
Posts: 7

Rep: Reputation: Disabled
Why is this topic marked as SOLVED? This is really misleading and doesn't help anyone..
 
Old 06-19-2013, 06:30 PM   #12
Wavebourn
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Rep: Reputation: Disabled
Quote:
Originally Posted by burek View Post
Why is this topic marked as SOLVED? This is really misleading and doesn't help anyone..
/etc/pure-ftpd/pure-ftpd.conf contains instructions which authentication to use.
 
Old 01-23-2015, 04:45 PM   #13
vincix
Senior Member
 
Registered: Feb 2011
Distribution: Ubuntu, Centos
Posts: 1,158

Rep: Reputation: 87
Quote:
Originally Posted by Wavebourn View Post
/etc/pure-ftpd/pure-ftpd.conf contains instructions which authentication to use.
So what was the solution? I have the exact same problem (without using TLS) and it doesn't work at all.
 
Old 02-05-2015, 12:51 AM   #14
mintystark
LQ Newbie
 
Registered: Feb 2015
Posts: 1

Rep: Reputation: Disabled
pure-pw useradd doesn't submit the password of the user to the Database.
So afterwards then try this:

pure-pw mkdb

or

pure-pw passwd joe -m
 
Old 11-23-2018, 05:07 PM   #15
NickT14
LQ Newbie
 
Registered: Nov 2018
Posts: 1

Rep: Reputation: Disabled
I had the same error which was due to a trailing space on the username. Testing with and without a trailing space I saw the "Response: 331 User username OK. Password required." in my packet capture; however, no joy passing the username with a trailing space.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
530 Authentication failed, sorry Manoj_linux10 Linux - Server 4 11-21-2011 07:25 AM
no authentication in pure-ftpd shifter Ubuntu 3 06-15-2010 04:19 PM
pure-ftpd 530: Login Failed wizzmaster Linux - Server 7 01-20-2009 08:04 PM
pure-ftpd login fails! i.you Linux - Software 1 12-03-2007 04:04 PM
pure ftpd running - can't login simplysi Linux - Newbie 4 03-05-2006 02:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration