LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-20-2007, 08:52 AM   #1
wizzmaster
LQ Newbie
 
Registered: Oct 2005
Posts: 4

Rep: Reputation: 0
pure-ftpd 530: Login Failed


Have installed pure-ftpd on a Fedora C5.
Start the server with this command /usr/sbin/pure-config.pl /usr/etc/pure-ftpd.conf

/usr/sbin/pure-ftpd -A -b -c100 -B -C100 -d -z -E -fftp -H -I15 -lmysql:/etc/pure-ftpd/pureftpd-mysql.conf -L2000:8 -m4 -p10000:19999 -s -S127.0.0.1,8686 -U077:077 -u100 -r -i -k99

When I try to connect (ftp localhost 8686), I get the following message:

Connected to localhost.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 100 allowed.
220-Local time is now 15:43. Server port: 8686.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
500 This security scheme is not implemented
500 This security scheme is not implemented
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): ftpuser
331 User ftpuser OK. Password required
Password:
530 Login authentication failed
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

What can be the reason of this error...?
 
Old 02-21-2007, 08:30 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 266Reputation: 266Reputation: 266
Are you using an anonymous login account? Does ftpuser actually have a password on the system?
 
Old 02-21-2007, 08:42 AM   #3
wizzmaster
LQ Newbie
 
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
No, no anonymous login are allowed.
 
Old 02-21-2007, 03:05 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 266Reputation: 266Reputation: 266
Quote:
Originally Posted by wizzmaster
No, no anonymous login are allowed.
So does this ftpuser have a password? More info always gets better replies so we don't have to guess..
 
Old 02-22-2007, 01:50 AM   #5
wizzmaster
LQ Newbie
 
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
more info

Sure I'm willing to give more info.

But this info was in my first post, not?

Quote:
Name (localhost:root): ftpuser
331 User ftpuser OK. Password required
Password:
530 Login authentication failed
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
I did check the DB where everything is updated : username,password as directory.
So I'm no sure what more I can tell?
 
Old 12-05-2008, 04:07 AM   #6
lsegalla
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
I have the same problem on a gentoo box...
Any thought?
 
Old 12-05-2008, 09:39 AM   #7
lsegalla
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
i solved the problem here
http://forums.gentoo.org/viewtopic-p...8.html#5264758
 
Old 01-20-2009, 08:04 PM   #8
simka007
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Rep: Reputation: 0
I had the same problem with pure-ftpd-1.0.21 on ASPLinux

You should try the following:
1) Recompile your pure-ftpd

# ./configure --with-everything
# make
# make install

2) Show your database /etc/pureftpd.pdb to pure-ftpd

# /usr/local/sbin/pure-ftpd -j -lpuredb:/etc/pureftpd.pdb

For more details see http://download.pureftpd.org/pub/pur....Virtual-Users

------------------------ ENABLING VIRTUAL USERS ------------------------


Of course, to use virtual users, you have to enable their support in the FTP
server itself. At compile-time, this is done by giving --with-puredb to
./configure (--with-everything also enables it and binary packages have it
compiled in) .

Then, add this switch to your usual pure-ftpd switches:

-l puredb:/path/to/puredb_file

If long options are enabled, you can also use --login instead of -l .

Let's run the server with automatic creation of home directories and puredb
authentication:

/usr/local/sbin/pure-ftpd -j -lpuredb:/etc/pureftpd.pdb &

Try to 'ftp localhost' and log in as joe.
 
  


Reply

Tags
failed, login, pureftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd and root login szymon Linux - Software 6 03-13-2012 11:28 AM
pure-ftpd roofy Linux - Software 6 03-05-2007 04:06 AM
pure ftpd running - can't login simplysi Linux - Newbie 4 03-05-2006 02:06 AM
pure-ftpd help hongman Linux - Software 16 04-06-2005 11:18 AM
Pure-ftpd, login with MySQL as control - problem KR-data Linux - Software 0 01-29-2005 06:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration