LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-01-2004, 10:08 PM   #1
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
ut2004 demo & nvidia problems


I have an nvidia GeForce FX graphics card and I updated the driver to the one found on this page: http://www.nvidia.com/object/linux_d..._1.0-6106.html

I downloaded the Unreal Tournament 2004 Demo and installed it. Whenever I try to open it I get an error message like this:
-------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
--------

Any ideas on how I can get this working? I have read posts about the GLX nvidia problem but I thought updating my drivers would fix it.
 
Old 07-02-2004, 12:46 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Make sure your XF86Config file has the line:
Load "glx"
in the Module section.

Dave
 
Old 07-12-2004, 12:17 PM   #3
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Original Poster
Rep: Reputation: 15
load "glx" is already there

load "glx" is in the modules section.

The error I just got after trying to run the 2004 demo again was:
Couldn't set video mode: Couldn't find matching GLX visual


History:

Exiting due to error
 
Old 07-13-2004, 12:21 AM   #4
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
What does glxinfo say. Does it give you any permission problems. If it does try running it as root, but be careful. You might may want to log out and log back in again to see if it works.

Do you have:

Driver "nvidia"

in the Device section.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
UT2004 Demo problems DarkNebula Linux - Games 2 03-08-2005 05:23 PM
UT2004 Demo Problems Fedoro Core 3 Nikolas_Linux Linux - Games 6 01-13-2005 04:40 PM
6 fps in ut2004 demo Tyir Linux - Software 13 11-24-2004 07:34 AM
No sound in UT2004 demo PeterWelzien Linux - Games 2 09-25-2004 08:51 AM
Yet another UT2004 Demo Question OutKaster Linux - Games 1 08-05-2004 07:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration