LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-23-2004, 11:40 PM   #1
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Rep: Reputation: 0
trouble mounting my dvd-rw - can someone check my fstab?


hello. I am trying to mount my dvd-rw drive but I get this error:

Quote:
mount /dev/scd0 is not a valid block device
I'm sure this is quite simple - I am just overlooking something, but I just cannot see what

here is a copy of my fstab - can someone check it out and see what the problem is?

Quote:
# Begin /etc/fstab

# filesystem mount-point fs-type options dump fsck-order

/dev/fd0 /floppy auto rw,exec,noauto,users 0 0
/dev/cdrom /mnt/cdrom/ auto ro,noauto,users,exec 0 0
#/dev/cdrom /mnt/cdrom supermount fs=iso9660,dev=/dev/cdrom,--,ro,iocharset=iso8859-1 0 0
none /dev/pts devpts gid=4,mode=620 0 0
none /proc proc defaults 0 0
/dev/hda2 / reiserfs notail,noatime 1 1
/dev/hda1 swap swap defaults 0 0
/dev/hda3 /home reiserfs notail,noatime 1 1
#/dev/scd0 /mnt/cdwriter supermount fs=iso9660,dev=/dev/scd0,--,ro,iocharset=iso8859-1 0 0
/dev/scd0 /mnt/cdwriter auto ro,noauto,users,exec 0 0
/dev/sda1 /external reiserfs defaults,user,noauto 0 0
Thanks!
 
Old 09-24-2004, 12:32 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Welcome to LQ Bigfoot!

How are you trying to mount it? What command are you issuing?

It looks like your dvd is being called cdwriter, eh?
And you can't quite use noauto and auto - conflicing statements.
Plus, you're using ro (read only) rather than rw (read/write). You
do want to write with it, don't you?

Try this for your dvd entry in fstab
Code:
/dev/scd0        /mnt/dvd         iso9660     user,umask=1000,rw,noauto 0 0
and mount it with
$ mount /mnt/dvd
as a normal user. Works like a charm here.

Your system is correct, /dev/scd0 is not a block device.

NB: Don't forget to make the directory you wish to mount.
 
Old 09-24-2004, 01:05 AM   #3
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
hello - thanks for the quick response.

I updated my fstab:

Quote:
# Begin /etc/fstab

# filesystem mount-point fs-type options dump fsck-order

/dev/fd0 /floppy auto rw,exec,noauto,users 0 0
/dev/cdrom /mnt/cdrom/ auto ro,noauto,users,exec 0 0
#/dev/cdrom /mnt/cdrom supermount fs=iso9660,dev=/dev/cdrom,--,ro,iocharset=iso8859-1 0 0
none /dev/pts devpts gid=4,mode=620 0 0
none /proc proc defaults 0 0
/dev/hda2 / reiserfs notail,noatime 1 1
/dev/hda1 swap swap defaults 0 0
/dev/hda3 /home reiserfs notail,noatime 1 1
#/dev/scd0 /mnt/cdwriter supermount fs=iso9660,dev=/dev/scd0,--,ro,iocharset=iso8859-1 0 0
/dev/scd0 /mnt/dvd iso9660 user,umask=1000,rw,noauto 0 0
/dev/sda1 /external reiserfs defaults,user,noauto 0 0
and I created a directory /mnt/dvd

but yet when I $ mount /mnt/dvd, I still get

Quote:
mount: /dev/scd0 is not a valid block device
hmmm...maybe it's not called scd0 but something else...?

Last edited by sasquatch; 09-24-2004 at 01:06 AM.
 
Old 09-24-2004, 01:14 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Please post the output of:

"mount" as normal user

Edit: Which distribution are you using?
Posted wrong commands.
Where is you DVD located in your box?

Last edited by Bruce Hill; 09-24-2004 at 01:24 AM.
 
Old 09-24-2004, 01:27 AM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Look in /var/log/dmesg
for lines that look like this
Code:
hda: Maxtor 6Y060L0, ATA DISK drive
hdb: SONY CD-RW CRX230E, ATAPI CD/DVD-ROM drive
blk: queue c04557a0, I/O limit 4095Mb (mask 0xffffffff)
hdc: Maxtor 6Y060L0, ATA DISK drive
hdd: SONY DVD RW DRU-500A, ATAPI CD/DVD-ROM drive
You should have a section all together like that where your
IDE drives are listed.
 
Old 09-24-2004, 01:39 AM   #6
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
output from $ mount:

Quote:
$ mount
rootfs on / type rootfs (rw)
/dev/root on / type reiserfs (rw,noatime)
/proc on /proc type proc (rw,nodiratime)
/sys on /sys type sysfs (rw)
none on /dev/pts type devpts (rw)
/dev/hda3 on /home type reiserfs (rw,noatime)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sda1 on /external type reiserfs (rw,nosuid,nodev,noexec)
I am using yoper.


/var/log/dmesg does not exist.

hmmm...
 
Old 09-24-2004, 02:35 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by sasquatch
output from $ mount:

I am using yoper.

/var/log/dmesg does not exist.

hmmm...
You got me on that one. I've never seen such stuff in mount.
I mean, what does this mean?
Quote:
rootfs on / type rootfs (rw) <-- never heard of rootfs filesystem
/dev/root on / type reiserfs (rw,noatime) <-- this is a directory, right? not a device
When you posted earlier, you had
Quote:
/dev/hda2 / reiserfs notail,noatime 1 1
Did you create a new /etc/fstab file?

And I'm thinking, how can you run a Linux OS and not have
a dmesg file? Try issuing "locate dmesg" to find it. I get this
Code:
mingdao@paul:~$ locate dmesg
/bin/dmesg
/var/log/dmesg
/usr/man/man8/dmesg.8.gz
/usr/src/linux-2.4.26/arch/m68k/tools/amiga/dmesg.c
in Slackware.

So you should be able to issue "dmesg" or "/bin/dmesg" and
get some output.

Assuming you can use some type of text editor, try issuing
dmesg > boot.messages
which will create a file named boot.messages and then open
that file with an editor and read it. Post if you find your drives.
Or you could issue "/bin/dmesg | less" and scroll up through the
output, but I thought reading a file might be easier for you. If
you can't find your drives, post the whole dmesg file.

If your comp doesn't recognize the drive, you'll never mount it. You
might not even have support in your kernel to use it.
 
Old 09-24-2004, 07:29 AM   #8
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hi,

To be sure that your CD/DVD is not associated to /dev/hd?, do "cat /proc/ide/hd?/model"... I have no scsi drive but I suppose that there's the same for scsi, so check also /proc/scsi/sc?/model
There's also /proc/devices which can give you the major of your drive

Oliv'
 
Old 09-24-2004, 04:37 PM   #9
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
You got me on that one. I've never seen such stuff in mount.
I mean, what does this mean?

quote:rootfs on / type rootfs (rw) <-- never heard of rootfs filesystem
/dev/root on / type reiserfs (rw,noatime) <-- this is a directory, right? not a device
I have no idea either - im new to this.

Quote:
And I'm thinking, how can you run a Linux OS and not have
a dmesg file? Try issuing "locate dmesg" to find it. I get this
ok here are my results from

1. $ locate dmesg

Quote:
$ locate dmesg
locate: /var/locatedb: No such file or directory
2. $ dmesg (sorry for the length)

Quote:
dmesg
Linux version 2.6.8.1-3 (root@yos) (gcc version 3.4.1) #1 SMP Wed Aug 25 11:18:30 Pacific/Auckland 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003fff0000 (usable)
BIOS-e820: 000000003fff0000 - 000000003fff3000 (ACPI NVS)
BIOS-e820: 000000003fff3000 - 0000000040000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
1023MB LOWMEM available.
found SMP MP-table at 000f6400
On node 0 totalpages: 262128
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 258032 pages, LIFO batch:16
HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 AWARD ) @ 0x000f7e80
ACPI: RSDT (v001 AWARD AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3000
ACPI: FADT (v001 AWARD AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3040
ACPI: MADT (v001 AWARD AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff6a00
ACPI: DSDT (v001 AWARD AWRDACPI 0x00001000 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:2 APIC version 20
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: Assigned apic_id 2
IOAPIC[0]: apic_id 2, version 20, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 dfl dfl)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode: Flat. Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=YOS ro root=302 splash=silent
Initializing CPU#0
PID hash table entries: 4096 (order 12: 32768 bytes)
Detected 2400.140 MHz processor.
Using pmtmr for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 262144 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 131072 (order: 7, 524288 bytes)
Memory: 1034072k/1048512k available (1884k kernel code, 13700k reserved, 732k data, 156k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 4751.36 BogoMIPS
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: Hyper-Threading is disabled
CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
CPU0: Intel(R) Pentium(R) 4 CPU 2.40GHz stepping 07
per-CPU timeslice cutoff: 1462.38 usecs.
task migration cache decay timeout: 2 msecs.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Total of 1 processors activated (4751.36 BogoMIPS).
ENABLING IO-APIC IRQs
init IO_APIC IRQs
IO-APIC (apicid-pin) 2-0, 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23 not connected.
..TIMER: vector=0x31 pin1=2 pin2=-1
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 2399.0308 MHz.
..... host bus clock speed is 133.0294 MHz.
Brought up 1 CPUs
CPU0: online
domain 0: span 01
groups: 01
domain 1: span 01
groups: 01
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 492k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfbaa0, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
Uncovering SIS962 that hid as a SIS503 (compatible=1)
Enabling SiS 96x SMBus.
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 6 7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 *9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs *3 4 5 6 7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 *5 6 7 9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 *11 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: the driver 'system' has been registered
PnPBIOS: Scanning system for PnP BIOS support...
PnPBIOS: Found PnP BIOS installation structure at 0xb00fc4d0
PnPBIOS: PnP BIOS version 1.0, entry 0xf0000:0xc500, dseg 0xf0000
pnp: match found with the PnP device '00:07' and the driver 'system'
pnp: match found with the PnP device '00:08' and the driver 'system'
pnp: match found with the PnP device '00:0b' and the driver 'system'
pnp: 00:0b: ioport range 0x1000-0x107f has been reserved
pnp: 00:0b: ioport range 0x10c0-0x10df has been reserved
pnp: match found with the PnP device '00:0c' and the driver 'system'
pnp: 00:0c: ioport range 0x3f0-0x3f1 has been reserved
PnPBIOS: 18 nodes reported by PnP BIOS; 18 recorded by driver
SCSI subsystem initialized
Linux Kernel Card Services
options: [pci] [cardbus] [pm]
PCI: Using ACPI for IRQ routing
ACPI: PCI interrupt 0000:00:02.1[B] -> GSI 17 (level, low) -> IRQ 17
ACPI: PCI interrupt 0000:00:02.3[B] -> GSI 17 (level, low) -> IRQ 17
ACPI: PCI interrupt 0000:00:02.5[A] -> GSI 16 (level, low) -> IRQ 16
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 20 (level, low) -> IRQ 20
ACPI: PCI interrupt 0000:00:03.1[B] -> GSI 21 (level, low) -> IRQ 21
ACPI: PCI interrupt 0000:00:03.2[C] -> GSI 22 (level, low) -> IRQ 22
ACPI: PCI interrupt 0000:00:03.3[D] -> GSI 23 (level, low) -> IRQ 23
ACPI: PCI interrupt 0000:00:07.0[A] -> GSI 18 (level, low) -> IRQ 18
ACPI: PCI interrupt 0000:00:07.2[B] -> GSI 19 (level, low) -> IRQ 19
ACPI: PCI interrupt 0000:00:08.0[A] -> GSI 19 (level, low) -> IRQ 19
ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
number of MP IRQ sources: 15.
number of IO-APIC #2 registers: 24.
testing the IO APIC.......................
IO APIC #2......
.... register #00: 02000000
....... : physical APIC id: 02
....... : Delivery Type: 0
....... : LTS : 0
.... register #01: 00178014
....... : max redirection entries: 0017
....... : PRQ implemented: 1
....... : IO APIC version: 0014
.... register #02: 02000000
....... : arbitration: 02
.... IRQ redirection table:
NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
00 000 00 1 0 0 0 0 0 0 00
01 001 01 0 0 0 0 0 1 1 39
02 001 01 0 0 0 0 0 1 1 31
03 001 01 0 0 0 0 0 1 1 41
04 001 01 0 0 0 0 0 1 1 49
05 001 01 0 0 0 0 0 1 1 51
06 001 01 0 0 0 0 0 1 1 59
07 001 01 0 0 0 0 0 1 1 61
08 001 01 0 0 0 0 0 1 1 69
09 001 01 0 1 0 1 0 1 1 71
0a 001 01 0 0 0 0 0 1 1 79
0b 001 01 0 0 0 0 0 1 1 81
0c 001 01 0 0 0 0 0 1 1 89
0d 001 01 0 0 0 0 0 1 1 91
0e 001 01 0 0 0 0 0 1 1 99
0f 001 01 0 0 0 0 0 1 1 A1
10 001 01 1 1 0 1 0 1 1 B1
11 001 01 1 1 0 1 0 1 1 A9
12 001 01 1 1 0 1 0 1 1 D9
13 001 01 1 1 0 1 0 1 1 E1
14 001 01 1 1 0 1 0 1 1 B9
15 001 01 1 1 0 1 0 1 1 C1
16 001 01 1 1 0 1 0 1 1 C9
17 001 01 1 1 0 1 0 1 1 D1
IRQ to pin mappings:
IRQ0 -> 0:2
IRQ1 -> 0:1
IRQ3 -> 0:3
IRQ4 -> 0:4
IRQ5 -> 0:5
IRQ6 -> 0:6
IRQ7 -> 0:7
IRQ8 -> 0:8
IRQ9 -> 0:9
IRQ10 -> 0:10
IRQ11 -> 0:11
IRQ12 -> 0:12
IRQ13 -> 0:13
IRQ14 -> 0:14
IRQ15 -> 0:15
IRQ16 -> 0:16
IRQ17 -> 0:17
IRQ18 -> 0:18
IRQ19 -> 0:19
IRQ20 -> 0:20
IRQ21 -> 0:21
IRQ22 -> 0:22
IRQ23 -> 0:23
.................................... done.
PCI: Cannot allocate resource region 4 of device 0000:00:02.1
vesafb: framebuffer at 0xc0000000, mapped to 0xf0807000, size 3072k
vesafb: mode is 1024x768x16, linelength=2048, pages=169
vesafb: protected mode interface info at c000:573b
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
fb0: VESA VGA frame buffer device
audit: initializing netlink socket (disabled)
audit(1095991630.084:0): initialized
Supermount version 2.0.4 for kernel 2.6
Initializing Cryptographic API
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Console: switching to colour frame buffer device 128x48
Using cfq io scheduler
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 8000K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 0000:00:02.5
ACPI: PCI interrupt 0000:00:02.5[A] -> GSI 16 (level, low) -> IRQ 16
SIS5513: chipset revision 0
SIS5513: not 100% native mode: will probe irqs later
SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdcMA, hddio
hda: ST380022A, ATA DISK drive
hdb: SONY DVD-ROM DDU1612, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: PIONEER DVD-RW DVR-105, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 156301488 sectors (80026 MB) w/1024KiB Cache, CHS=65535/16/63, UDMA(100)
hda: hda1 hda2 hda3
hdb: ATAPI 40X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
hdc: ATAPI 32X DVD-ROM DVD-R CD-R/RW drive, 2000kB Cache, UDMA(33)
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: ImPS/2 Logitech Wheel Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
NET: Registered protocol family 2
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
NET: Registered protocol family 1
NET: Registered protocol family 17
PM: Reading pmdisk image.
PM: Resume from disk failed.
ACPI: (supports S0 S3 S4 S5)
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
8139too Fast Ethernet driver 0.9.27
ACPI: PCI interrupt 0000:00:08.0[A] -> GSI 19 (level, low) -> IRQ 19
eth0: RealTek RTL8139 at 0xf0b08000, 00:0d:88:39:31:63, IRQ 19
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ACPI: PCI interrupt 0000:00:03.3[D] -> GSI 23 (level, low) -> IRQ 23
ehci_hcd 0000:00:03.3: Silicon Integrated Systems [SiS] USB 2.0 Controller
ehci_hcd 0000:00:03.3: irq 23, pci mem f0b0c000
ehci_hcd 0000:00:03.3: new USB bus registered, assigned bus number 1
PCI: cache line size of 128 is not supported by device 0000:00:03.3
ehci_hcd 0000:00:03.3: USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 20 (level, low) -> IRQ 20
ohci_hcd 0000:00:03.0: Silicon Integrated Systems [SiS] USB 1.0 Controller
ohci_hcd 0000:00:03.0: irq 20, pci mem f0b0e000
ohci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:03.1[B] -> GSI 21 (level, low) -> IRQ 21
ohci_hcd 0000:00:03.1: Silicon Integrated Systems [SiS] USB 1.0 Controller (#2)
ohci_hcd 0000:00:03.1: irq 21, pci mem f0b16000
ohci_hcd 0000:00:03.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:03.2[C] -> GSI 22 (level, low) -> IRQ 22
ohci_hcd 0000:00:03.2: Silicon Integrated Systems [SiS] USB 1.0 Controller (#3)
ohci_hcd 0000:00:03.2: irq 22, pci mem f0b18000
ohci_hcd 0000:00:03.2: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI interrupt 0000:00:02.3[B] -> GSI 17 (level, low) -> IRQ 17
ohci1394: fw-host0: Unexpected PCI resource length of 1000!
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[17] MMIO=[e8129000-e81297ff] Max Packet=[2048]
ACPI: PCI interrupt 0000:00:07.2[B] -> GSI 19 (level, low) -> IRQ 19
ohci1394: fw-host1: OHCI-1394 1.1 (PCI): IRQ=[19] MMIO=[e8128000-e81287ff] Max Packet=[2048]
ReiserFS: hda2: found reiserfs format "3.6" with standard journal
usb 1-3: new high speed USB device using address 3
usb 3-1: new full speed USB device using address 2
ReiserFS: hda2: using ordered data mode
ReiserFS: hda2: journal params: device hda2, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda2: checking transaction log (hda2)
ReiserFS: hda2: Using r5 hash to sort names
Freeing unused kernel memory: 156k freed
ieee1394: Host added: ID:BUS[0-00:1023] GUID[000010dc0008596f]
ieee1394: Host added: ID:BUS[1-00:1023] GUID[00023c015105b571]
ip1394: $Rev: 1224 $ Ben Collins <bcollins@debian.org>
ip1394: eth1: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
ip1394: eth2: IEEE-1394 IPv4 over 1394 Ethernet (fw-host1)
ReiserFS: hda3: found reiserfs format "3.6" with standard journal
ReiserFS: hda3: using ordered data mode
ReiserFS: hda3: journal params: device hda3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda3: checking transaction log (hda3)
ReiserFS: hda3: Using r5 hash to sort names
Real Time Clock Driver v1.12
Adding 3145928k swap on /dev/hda1. Priority:-1 extents:1
ts: Compaq touchscreen protocol output
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected SiS 651 chipset
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: AGP aperture is 128M @ 0xe0000000
ACPI: PCI interrupt 0000:00:07.0[A] -> GSI 18 (level, low) -> IRQ 18
gameport: pci0000:00:07.1 speed 1147 kHz
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
pnp: the driver 'serial' has been registered
pnp: match found with the PnP device '00:0d' and the driver 'serial'
pnp: the driver 'parport_pc' has been registered
pnp: match found with the PnP device '00:10' and the driver 'parport_pc'
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP(,...)]
USB Universal Host Controller Interface driver v2.2
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Maxtor 6 Model: Y120L0 Rev: 0 0
Type: Direct-Access ANSI SCSI revision: 02
USB Mass Storage device found at 3
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: Medion Model: Flash XL CF Rev: 2.7D
Type: Direct-Access ANSI SCSI revision: 02
Vendor: Medion Model: Flash XL MS Rev: 2.7D
Type: Direct-Access ANSI SCSI revision: 02
Vendor: Medion Model: Flash XL MMC/SD Rev: 2.7D
Type: Direct-Access ANSI SCSI revision: 02
Vendor: Medion Model: Flash XL SM Rev: 2.7D
Type: Direct-Access ANSI SCSI revision: 02
USB Mass Storage device found at 2
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
SCSI device sda: 240121728 512-byte hdwr sectors (122942 MB)
sda: assuming drive cache: write through
sda: sda1
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0
Attached scsi removable disk sdc at scsi1, channel 0, id 0, lun 1
Attached scsi removable disk sdd at scsi1, channel 0, id 0, lun 2
sde: Unit Not Ready, sense:
Current : sense = 70 6
ASC=28 ASCQ= 0
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x28 0x00 0x00 0x00 0x00 0x00
sde: Write Protect is off
sde: Mode Sense: 4b 00 00 08
sde: assuming drive cache: write through
Attached scsi removable disk sde at scsi1, channel 0, id 0, lun 3
apm: Unknown parameter `2'
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
apm: overridden by ACPI.
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
lp0: using parport0 (interrupt-driven).
atkbd.c: Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying access hardware directly.
atkbd.c: Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying access hardware directly.
ReiserFS: sda1: found reiserfs format "3.6" with standard journal
ReiserFS: sda1: using ordered data mode
ReiserFS: sda1: journal params: device sda1, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sda1: checking transaction log (sda1)
ReiserFS: sda1: Using r5 hash to sort names
3. $ /bin/dmesg | less
Quote:
$ /bin/dmesg | less
Linux version 2.6.8.1-3 (root@yos) (gcc version 3.4.1) #1 SMP Wed Aug 25 11:18:
30 Pacific/Auckland 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003fff0000 (usable)
BIOS-e820: 000000003fff0000 - 000000003fff3000 (ACPI NVS)
BIOS-e820: 000000003fff3000 - 0000000040000000 (ACPI data)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
1023MB LOWMEM available.
:
Quote:
If your comp doesn't recognize the drive, you'll never mount it. You
might not even have support in your kernel to use it.
Well, I am currently using 2.6.8-13 with yoper distro. The drive was automatically and easily detected by my two previous distros - suse personal 9.1 and libranet 2.8.1 (libranet uses 2.4 kernel I believe). So, I think my drive is compatable - its just my fstab or some other configuration file is kinda messed up

I appreciate your help Chinaman
cheers!
 
Old 09-24-2004, 04:42 PM   #10
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
**update***

I spoke too soon! After re-reviewing the dmesg, I see my dvd-rw is listed as hdc. So I can now mount it! Sweet. Now, I have one thing left: when I mount it, I get an error that says

Quote:
mount: block device /dev/hdc is write-protected, mounting read-only
and when I try to unmount it, I get:

Quote:
Could not unmount device.
The reported error was:
umount: only root can unmount /dev/hdc from /mnt/dvd
how should I modify this?

Last edited by sasquatch; 09-24-2004 at 04:44 PM.
 
Old 09-24-2004, 06:47 PM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by sasquatch
**update***

I spoke too soon! After re-reviewing the dmesg, I see my dvd-rw is listed as hdc. So I can now mount it! Sweet. Now, I have one thing left: when I mount it, I get an error that says



and when I try to unmount it, I get:



how should I modify this?
Good morning

Edit: Sorry, I've got a new keyboard and hit some
key with enter at the same time. Will continue in next post.

Last edited by Bruce Hill; 09-24-2004 at 06:52 PM.
 
Old 09-24-2004, 07:58 PM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
simple but incomplete answer

Sasquatch,

For now I can only give you a little bit of an answer. You are
running a 2.6.x series kernel, and everything changed when
we went from 2.4 to 2.6, as far as using CD/DVD writers and
maybe some SCSI devices are concerned.

I see from your dmesg output that you have Seagate 80GB
ATA drive, a Maxtor SCSI drive, a Flash disk, a DVD-ROM and
a DVD-RW - at least. Is that correct?

I just installed a 2.6.7 kernel and I'm having to find out how
to use the CD/DVD writers without scsi emulation, which is
how we've done it in all the kernels before 2.6. That is on
my To Do List for today, but time with my girls is first. I will
get back with you.

In the meantime, here's some tidbits.
(1) you said when you mounted it you were given this:
mount: block device /dev/hdc is write-protected, mounting read-only
but that's not an error, just an informational message. It says
you can read, but not write, to the drive. That comes from the
line in /etc/fstab where you have ro rather than rw.
(2) you know how to mount it, obviously, but to unmount it you issue
"umount /mnt/dvd" if that's the directory where it's mounted. And
yes, there is only one n in the umount command.
(3) K3b may be all you need to burn CD/DVDs with your present
setup, but I can't answer that yet. Once you've changed your
/etc/fstab to rw, see if you have a menu where you can find
the K3b program. I don't know what apps are available in
Yoper. You could also issue locate k3b | grep '/k3b$'
in a terminal.

Just last night I moved 3 drives from my other computer into
this one, and I've not yet read/searched to find out how I'm going
to use my writers, flash disk, and usb hard drives with the 2.6.7
kernel. I do know that I can mount my flash disk just by issuing
"mingdao@james:~$ mount /mnt/sdb1"

Below is my present /etc/fstab, mostly from the other comp. I'll be
working on it today, but those last entries are for mounting my
flash and usb hard drives. They say /dev/sdb(c, d) and the letter
all depends upon which order they're plugged in. My SATA hard
drive is /dev/sda and then next thing I plug in (flash disk in my
example above) will become /dev/sdb. Therefore, when I issued
the above command I mounted it as user, and now user can read/
write to that drive. I'm posting this file in hopes that some of it
makes sense to you, and you can use that knowledge to edit your
file.

Code:
mingdao@james:~$ cat /etc/fstab
/dev/sda3        swap             swap        defaults         0   0
/dev/sda1        /                reiserfs    defaults         1   1
/dev/sda2        /home            reiserfs    defaults         1   2
/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
###I added this from paul's fstab, in case it bombs we know why
#/dev/hda5        swap             swap        defaults         0   0
#/dev/hdc6        /                reiserfs    defaults         1   1
#/dev/hdc1        /boot            reiserfs    defaults         1   2
#/dev/hdc2        /home            reiserfs    defaults         1   2
#/dev/hdc3        /usr             reiserfs    defaults         1   2
#/dev/hdc5        /var             reiserfs    defaults         1   2
#/dev/hdc7        /tmp             reiserfs    defaults         1   2
#/dev/hdc8        /distro          reiserfs    defaults         1   2
/dev/hda1        /XP              ntfs        user,umask=1000,ro,auto      1   0
/dev/hda2        /PROGRAMS        ntfs        user,umask=1000,ro,auto      1   0
/dev/hda3        /DATA            vfat        user,umask=1000,rw,auto      1   0
###added these for usb devices
#/dev/sda1        /mnt/sda1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdb1        /mnt/sdb1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdc1        /mnt/sdc1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdd1        /mnt/sdd1        vfat        user,umask=1000,rw,noauto 0 0
I deleted the entries for my CD-RW and DVD+/-RW from the previous
machine, because I used them with scsi emulation with kernel 2.4.26.
 
Old 09-25-2004, 07:13 PM   #13
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
I see from your dmesg output that you have Seagate 80GB
ATA drive, a Maxtor SCSI drive, a Flash disk, a DVD-ROM and
a DVD-RW - at least. Is that correct?
yes, that is correct.

Quote:
(1) you said when you mounted it you were given this:
mount: block device /dev/hdc is write-protected, mounting read-only
but that's not an error, just an informational message. It says
you can read, but not write, to the drive. That comes from the
line in /etc/fstab where you have ro rather than rw.
In my fstab, the line concerning my DVD-RW is:

Quote:
/dev/hdc /mnt/dvd auto rw,noauto,users,exec 0 0
as far as I understand, the rw should take care of the ability to write, no? I am still getting the mount: block device /dev/hdc is write-protected, mounting read-only message whenever I mount the drive.

Quote:
(2) you know how to mount it, obviously, but to unmount it you issue
"umount /mnt/dvd" if that's the directory where it's mounted. And
yes, there is only one n in the umount command.
I changed permissions to allow non-root umounting, so that's all taken care of.

Quote:
(3) K3b may be all you need to burn CD/DVDs with your present
setup, but I can't answer that yet. Once you've changed your
/etc/fstab to rw, see if you have a menu where you can find
the K3b program. I don't know what apps are available in
Yoper. You could also issue locate k3b | grep '/k3b$'
in a terminal.
yup, I have k3b all setup & I'm quite familiar with it from using other distros. great app, if you ask me

Quote:
Below is my present /etc/fstab, mostly from the other comp. I'll be
working on it today, but those last entries are for mounting my
flash and usb hard drives. They say /dev/sdb(c, d) and the letter
all depends upon which order they're plugged in. My SATA hard
drive is /dev/sda and then next thing I plug in (flash disk in my
example above) will become /dev/sdb. Therefore, when I issued
the above command I mounted it as user, and now user can read/
write to that drive. I'm posting this file in hopes that some of it
makes sense to you, and you can use that knowledge to edit your
file.
thanks - I'll take a look at that - hopefully I can learn what I am doing wrong here. I am still not understanding why my fstab is inadequate for writing.

I appreciate your help again chinaman.
cheers
 
Old 09-25-2004, 11:06 PM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
You still have your /etc/fstab file wrong.
Quote:
In my fstab, the line concerning my DVD-RW is:

quote:/dev/hdc /mnt/dvd auto rw,noauto,users,exec 0 0
You don't issue "auto" and "noauto" - those statements conflict.
Just use one or the other, not both, to suit your personal taste.

And I'm not sure the purpose of the exec command. What are
you "executing?" Issue and read "man exec" for more info.

I've learned how to setup /etc/fstab for these drives in 2.6.7
Code:
/dev/hdc         /mnt/cdrw        iso9660     noauto,user,rw   0   0
/dev/hdd         /mnt/dvd         iso9660     noauto,user,rw   0   0
Here's two ways to mount it. Get you an icon on the desktop, insert
a disc into the drive, right-click the icon and choose mount. Then
after it mounts you can click that icon and launch the file browser.

The other way is to use the command line from a terminal and issue

mingdao@james:~$ mount /mnt/dvd
mount: block device /dev/hdd is write-protected, mounting read-only
mingdao@james:~$ ls -alc /mnt/dvd
total 21
dr-xr-xr-x 1 root root 2048 1970-01-01 07:00 ./
drwxr-xr-x 10 root root 240 2004-09-25 22:18 ../
-r-xr-xr-x 1 root root 56 2001-09-26 17:18 AUTORUN.INF*
dr-xr-xr-x 1 root root 2048 2003-09-26 14:27 AutoRun/
-r-xr-xr-x 1 root root 10134 2000-03-09 18:34 CyberLink.ico*
dr-xr-xr-x 1 root root 2048 2003-09-26 14:26 MediaShow/
dr-xr-xr-x 1 root root 2048 2003-09-26 14:23 PowerDVD/
dr-xr-xr-x 1 root root 2048 2003-09-26 14:24 PowerDirector/

mingdao@james:~$ mount /mnt/cdrw
mount: block device /dev/hdc is write-protected, mounting read-only
mingdao@james:~$ ls -alc /mnt/cdrw
total 839
drwxr-xr-x 7 root root 4096 2004-07-08 03:06 ./
drwxr-xr-x 10 root root 240 2004-09-25 22:18 ../
-rw-r--r-- 1 root root 9681 2004-07-08 03:04 ANNOUNCE.10_0
-rw-r--r-- 1 root root 18606 2004-07-08 03:04 BOOTING.TXT
-rw-r--r-- 1 root root 93284 2004-07-08 03:04 CHECKSUMS.md5
-rw-r--r-- 1 root root 189 2004-07-08 03:04 CHECKSUMS.md5.asc
-rw-r--r-- 1 root root 17976 2004-07-08 03:04 COPYING
-rw-r--r-- 1 root root 15234 2004-07-08 03:04 COPYRIGHT.TXT
-rw-r--r-- 1 root root 602 2004-07-08 03:04 CRYPTO_NOTICE.TXT
-rw-r--r-- 1 root root 125321 2004-07-08 03:04 ChangeLog.txt
-rw-r--r-- 1 root root 32425 2004-07-08 03:04 FAQ.TXT
-rw-r--r-- 1 root root 117520 2004-07-08 03:04 FILELIST.TXT
-rw-r--r-- 1 root root 1565 2004-07-08 03:04 GPG-KEY
-rw-r--r-- 1 root root 275105 2004-07-08 03:04 PACKAGES.TXT
-rw-r--r-- 1 root root 12530 2004-07-08 03:04 README.TXT
-rw-r--r-- 1 root root 5191 2004-07-08 03:04 RELEASE_NOTES
-rw-r--r-- 1 root root 14826 2004-07-08 03:06 SPEAKUP_DOCS.TXT
-rw-r--r-- 1 root root 15434 2004-07-08 03:06 SPEAK_INSTALL.TXT
-rw-r--r-- 1 root root 70561 2004-07-08 03:06 Slackware-HOWTO
-rw-r--r-- 1 root root 5136 2004-07-08 03:06 UPGRADE.TXT
drwxr-xr-x 2 root root 4096 2004-07-10 02:32 bootdisks/
drwxr-xr-x 3 root root 2048 2004-07-12 05:35 isolinux/
drwxr-xr-x 20 root root 4096 2004-07-11 23:46 kernels/
drwxr-xr-x 2 root root 4096 2004-07-08 03:04 rootdisks/
drwxr-xr-x 15 root root 4096 2004-07-08 03:06 slackware/

Great! They mount!

So I guess it's going to mount it read-only, since I'm using a disc that's
already written to and closed. Additionally, there are some filesystems
that can't be read unless you compile support into the kernel, such as
the cdfs filesystem. To play regular audio CDs, which are .cda files, what
I do is install this xmms-cdread-0.11d.tar.gz and then xmms will read the
CDs and play them.

I don't have K3b on this comp. I'll d/l and compile it tomorrow. Then I can
tell you how to burn CDs and DVDs - or maybe you can tell me. I did check
the dependencies and I have everything except vcdimager for reading and
copying VCDs.

But for this issue
Quote:
as far as I understand, the rw should take care of the ability to write, no?
I am still getting the mount: block device /dev/hdc is write-protected,
mounting read-only message whenever I mount the drive.
my mind wasn't focused, and I wandered off the path. These drives will not be
written to as a normal drive, so you will not "mount" them to write to them.
Writing will be done by K3b, if you desire. I also believe that cli apps such
as cdrecord will write to them, I'm just not sure how now that I've changed
to a 2.6.x kernel. After all, K3b is just a gui frontend for cdrecord and other
apps, it doesn't do anything without them.

If I remember correctly what I read in K3b, the permissions for writing to the
drives are given to cdrecord. That being correct, it shouldn't matter whether
you give rw or ro in the line in /etc/fstab but maybe with ro you won't get that
informational message. So I don't think your fstab is exactly inadequate for
writing, but rather, the way it's done in the 2.6.x kernels.

I'll check more tomorrow. It's Sunday here, and I'm supposed to be "resting
from my work."

If you want, you can read about K3b at their website. And don't forget to setup
your DVD-ROM similar to the DVD-RW. Just give it the proper device name.

So, after you change your /etc/fstab like mine above, where is the problem?
Can you mount and read discs? Do you have ISO 9660 CD-ROM filesystem
support in your kernel? And you will need to get the latest versions of both
Kb3 and cdrecord, because earlier versions did not know how to work with
ide-cd and thus you had to load ide-scsi anyway.
 
Old 09-26-2004, 01:03 AM   #15
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
So I guess it's going to mount it read-only, since I'm using a disc that's
already written to and closed.
even with blank dvds/cds or written dvd-rw/cd-rw (discs that should be able to write to), I still get mount: block device /dev/hdc is write-protected, mounting read-only No matter what disc I put it, I still get this message. I havent tried to actually burn a disc yet, but I will try soon.

If the message comes at no consequence and I am able to burn all disc types, why does it always have to pop up and tell me? how I can prevent it from coming up?

as for my trouble umounting:

sure, I can mount/umount in the konsole but it would be nice (and easier for the family) to be able to simply click the dvd icon to mount and then right-click "umount" - how can I simply configure this so that non-root can umount? Right now, non-root can mount but root is needed to umount - this doesnt seem very intuitive and surely there must be a way so that all users can mount/umount via kde.

here is my current fstab:

Quote:
# Begin /etc/fstab

# filesystem mount-point fs-type options dump fsck-order

/dev/fd0 /floppy auto rw,exec,noauto,users 0 0
/dev/cdrom /mnt/cdrom/ iso9660 noauto,user,rw 0 0
none /dev/pts devpts gid=4,mode=620 0 0
none /proc proc defaults 0 0
/dev/hda2 / reiserfs notail,noatime 1 1
/dev/hda1 swap swap defaults 0 0
/dev/hda3 /home reiserfs notail,noatime 1 1
/dev/hdc /mnt/dvd iso9660 noauto,user,rw 0 0
/dev/sda1 /external reiserfs defaults,user,noauto 0 0
regardless of the changes I made (getting rid of auto/nonauto), I still get these messages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble mounting DVD/CDRW BobCobb Linux - Newbie 6 11-01-2005 11:38 PM
Trouble mounting an external dvd-rw drive zirtik Linux - Hardware 2 07-12-2005 05:03 AM
Mounting :: DVD, CD, USB.. do we need to configure etc/fstab? Swakoo Linux - Newbie 4 04-29-2005 02:58 AM
Trouble mounting DVD Burner shadow13 Linux - Hardware 5 12-04-2004 09:36 AM
trouble mounting NEC DVD +/-RW nirva Linux - Hardware 0 04-29-2004 03:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration