LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-26-2004, 07:48 AM   #16
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128

The reason you still get the message is because you still have rw in
the line, and they can only mount ro. I just changed rw to ro for both
my drives in /etc/fstab and as I alluded to before, that made the
informational message disappear.

I don't know where to get the documentation, but I can tell you this.
You cannot write directly to a CD-RW or DVD+/-RW drive using
Linux, nor Windoze, for that matter. They must use some app to do
it - some software must turn on the lasers Scotty!, or the job is
not going to get done.

Don't let this mount issue get you off track. For the purpose of looking
at a CD/DVD, just mount the thing. When you want to burn, you'll have to
use a program to accomplish that. It's either K3b or something else, K3b
being simply a frontend (IMO) for the real software which is actually doing
the burning. But note this: we didn't "mount" the devices in the 2.4.x and
prior kernels before burning, and you won't "mount" them to burn now.

Look at this output. I only post it so you can see the command, given properly:
Code:
mingdao@james:~$ mount /mnt/dvd
mingdao@james:~$ ls -alc /mnt/dvd
total 21
dr-xr-xr-x   1 root root  2048 1970-01-01 07:00 ./
drwxr-xr-x  10 root root   240 2004-09-25 22:18 ../
-r-xr-xr-x   1 root root    56 2001-09-26 17:18 AUTORUN.INF*
dr-xr-xr-x   1 root root  2048 2003-09-26 14:27 AutoRun/
-r-xr-xr-x   1 root root 10134 2000-03-09 18:34 CyberLink.ico*
dr-xr-xr-x   1 root root  2048 2003-09-26 14:26 MediaShow/
dr-xr-xr-x   1 root root  2048 2003-09-26 14:23 PowerDVD/
dr-xr-xr-x   1 root root  2048 2003-09-26 14:24 PowerDirector/
mingdao@james:~$ umount /mnt/dvd
mingdao@james:~$

mingdao@james:~$ mount /mnt/cdrw
mingdao@james:~$ ls -alc /mnt/cdrw
total 1714
dr-xr-xr-x   1 root root    2048 2004-01-16 10:32 ./
drwxr-xr-x  10 root root     240 2004-09-25 22:18 ../
-r-xr-xr-x   1 root root     671 2004-01-09 17:29 AUTORUN.INF*
dr-xr-xr-x   1 root root    2048 2004-01-15 10:10 Content/
dr-xr-xr-x   1 root root    4096 2004-01-15 10:10 CoverDesigner/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:11 EasyWrite\ Reader/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:11 InCD\ 4/
-r-xr-xr-x   1 root root   12390 2003-03-13 01:27 NERO.ICO*
dr-xr-xr-x   1 root root    2048 2004-01-15 10:11 Nero\ BurnRights/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:11 Nero\ Media\ Player/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:12 Nero\ OEM/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:14 NeroVision\ Express\ 2\ SE/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:16 ODD\ Toolkit/
dr-xr-xr-x   1 root root    2048 2004-01-15 10:21 USB_RW_Driver/
-r-xr-xr-x   1 root root 1716224 2003-09-19 21:54 setup.exe*
mingdao@james:~$ umount /mnt/cdrw
mingdao@james:~$

mingdao@james:~$ cat /etc/fstab
/dev/sda3        swap             swap        defaults         0   0
/dev/sda1        /                reiserfs    defaults         1   1
/dev/sda2        /home            reiserfs    defaults         1   2
#/dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0   <-- notice I have this commented out
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
/dev/hdc         /mnt/cdrw        iso9660     noauto,user,ro   0   0
/dev/hdd         /mnt/dvd         iso9660     noauto,user,ro   0   0
###I added this from paul's fstab, in case it bombs we know why
#/dev/hda5        swap             swap        defaults         0   0
#/dev/hdc6        /                reiserfs    defaults         1   1
#/dev/hdc1        /boot            reiserfs    defaults         1   2
#/dev/hdc2        /home            reiserfs    defaults         1   2
#/dev/hdc3        /usr             reiserfs    defaults         1   2
#/dev/hdc5        /var             reiserfs    defaults         1   2
#/dev/hdc7        /tmp             reiserfs    defaults         1   2
#/dev/hdc8        /distro          reiserfs    defaults         1   2
/dev/hda1        /XP              ntfs        user,umask=1000,ro,auto      1   0
/dev/hda2        /PROGRAMS        ntfs        user,umask=1000,ro,auto      1   0
/dev/hda3        /DATA            vfat        user,umask=1000,rw,auto      1   0
###added these for usb devices
/dev/sdb1        /mnt/sdb1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdc1        /mnt/sdc1        vfat        user,umask=1000,rw,noauto 0 0
/dev/sdd1        /mnt/sdd1        vfat        user,umask=1000,rw,noauto 0 0
No runs, drips, or errors! And they work with the little icons on the
desktop just as well. Right-click on the icon, select mount, then a little
green arrow appears on the bottom right of the icon. Click on the icon
and view the files with the Konqueror file browser. Close the browser,
right-click on the icon again, choose Unmount, and the arrow disappears.
Right-click on the icon again, choose eject, and the drawer pops open. I
can stick a disc in the drawer, close it, and just click on the icon and it
will open the file browser and mount the device. If it doesn't seem
to unmount it the first time you click, click again. Mine do all manner of
strange things, but they will mount, read, unmount, eject, etc.

I don't know how much simpler it could be, but I still like Fluxbox and cli
lot's better. How did you create the icons on your desktop? This is how
I did it, and it's working here.

First I left-clicked on the little wrench icon on the toolbar,
then I selected Desktop > Behavior and right-clicked that,
then I selected Device Icons and put a checkmark in
Mounted CD Writer, Mounted CD-ROM, Mounted DVD and
Unmounted CD Writer, Unmounted CD-ROM, Unmounted DVD.

You might ask, "Why did you choose 'Mounted CD-ROM and Unmounted
CD-ROM also, when the other choices are correct for the devices?"
The answer: because the icons didn't show up with only CD Writer and
DVD selected. They only showed up after I selected CD-ROM too.
Now, do you see why I prefer the cli? I call this a bug - KDE probably
calls it a "feature." Either way, it's incorrect, illogical, and impractical.
Which is my opinion of guis. But, I'm trying to help you and your family.

NB: Don't forget you also need to make your regular DVD mount as a
drive (/dev/hdb) and not as a symlink (/dev/cdrom). In /etc/fstab if I were
you, I would change this
Code:
/dev/cdrom /mnt/cdrom/ iso9660 noauto,user,rw 0 0
to this
Code:
/dev/hdb         /mnt/dvdrom        iso9660     noauto,user,ro   0   0
Maybe even make your SONY DVD-ROM mount to /dev/dvd and your
PIONEER DVD-RW mount to /dev/dvdrw just because IMO that's logical.

Okay, hope this gets you on the right path.
 
Old 09-26-2004, 01:19 PM   #17
sasquatch
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ok, adding ro worked - guess I missed that suggestion.
now, pardon my ignorance - but how exactly do you allow
non-root to umount?

thanks!
 
Old 09-26-2004, 07:50 PM   #18
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Fedora, Gentoo, Ubuntu (all servers at work are openSUSE)
Posts: 6,931

Rep: Reputation: 128Reputation: 128
Quote:
Originally posted by sasquatch
ok, adding ro worked - guess I missed that suggestion.
now, pardon my ignorance - but how exactly do you allow
non-root to umount?

thanks!
I've gone back and re-read your posts. Seems I wasn't reading
the information correctly.
Quote:
mount /dev/scd0 is not a valid block device
We fixed that. The device is /dev/hdc and the filesystem /mnt/dvd
and we're now mounting it correctly with "$ mount /mnt/dvd" but got
Quote:
mount: block device /dev/hdc is write-protected, mounting read-only
which simply told us this device is a read-only device. So we
changed rw to ro and got rid of that message.

The next thing we see is
Quote:
Could not unmount device.
The reported error was:
umount: only root can unmount /dev/hdc from /mnt/dvd
which means you're tyring to unmount a device rather than a
filesystem on a directory. So you should issue "umount <directory>"
which in this case would be "umount /mnt/dvd" to unmount it.

NB: I have the option user which allows only the user who mounted
the filesystem to unmount it. The option users allows every user to
mount and unmount the file system.

If user sasquatch has mounted a filesystem, and a different user
(i.e. mingdao) is trying to unmount it, then you need to change
user to users in /etc/fstab.

If this doesn't address the present problem unmounting the filesystem,
please post the exact output of the command you are issuing and use
the -v switch to get verbose output - which I believe should be
"$ umount -v /mnt/dvd"

If it works correctly in a terminal, but doesn't work correctly in KDE,
then the issue is with whatever gui frontend KDE uses to mount and
unmount the device. But please do it in a terminal so that we can
actually see if your system calls are working correctly. If so, then
you've eliminated that and you can go on to find out why the KDE
guis don't work.
 
Old 09-27-2004, 01:47 AM   #19
ernesto_lelo
Member
 
Registered: Oct 2003
Posts: 49

Rep: Reputation: 15
I seem to have the same problem here. I was about the edit the fstab but when I tried to get the iformation from my dmesg file I foud a problem...

Here is a copy of my dmesg file:

hda: ST340823A, ATA DISK drive
hdb: LITE-ON LTR-52246S, ATAPI CD/DVD-ROM drive
blk: queue c03b3360, I/O limit 4095Mb (mask 0xffffffff)
hdc: WDC WD400EB-00CPF0, ATA DISK drive
hdd: JLMS DVD-ROM LTD-166S, ATAPI CD/DVD-ROM drive
blk: queue c03b37b4, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 78165360 sectors (40021 MB) w/512KiB Cache, CHS=4865/255/63, UDMA(100)
hdc: attached ide-disk driver.
hdc: host protected area => 1
hdc: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=77545/16/63, UDMA(33)
hdb: attached ide-cdrom driver.
hdb: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)


Now, the problem here is that both the DVD and the CD-R/RW are listed under hdb

What do I do???
 
Old 09-27-2004, 02:04 AM   #20
ernesto_lelo
Member
 
Registered: Oct 2003
Posts: 49

Rep: Reputation: 15
Here is a copy of my modified fstab:

/dev/hdc2 swap swap defaults 0 0
/dev/hdc1 / reiserfs defaults 1 1
/dev/hda1 /WindowsXP ntfs ro 1 0
/dev/hdd /mnt/dvd iso9660 noauto,owner,ro 0 0
/dev/hdb /mnt/cdrw iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


assuming hdd is my dvd and hdb is my cd-r/rw

when I try to mount any of the drivers I get the following error message:

mount: wrong fs type, bad option, bad superblock on /dev/hdb,
or too many mounted file systems

Any suggestion?
 
Old 09-27-2004, 03:09 AM   #21
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Mounting CD-ROM or DVD-ROM as read-write will not work hence they are read-only. To make a CD or DVD, use cdrecord or dvdrecord. You may need to upgrade cdrecord and dvdrecord so they can work properly under kernel version 2.6.x. Also from looking at the previous posts. It seems your PATH variable is not setup properly. You should have something like "/bin:/usr/bin:/usr/local/bin:/usr/local/sbin:~/bin" when you type "echo $PATH".

Your fstab file should have:

# PIONEER DVD-RW DVR-105
/dev/hdc /mnt/cdrom auto ro,users 0 0
# SONY DVD-ROM DDU1612
/dev/hdb /mnt/dvd auto ro,users 0 0

ernesto_lelo:
Change iso9660 to auto. Also take out owner and in its place add users. From your first post, your DVD drive is at hdd and the CD-RW is at hdb.

BTW, It took two pages for Chinaman to answer a mount problem.
 
Old 09-27-2004, 07:50 AM   #22
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
ernesto_lelo,

We truly should express that when you start asking questions in others threads they have started to seek answers is looked down upon in most cases, especially if they haven't come to a resolution for their problem. Some call it hijacking the thread. As its not part of our stated rules, we ask members not to do this and start new threads with their own questions they may have, even if its the exact problem in the thread you've so-called "hijacked"

If you have any questions or concerns, feel free to email me, another moderator or the site admin.

Thanks.

Last edited by trickykid; 09-27-2004 at 07:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble mounting DVD/CDRW BobCobb Linux - Newbie 6 11-02-2005 12:38 AM
Trouble mounting an external dvd-rw drive zirtik Linux - Hardware 2 07-12-2005 06:03 AM
Mounting :: DVD, CD, USB.. do we need to configure etc/fstab? Swakoo Linux - Newbie 4 04-29-2005 03:58 AM
Trouble mounting DVD Burner shadow13 Linux - Hardware 5 12-04-2004 10:36 AM
trouble mounting NEC DVD +/-RW nirva Linux - Hardware 0 04-29-2004 04:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration