LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-06-2004, 06:08 AM   #1
pixelution
LQ Newbie
 
Registered: Mar 2004
Location: Hitchin, UK
Distribution: Suse 9
Posts: 4

Rep: Reputation: 0
Question Suse9 64 bit wont boot with 6 GB RAM


I've built a dual AMD64 machine with 4 GB RAM, using Tyan Tiger m/b. Installed SUSE 9 64 bit distribution and it works fine. Added another 2 GB of RAM to take RAM to 6 GB and it fails to boot with many addressing errors, followed by kernel panic.

The BIOS correctly reports 6 GB of RAM. I guess I have to recompile the kernel with a 'big memory' flag of somesort, but nowhere have I been able to find what this should be, not being that much of a Linux expert.

Any suggestions gratefully received.
 
Old 03-06-2004, 08:00 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
When you configure the kernel using menuconfig or whatever you use, the high memory option is in Processor type and features. Your options are off, 4GB and 64GB. With your setup you'd need to set it to 64GB.


Håkan
 
Old 03-07-2004, 07:49 AM   #3
pixelution
LQ Newbie
 
Registered: Mar 2004
Location: Hitchin, UK
Distribution: Suse 9
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the reply but when I look in menuconfig->Processor types and features I see no option relating to high memory - the nearest option is MTRR (Memory type range registry support) but that is already built in anyway. Am I missing something obvious?
 
Old 03-07-2004, 03:29 PM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Are you using a 2.6 series kernel? You should go with 2.6.3 or higher since it has better support for the AMD6 and stuff you probably want, like the option to use a preemptible kernel and high memory support.


Håkan
 
Old 03-07-2004, 03:44 PM   #5
pixelution
LQ Newbie
 
Registered: Mar 2004
Location: Hitchin, UK
Distribution: Suse 9
Posts: 4

Original Poster
Rep: Reputation: 0
That's probably the problem then - I think I'm using 2.4.22 because that was what was on the SUSE distro I bought. So is it straight forward to upgrade to 2.6.3 or above - I presume I have to download it from somewhere?

Many thanks for your help.

Giles
 
Old 03-07-2004, 04:43 PM   #6
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Upgrading to 2.6 kernel is hard and time consuming. First you need to gather what additional modules (drivers) that you have installed such as nvidia, vmware, controllers, etc. Go to kernel.org and download the full 2.6 kernel version instead of patches. Decompress the kernel file in /usr/src. As root you probably want to run "make oldconfig" so that some of the options are carried over from your old kernel to your new kernel. The link below is the one that I used. Its easy to follow and it explains what you are doing for each step.

http://www.justlinux.com/nhf/Compili...mpilation.html

Upgrading to the new kernel may make more problems than correcting problems. I suggest re-compile the kernel that you have and set the memory to 64 GB and hi-mim support. If this corrects the problem than you can try compile the 2.6 kernel, but make a backup of the old modules and kernel image in the /boot directory.

Good luck compiling
 
Old 03-07-2004, 05:05 PM   #7
pixelution
LQ Newbie
 
Registered: Mar 2004
Location: Hitchin, UK
Distribution: Suse 9
Posts: 4

Original Poster
Rep: Reputation: 0
When you say :

I suggest re-compile the kernel that you have and set the memory to 64 GB and hi-mim support

just how do I do that?, because looking through all the config options I do not see anything that relates to hi-mem or similar. Am I misunderstanding where to look, or what to do. I've tried looking in the config file directly or using make menuconfig but I fail to see any flag relating to high memory.

Many thanks for your help

giles
 
Old 03-08-2004, 05:22 PM   #8
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Open up the terminal and login as su or as root. Go into the kernel's directory and type make config if your are in the terminal but not running X Window Server. If you are running X Window Server type make xconfig. Click on the "Processor type and features". Then click on "High Memory". Select 64 GB.

You need tcl/tk installed before using the xconfig. Though your distribution should already have it installed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't boot AMD64X2 with SUSE9.3 64-bit Lindley Worthington Linux - Software 1 10-14-2005 05:45 AM
Trouble installing SuSE9 because of low RAM cbjhawks Linux - General 2 03-02-2005 03:52 PM
64-bit Suse9.1 on HD1, need WinXP on HD2 sharkcatcher Linux - Newbie 4 01-22-2005 02:16 PM
4GB RAM: 64-bit Opteron Problems deviance99 Linux - Hardware 6 06-22-2004 09:24 PM
Suse9.0 Pro (AMD64) RAM problem amwassil Linux - Distributions 2 03-24-2004 11:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration