Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 03-07-2006, 04:46 PM   #1
LQ Newbie
Registered: Feb 2005
Posts: 21

Rep: Reputation: 15
Printer Driver (and printer) install errors.

First off, i'm trying to install my HP Deskjet 970c, hooked up to the parallel port. I'm running slackware 9.1, with kernal 2.4.26, and KDE 3.2.3. I'm trying to install the HPIJS 2.1.4, but when i try to "make install", i get an error message after a few seconds.

make[2]: Entering directory `/root/Packages/Installed/HP Drivers/hpijs-2.1.4'
/root/Packages/Installed/HP Drivers/hpijs-2.1.4/install-sh -d /usr/share/ppd/HP
make[2]: /root/Packages/Installed/HP: Command not found
make[2]: *** [install-foomatic] Error 127
make[2]: Leaving directory `/root/Packages/Installed/HP Drivers/hpijs-2.1.4'
make[1]: *** [install-data-am] Error 2
make[1]: Leaving directory `/root/Packages/Installed/HP Drivers/hpijs-2.1.4'
make: *** [install-am] Error 2

I'm also getting the error "unknown URI" when i try to run CUPS, and select parallel for the connection typel.

For the record, my printer IS supported by both files, according to
Old 03-07-2006, 05:17 PM   #2
Gentoo Developer
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Is there anything there;
ls /usr/share/ppd
is foomatic installed?
ls /usr/sbin/foomatic-*
Old 03-07-2006, 05:30 PM   #3
LQ Newbie
Registered: Feb 2005
Posts: 21

Original Poster
Rep: Reputation: 15
/usr/share/ppd: looks like it has all kinds of HP drivers in it

foomatic does not appear to be installed. idid cat /usr/sbin/foomatic-*, and it said it could not be found.
Old 03-07-2006, 06:54 PM   #4
LQ Newbie
Registered: Feb 2005
Posts: 21

Original Poster
Rep: Reputation: 15
update: downloaded and compiled foomatic 3.0.2 Is there anything else i need to do to get foomatic up and running?
Old 03-07-2006, 07:02 PM   #5
LQ Newbie
Registered: Feb 2005
Posts: 21

Original Poster
Rep: Reputation: 15
still get "empty URI" after foomatic install. However, all drivers are updated from foomatic database.

when i type cat /proc/sys/dev/parport/parport*/autoprobe*, i get nothing, until i type:

modprobe -r lp parport_pc parport
modprobe lp

then, when i cat the parallel port, i get:

DESCRIPTION:Hewlett-Packard DeskJet 970C;

however, CUPS still says that the URI is empty.
Old 03-07-2006, 07:16 PM   #6
LQ Newbie
Registered: Feb 2005
Posts: 21

Original Poster
Rep: Reputation: 15
disregard this post, i downloaded the latest version of CUPS and ran the CUPS installer, and under parallel, lp0 showed up. I selected this as the location, and the foomatic driver (hpijs foomatic) for the printer, and tried a test page, and it worked great.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install a driver for my printer? Lucas10 Linux - Software 13 08-30-2005 05:29 PM
install printer driver comprookie2000 Red Hat 3 02-22-2004 12:27 PM
install the driver of my printer jeanrev Linux - Hardware 1 08-13-2003 03:30 PM
Install driver for printer futurist Linux - General 1 03-17-2003 01:24 AM
how do i make redhat recognize my printer new printer driver Kilahchris Linux - General 2 03-04-2003 05:08 PM

All times are GMT -5. The time now is 07:41 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration