LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-16-2006, 06:54 PM   #1
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Mint, Ubuntu server, FreeBSD, Android
Posts: 362

Rep: Reputation: 32
getting both video & audio from saa7133 tv card to divx file


Hi all,

I would like to rip a collection of vhs tapes to divx format, and I have a couple questions about audio.

I added a Pinnacle PCTV 40i card to my Fedora Core 5 system and the kernel recognized it w/o a problem. For some reason, the patch cable from the video card to the sound card does not seem to work, so I tried using sox:

Code:
sox -r 32000 -w -t ossdsp /dev/dsp2 -t ossdsp /dev/dsp
and for watching tv this works fine. However, when I try something like this:
Code:
mencoder tv:// -tv driver=v4l2 -ovc xvid -oac mp3lame -xvidencopts pass=1 -o <fileout>.avi
I get an divx file but has no sound.

Likewise, I have connected my vcr to the sound card via a scart adapter one the vcr and cable to the composite input on the tv card. When I play back a tape and switch to composite as input in tvtime, I see the vhs output onscreen, but without sound. How do I get the audio into the mixture, ideally to the point where I can grab it with mencorder together with the video? There is a mono audio output on the scart adapter, what looks like an RCA jack.

One last question: how does audio work with the Hauppauge cards? Do you also have use the cable between the sound card and the tv card to get sound?

Thanks.
 
Old 08-17-2006, 01:37 PM   #2
soggycornflake
Member
 
Registered: May 2006
Location: England
Distribution: Slackware 10.2, Slamd64
Posts: 249

Rep: Reputation: 31
I have an old Hauppage bt848 card, I have a cable from the line-out on the tv card to the line-in on my sound card.
I assume you've checked that it's not something trivial like line-in being muted?

Also, make sure you've got all the correct modules loaded, I need the oss bt848 mixer module (Device drivers->Sound->Open Sound System->TV card (bt848) mixer support), though you may have a different audio device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD, DiVX, AVI, VCD on SUSE 10.1-video jumpy, audio OK riba43 SUSE / openSUSE 6 06-16-2006 07:09 PM
Video Playback-speeded up audio & video howone SUSE / openSUSE 1 10-20-2005 02:24 AM
Problems with Audio & Video robgenna MEPIS 1 06-05-2005 11:48 PM
Splitting video from audio in divx Hammett Linux - Software 5 05-11-2004 08:44 PM
Phillips SAA7133/7134 card wont work arimus25 Mandriva 2 04-02-2004 11:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration