LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-11-2012, 03:48 AM   #1
m_kane
Member
 
Registered: Jan 2009
Posts: 31

Rep: Reputation: 2
modify module parameters after suspend.. how?


I have strange problem. Alsa uses by default power save in my sound card, what causes cracking noise. I can disable it by running:

sudo sh -c "echo '0' > /sys/module/snd_hda_intel/parameters/power_save"

But after I suspend and wake up machine, it is restored to 10..
I have tried almost everything. I put this to modprobe.conf:

options snd_hda_intel power_save=0

But still 10 after suspend..
Then I tried to add command to /etc/pm/sleep.d/sleep_commands file.
(This file is created by me, it sets pidgin state after suspend and sets correct time.)

sudo sh -c "echo '0' > /sys/module/snd_hda_intel/parameters/power_save"

I checked system log, that command is executed:

Mar 11 09:28:01 BlueGene sudo: root : TTY=unknown ; PWD=/usr/lib/hal/scripts ; USER=root ; COMMAND=/bin/sh -c echo '0' > /sys/module/snd_hda_intel/parameters/power_save

But still 10..

I have no clue how to get this working..
 
Old 03-11-2012, 03:58 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
The scripts in /etc/pm/sleep.d are run by root so you don't need the sudo. IDK if using it would prevent the command from working but you could try changing it to echo '0' > /sys/module/snd_hda_intel/parameters/power_save
 
Old 03-11-2012, 04:42 AM   #3
m_kane
Member
 
Registered: Jan 2009
Posts: 31

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by catkin View Post
The scripts in /etc/pm/sleep.d are run by root so you don't need the sudo. IDK if using it would prevent the command from working but you could try changing it to echo '0' > /sys/module/snd_hda_intel/parameters/power_save
Thanks for response.
Unfortunately it did not help.
But I resolved problem. I disabled power save in kernel settings and recompiled..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
module parameters joeldavis Linux - Kernel 1 04-17-2011 05:44 PM
Modify kernel boot parameters? HighLife Red Hat 2 08-16-2007 10:05 PM
how to set module parameters lordofring Programming 2 09-02-2005 07:07 AM
initrd - module parameters diamondT Linux - General 0 09-03-2003 03:39 AM
Modify Kernel Parameters. Need Help! LenkaNguyen Linux - General 1 12-07-2001 01:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 01:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration