LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-01-2003, 09:43 PM   #1
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Rep: Reputation: 30
Angry FTP Server


i can't seems to get my FTP server goin under slackware 8.1.....can anyone help me on how 2 configure everything from top 2 bottom....... oh, and i use xinetd.
 
Old 01-01-2003, 10:50 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
What ftp server are you using ? Well what have you tried so far ? There are many docs and howto's out there, are you really going to make someone explain how to setup an FTP from top to bottom when its already explained in the docs most likely ?
 
Old 01-02-2003, 03:04 PM   #3
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
ok, i already convert inetd to xinetd, enable all access except letting ppl write, i have a ftp directory in /home/ and i can share directory on a user, bot not in root, and most of HOWTO is not for slackware.... a lot of commands doens't work on my slackware8.1, and most of it doesn't tell me from top 2 bottom, it jumped around so i might be missing that and that... so i dunno wut 2 do now
 
Old 01-02-2003, 03:40 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Okay, you still didn't give us the FTP server your using. Is it the proftpd server that comes with Slack or are you using a different one ?

Not sure what you mean by "i have a ftp directory in /home/ and i can share directory on a user, bot not in root" <--- the bot not in root ?
 
Old 01-02-2003, 04:07 PM   #5
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
Smile thanx 4 helping me


yes im using proftpd, i and i mean like one of my user name is punkshark, so if i log into punkshark and share i directory, it says itz sharing (but i doubt it), and when i login as root, and i try to share a directory, it said failed. so i am pretty sure i need 2 be root inorder 4 my ftp 2 be ^, and i dun wanna configure so i can be a user and ftp still be ^.
Right now i just want to get my ftp server ^ running and working
 
Old 01-02-2003, 05:45 PM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
What do you mean when you refer to sharing a directory ? FTP you have a home directory, either set for anonymous login or it will be the users home directory ?
 
Old 01-02-2003, 06:49 PM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Hi Henry I am confused as well. To get your FTP up there are a few things you'll need to do. First, edit your /etc/proftpd.conf file to suit your needs. If you need help with that, here's what mine looks like:
ftp://masterc.no-ip.org/share/proftpd.conf

I allow anonymous ftp. In order to do that, you'll wanna create a user ftp:
adduser ftp
Make them part of the ftp group (Not too sure if this is needed, but works for me).
Then open up /etc/ftpusers and comment out the ftp user.

I am probably missing something, but I think that's it. Proftpd is probably already running on your box, if not, run it with:
proftpd
Then it should be good to go.

Now for someone to ftp into your box, they'll need to either:
ftp://x.xx.xxx.xx
Where the X's represent your IP; OR
Get a DNS (?). I know little to jack about networking so I appologize if I get this stuff wrong. Anyway, it's the name.com associated with your IP. Then people can access your box with:
ftp://yourDNS.com
Where yourDNS is the one you've picked up.

Ok, I guess that's it.

Oh, and so for sharing to the anonymous, you'll place the files in /home/ftp (unless you've specified elsewhere in your proftpd.conf file)

Cool
 
Old 01-03-2003, 03:19 PM   #8
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
thanx, but i already did all those stuff u said, i even convert inetd to xinetd cuz my friend said itz better. but it's stilll not working..like when i put directory into the user ftp, and do rite click=>properties=>click sharing=>click share app, it says it failed to share.

i think if it sound as easy as u said, then i think i screwed it ^ on the xinetd converting,i did this:


cat /etc/inetd.conf | ./xconv.conf > /etc/xinetd.conf

im pretty sure this is right... and if i need 2 do anything after this, i didn't do it. cuz i dunno wut 2 do now

Last edited by Henry; 01-03-2003 at 03:40 PM.
 
Old 01-03-2003, 03:59 PM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Quote:
Originally posted by Henry
thanx, but i already did all those stuff u said, i even convert inetd to xinetd cuz my friend said itz better. but it's stilll not working..like when i put directory into the user ftp, and do rite click=>properties=>click sharing=>click share app, it says it failed to share.
This makes no sense on what your trying to accomplish or do ?

If you have an FTP directory setup, and depending on the permissions of the files within that directory will make any file you place there accessible thru FTP.
 
Old 01-03-2003, 05:58 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Right click? Welcome to the command line, it's your buddy. What are you using to administer this?

Could you please tell us everything you've done, exactly what you want to do, and then maybe we can help a bit more. I just went back and reread all your messages, I am sure it's not on purpose, but every message almost seems "cryptic" in a way. Like you don't want us to know something?

Anyway, yeah, let us know at the very least exactly what you want: An anonymous ftp server, NO anon server, SSH server, OR WHAT? And how you'd like this server running; always, only certain times, what?

Cool
 
Old 01-03-2003, 07:40 PM   #11
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
i would like to run this ftp server when my computer is ^, and i want it to be a anonymouse ftp server, herez wut i have done so far:

1.setup ftp user directory in /home/, which is /home/ftp
2.went to the ftpuser file and deleted the ftp under the users
3.convert inetd into xinetd by DLing xinetd and do this command:
cat /etc/inetd.conf | ./xconv.conf > /etc/xinetd.conf
4. set the proftpd.conf like this:
# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName "ProFTP Punkshark Style"
#ServerType standalone
ServerType xinetd
DefaultServer on

# Port 21 is the standard FTP port.
Port 21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog /var/log/proftpd.log
TransferLog /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on
</Directory>

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
<Anonymous ~ftp>
RequireValidShell off
User ftp
Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 50

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>

# An upload directory that allows storing files but not retrieving
# or creating directories.
# <Directory incoming/*>
# <Limit READ>
# AllowAll
# </Limit>
#
# <Limit STOR>
# AllowAll
# </Limit>
# </Directory>

</Anonymous>



ftp don't work:
1.can't share files
2.can't connect to the ftp server when i go to my mozilla and typed ftp://<ip>


oh and one more thing, i can't connect to the sever w/ router and w/out router. of course i use the ip that i get when i do ifconfig.
IF it ever work, how do i configure the ftp server so it can run under router connection?

Last edited by Henry; 01-03-2003 at 07:42 PM.
 
Old 01-04-2003, 06:20 PM   #12
Blitzkrieg
LQ Newbie
 
Registered: Nov 2002
Distribution: RH8+SuSe8
Posts: 27

Rep: Reputation: 15
Quote:
2.can't connect to the ftp server when i go to my mozilla and typed ftp://<ip>
don't use mozilla to connect to yout ftp server. try with an ftp client like gftp or other
 
Old 01-14-2003, 11:09 PM   #13
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
ok, i got my ftp server working, but how do i share it on the internet w/ a router, cuz i dun wanna just share it inside the router, so is there anyway i can get around the router? i kno what my other ip thatz not 192.168. is, but i dunno how 2 setup the ftp server so it can share outside of my router, i enable all the firewall stuff that might be blocking the ftp, but can someone tell me how to get it thro my router with built-in firewall? my router is a LINKSYS
 
Old 01-15-2003, 01:30 AM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Which linksys (just out of curiosity)? Anyway, you'll need to enable port forwarding (to port 21), and unless there's been some updates since the docs were written, you'll not be able to use the DHCP server function of the router when using port forwarding (meaning you'll need to assign your server an internal IP).

Check out my recent thread regarding problems with my new router (Linksys BEFSR41 ver 2):
http://www.linuxquestions.org/questi...threadid=40355

Cool
 
Old 01-15-2003, 01:44 AM   #15
wldkos
Member
 
Registered: Jan 2003
Distribution: Mandrake 9.2 =<3 and Red Hat 8.0 (server)
Posts: 242

Rep: Reputation: 30
helpful hints

I think that you are impressing no one with the language that you chose to type in. I hope that you weren't offended by that, but it makes it easier to understand if proper spelling and grammar are used. Now aside from my flame, (i appologize) when you type in ftp://Ip address, you must have the port number ex, this is mine ftp://24.186.169.218:1337. That is usually why most of my users mess it up in the logging in process. The port is everything. AND one last thing. I assume that you are using either DSL or Cable (a dialup ftp?). One big thing that you should do, is change your port number to something other than 21, or 22. If you were handling a decent amount of traffic on your server, and you ISP is curious, Your done in reguards to the TOS. I use optimum online and you can't even have kazaa on ur computer cuz it is considered a type of server. So check that out before you start sharing a lot. Hope the small shit was helfpful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp(through web site access to ftp server) kelper Linux - Software 4 07-03-2015 05:14 PM
ftp server - Pure ftp - logs in OK but no files visible tp11235 Linux - Networking 2 08-30-2005 05:11 AM
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 04:24 PM
How do I set my FTP server to accept passive FTP? imsam Linux - Newbie 3 12-12-2004 06:22 AM
how can I restrict ftp users listing files from a pure-ftp server adrianmak Linux - Networking 2 12-31-2002 08:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration