LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 06-16-2005, 05:04 PM   #1
JK_Shark
LQ Newbie
 
Registered: Jun 2005
Posts: 1

Rep: Reputation: 0
ut2004 ati driver problem


hi,
i've installed on my pc ut2004, and i played several times.

i decided install the new driver for my video card and now i can play no more.

My video card is ati radeon mobility 9000.
I've installed the driver from ati website.
My xorg version is 6.8.2-35.1

Each time i start the game there's that problem:

Code:
bash>ut2004
WARNING: ALC_EXT_capture is subject to change!
Couldn't set video mode: Couldn't find matching GLX visual
i tried to reinstall and upgrade packages but the problem persists.

Moreover i've another problem, that i think they they're related:
Code:
bash>fgl_glxgears
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  32
  Current serial number in output stream:  32
what can i do ?
 
Old 07-13-2005, 12:05 PM   #2
koy
Member
 
Registered: Apr 2003
Distribution: SuSe 10
Posts: 55

Rep: Reputation: 15
I've got the same problem with my x600 on pci-e on suse9.3

Code:
fgl_glxgears
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  30
  Current serial number in output stream:  30
and same error message for ut2004 :S
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 1, ATI, and Ut2004 demo problem nscrnbr27 Linux - Hardware 14 09-06-2005 03:49 PM
UT2004 Graphics Problem: Artifacts Everywhere (ATI Radeon Mobility 7500) deadjoebob Linux - Games 16 04-13-2005 06:21 AM
UT2004 xlib error with ATI driver true_atlantis Linux - Software 0 11-29-2004 05:02 PM
ati and ut2004 haamann Linux - Hardware 2 08-02-2004 04:50 PM
ATI driver prolems with UT2004 Russb Linux - Software 1 07-27-2004 08:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration