LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 01-08-2005, 05:07 PM   #1
rvijay
Member
 
Registered: Aug 2003
Location: Quebec, Canada
Distribution: Debian HD install of Knoppix 5.0.1
Posts: 921
Blog Entries: 24

Rep: Reputation: 64
BLFS Trial/Hard Time/Mplayer


I downloaded/installed Mplayer, skin and fonts.

The new default skin is Blue.

I used the following to setup the gui:
cat > /etc/mplayer/mplayer.conf << "EOF"
gui = yes
skin = Blue
EOF

Here is the result:
bash-2.05b$ sudo mplayer
MPlayer 1.0pre4-2.95.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices K6-2 337.9 MHz (Family: 5, Stepping: 12)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX 3DNow

Reading config file /etc/mplayer/mplayer.conf
Please remove gui=yes from your config and run gmplayer if you want the GUI.
Error parsing option gui=yes at line 1
Warning unknown option skin at line 2
bash-2.05b$

I tried replacing Blue in the script for default. Still get the same error.

Please assist.

Thanks.

Vijay
 
Old 01-08-2005, 05:37 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Re: BLFS Trial/Hard Time/Mplayer

Quote:
Originally posted by rvijay
Please remove gui=yes from your config and run gmplayer if you want the GUI.
Kinda says it all. Re-edit your config file, set gui=yes to gui=no and run gmplayer. If you didn't run ./configure --enable-gui when you installed, you will have to start from that point.
 
Old 01-08-2005, 06:39 PM   #3
rvijay
Member
 
Registered: Aug 2003
Location: Quebec, Canada
Distribution: Debian HD install of Knoppix 5.0.1
Posts: 921

Original Poster
Blog Entries: 24

Rep: Reputation: 64
I didnot (include)run the
/ configure --enable-gui
command the first time. Thanks for posinting this out. Now I get a very different output. For the GUI I see there are several dependencies. I need to get them all.

Vijay

Checking for GUI ... yes
Checking for XShape extension ... yes
Checking for gtk version ...
Error: The GUI requires GTK devel packages (which were not found).

Check "configure.log" if you do not understand why it failed.
bash-2.05b#
 
Old 01-08-2005, 06:45 PM   #4
rvijay
Member
 
Registered: Aug 2003
Location: Quebec, Canada
Distribution: Debian HD install of Knoppix 5.0.1
Posts: 921

Original Poster
Blog Entries: 24

Rep: Reputation: 64
Also used gui=no, it didn't help. Please Assist.

Thanks.

Vijay

bash-2.05b# cat > /etc/mplayer/mplayer.conf << "EOF"
> gui = no
> skin = default
> EOF
bash-2.05b# exit
exit
bash-2.05b$ sudo mplayer
MPlayer 1.0pre4-2.95.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices K6-2 337.9 MHz (Family: 5, Stepping: 12)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX 3DNow

Reading config file /etc/mplayer/mplayer.conf
Please remove gui=yes from your config and run gmplayer if you want the GUI.
Error parsing option gui=no at line 1
Warning unknown option skin at line 2
bash-2.05b$
 
Old 01-08-2005, 06:52 PM   #5
rvijay
Member
 
Registered: Aug 2003
Location: Quebec, Canada
Distribution: Debian HD install of Knoppix 5.0.1
Posts: 921

Original Poster
Blog Entries: 24

Rep: Reputation: 64
Command gmplayer doesn't work.

Vijay

bash-2.05b# gmplayer
bash: gmplayer: command not found
bash-2.05b# exit
exit
bash-2.05b$ sudo gmplayer
sudo: gmplayer: command not found
bash-2.05b$
 
Old 01-09-2005, 03:44 AM   #6
BlueSilence
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
The GUI requires GTK devel packages (which were not found).
install GTK+-1.2.10 first
if you want enable-gui
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VMware-trial version-no hard disk master Linux - Software 0 12-11-2004 03:35 PM
MPLAYER just plays 3 sec per time robertoneto123 Linux - Software 4 04-03-2004 11:45 AM
Hard time installing Debian and Mplayer zilaei Linux - Software 3 12-10-2003 04:10 AM
Having a hard time getting mplayer to capture sound from TV tuner Electrode Linux - Software 6 06-17-2003 01:57 AM
Having a hard time capturing from TV card with mplayer Electrode Linux - Software 2 04-30-2003 03:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 10:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration