LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices


Reply
  Search this Thread
Old 06-26-2011, 11:28 AM   #1
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Rep: Reputation: 55
No keyboard/mouse


After a world update I get no keyboard/mouse response either with keyboard/mouse drivers or evdev.
Xserver verson 1.10.2
Input devices in make.conf are "keyboard mouse evdev"
And xserver reports
Code:
[  2996.900] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2996.902] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.465] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) No input driver matching `evdev'
[  2997.465] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.465] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) No input driver matching `evdev'
[  2997.474] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.474] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.474] (EE) No input driver matching `evdev'
[  2997.478] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.478] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.478] (EE) No input driver matching `evdev'
[  2997.480] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.480] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.480] (EE) No input driver matching `evdev'
[  2997.481] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.481] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.481] (EE) No input driver matching `evdev'
[  2997.482] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.482] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.482] (EE) No input driver matching `evdev'
Similar errors without evdev:
Code:
[  2858.563] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2858.565] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[  2858.568] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2858.570] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[  2859.133] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2859.133] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[  2859.133] (EE) No input driver matching `mouse'
[  2859.133] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2859.133] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[  2859.133] (EE) No input driver matching `kbd'
I re-emerged xorg-drivers and xorg-server.
Also xfree86-input-keyboard and xfree86-input-mouse are installed.
Any help/ideas appreciated.
 
Old 06-26-2011, 12:14 PM   #2
segmentation_fault
Member
 
Registered: Sep 2008
Location: Ioannina, Greece
Distribution: Gentoo
Posts: 332

Original Poster
Rep: Reputation: 55
After all re-emerges (xorg-server, xorg-drivers, xf86-input-keyboard/mouse/evdev) and a reboot everything seems to work...
WTF? Maybe some usb initialization stuff? The PC had a bad dream and was not in the right mood? Strange evil machines...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse interrupting keyboard events, can't type while mouse is moving sandaili Linux - Hardware 0 08-04-2008 07:56 PM
Bluetooth mouse and keyboard connect, mouse doesn't work BallsOfSteel Linux - Hardware 2 05-25-2008 02:09 AM
Mouse and Keyboard mtecknology Linux - Hardware 1 06-22-2005 04:14 PM
How to use keyboard as mouse lukecolb Linux - Newbie 3 12-15-2004 04:18 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 10:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo

All times are GMT -5. The time now is 09:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration