LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Gentoo (https://www.linuxquestions.org/questions/gentoo-87/)
-   -   No keyboard/mouse (https://www.linuxquestions.org/questions/gentoo-87/no-keyboard-mouse-888439/)

segmentation_fault 06-26-2011 10:28 AM

No keyboard/mouse
 
After a world update I get no keyboard/mouse response either with keyboard/mouse drivers or evdev.
Xserver verson 1.10.2
Input devices in make.conf are "keyboard mouse evdev"
And xserver reports
Code:

[  2996.900] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2996.902] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.465] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) No input driver matching `evdev'
[  2997.465] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.465] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.465] (EE) No input driver matching `evdev'
[  2997.474] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.474] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.474] (EE) No input driver matching `evdev'
[  2997.478] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.478] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.478] (EE) No input driver matching `evdev'
[  2997.480] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.480] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.480] (EE) No input driver matching `evdev'
[  2997.481] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.481] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.481] (EE) No input driver matching `evdev'
[  2997.482] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2997.482] (EE) Failed to load module "evdev" (module requirement mismatch, 0)
[  2997.482] (EE) No input driver matching `evdev'

Similar errors without evdev:
Code:

[  2858.563] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2858.565] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[  2858.568] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2858.570] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[  2859.133] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2859.133] (EE) Failed to load module "mouse" (module requirement mismatch, 0)
[  2859.133] (EE) No input driver matching `mouse'
[  2859.133] (EE) module ABI major version (11) doesn't match the server's version (12)
[  2859.133] (EE) Failed to load module "kbd" (module requirement mismatch, 0)
[  2859.133] (EE) No input driver matching `kbd'

I re-emerged xorg-drivers and xorg-server.
Also xfree86-input-keyboard and xfree86-input-mouse are installed.
Any help/ideas appreciated.

segmentation_fault 06-26-2011 11:14 AM

After all re-emerges (xorg-server, xorg-drivers, xf86-input-keyboard/mouse/evdev) and a reboot everything seems to work...
WTF? Maybe some usb initialization stuff? The PC had a bad dream and was not in the right mood? Strange evil machines... :D


All times are GMT -5. The time now is 01:41 PM.