LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-15-2005, 12:36 AM   #46
awtoc123
Member
 
Registered: Apr 2002
Location: China
Distribution: Suse 10
Posts: 225

Rep: Reputation: 30

Hi kngharv, no on redhat it works first time WITHOUT any extra fiddling, just install scim & scim-chinese plus scim-tables, and bingo it all works absolutly perfect, it is only fedora fc3 there is some problems, I don't even want to look at the locale yet as when I install scim I can not start Mozilla or Firefox, and the machine frezzes at boot time, on start of X, when this is sorted we can try to get it working inputing as well.
below is my locale output
The problem is on three different computers all with fc3 installed the other computers with redhat install have NO problems at all with scim.
What are we doing wrong with fedora fc3 ?
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
 
Old 01-15-2005, 11:29 PM   #47
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Rep: Reputation: 15
hi awtoc123, i am currently using kde, and i don't have that openoffice freezing problem anymore. I installed my scim when i was using gnome and openoffice didn't work there, and once i switch to kde, everything works fine, but of course there is no chinese support in it. at least it doesn't freeze anymore,
 
Old 01-16-2005, 12:39 AM   #48
suzhe
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
I found that OpenOffice shipped in FC3 does not compatible with SCIM's gtkimmodule, it should be a bug of OpenOffice, because OOo in SUSE doesn't have such issue.

To prevent OOo from using gtkimmodule, you need set the following environment var some where:

OOO_FORCE_DESKTOP=none

Then OpenOffice can work with SCIM without problem.
 
Old 01-20-2005, 01:39 AM   #49
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Rep: Reputation: 15
sorry, forget about what i ask

Last edited by ksmj; 01-20-2005 at 01:41 AM.
 
Old 01-21-2005, 12:25 PM   #50
LYLC
LQ Newbie
 
Registered: Jan 2005
Posts: 1

Rep: Reputation: 0
Hi Everyone,

I am a beginner of Fedora 3.
I met the problem of SCIM and OpenOffice working together as well.
I use "export OOO_FORCE_DESKTOP=none" command to set the environment variable.
It can't work.

What should I do to solve this problem?

Thanks a million.
 
Old 01-21-2005, 10:50 PM   #51
suzhe
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
Quote:
Originally posted by LYLC
Hi Everyone,

I am a beginner of Fedora 3.
I met the problem of SCIM and OpenOffice working together as well.
I use "export OOO_FORCE_DESKTOP=none" command to set the environment variable.
It can't work.

What should I do to solve this problem?

Thanks a million.
You need export this env in a system wide script, in order to let OOo make use of it. Otherwise you need start a terminal and start OOo by following commands:

$ export OOO_FORCE_DESKTOP=none
$ ooffice
 
Old 01-22-2005, 02:12 AM   #52
ahpin
Member
 
Registered: Oct 2003
Location: Malaysia
Distribution: Redhat, Mandrake 9.1, SuSE Linux
Posts: 32

Rep: Reputation: 15
I also installed already the SCIM and it working fine but not in OpenOffice. The OpenOffice will seem like freeze just after open. Any idea i can set the export OOO_FORCE_DESKTOP=none permanently? Please help .....thanks
 
Old 01-23-2005, 12:48 PM   #53
rykel
Member
 
Registered: Jan 2004
Location: Singapore
Distribution: Main Distros: Ubuntu & SUSE, OTHERS: MEPIS, FC, Mandriva, Linspire, Xandros, Knoppix
Posts: 58

Original Poster
Rep: Reputation: 15
hi all,

I am really touched that each and everyone of you have spent so much time trying to help me with my problem! A big THANK YOU to all!!


Anyway, I have solved my problem now, and this is how I did it:

1. Made sure my locale is English UTF-8. (type "locale" in a terminal to confirm)
NOTE: To change the locale, I selected English (British) from the Language section.

2. Downloaded and installed the RPMs for SCIM and SCIM-Chinese. (I did not install SCIM-Tables)
NOTE: When I did NOT install SCIM-Chinese, my SCIM alone did not have any Pinyin input.

3. To use Pinyin, I simply pressed CTRL-SPACE, and chose Simplified Chinese as my engine.

4. Like everybody else, OpenOffice 1.1.2 which came default with FC3 did NOT work. In fact, it hangs right after trying to start. So, I removed it and installed 1.1.3 from tgz. HOWEVER, I cannot seem to get SCIM to work in the current OOo. [somebody please help?]


It is really that straight forward.

The next statement is typed in Simplified Chinese.
嗨! 你们大家好吗? 谢谢你们对 Linux 的热忱 & 你们给我很大的帮助!



Regards,

Rykel
Singapore
 
Old 01-25-2005, 01:13 AM   #54
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Rep: Reputation: 15
i follow what suzhe said, and my open office doesn't hang any more. but scim still doesn't work in open office (i can't type chinese in there).

Kel
 
Old 01-25-2005, 03:00 AM   #55
suzhe
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
Quote:
Originally posted by ksmj
i follow what suzhe said, and my open office doesn't hang any more. but scim still doesn't work in open office (i can't type chinese in there).

Kel
Please check whether XMODIFIERS is set correctly. It should be set like:

XMODIFIERS=@im=SCIM

And please confirm that SCIM is started without any problem. Please use command "ps awx |grep scim" to see if there are three process looking like:

5807 ? Ss 0:00 /usr/lib/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay
5809 ? Ss 0:00 /usr/lib/scim-1.0/scim-launcher -d -c socket -e socket -f x11
5847 ? Ssl 0:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 
Old 01-25-2005, 09:37 AM   #56
kngharv
Member
 
Registered: Nov 2001
Location: China, USA
Distribution: SUN JDS/SUSE 9.1
Posts: 33

Rep: Reputation: 15
util this day...

I still don't know what does input Chinese in English environment has anything to do with SCIM nor any other input framework.
 
Old 01-26-2005, 09:05 PM   #57
suzhe
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
Re: util this day...

Quote:
Originally posted by kngharv
I still don't know what does input Chinese in English environment has anything to do with SCIM nor any other input framework.
Because currently only SCIM and IIIMF supports inputting Chinese in English environment. But IIIMF is buggy and hard to use, so SCIM is the best choice here.
 
Old 01-27-2005, 12:58 AM   #58
kngharv
Member
 
Registered: Nov 2001
Location: China, USA
Distribution: SUN JDS/SUSE 9.1
Posts: 33

Rep: Reputation: 15
Re: Re: util this day...

Quote:
Originally posted by suzhe
Because currently only SCIM and IIIMF supports inputting Chinese in English environment. But IIIMF is buggy and hard to use, so SCIM is the best choice here.
Best or not, it's up to users to decide. I've been using IIIMF for a while and I really don't see much of difference.

The original thread was "Using IIIMF Chinese in English locale." I know that you are author of SCIM and you are proud of your work. But there is no need to bash other technology in this forum for sake of promoting yours and Novell's agenda.

The main problem which these user are having is the fact that few differenciate the language they use and the encoding they are using. The key to this "Using IIIMF Chinese in English locale" is to make sure he/she uses unicode encoding. Replacing IIIMF with SCIM, but kept locale to "posix" or "ascii" will not resolve the problem. There is no need to decieve naive user to think that only way to input Chinese in English locale is to install SCIM.

I am sure many users are interested in comparing SCIM and IIIMF. You are more than welcome to post such article in some other thread.
 
Old 01-27-2005, 07:54 AM   #59
suzhe
LQ Newbie
 
Registered: Jan 2005
Posts: 16

Rep: Reputation: 0
Re: Re: Re: util this day...

Yes of course you are right. It's not suitable to discuss SCIM installation in this thread. So let's open new thread for SCIM installation if you want.

But as I know, FC3 uses UTF-8 encoding for all languages by default, so if an user installed FC3 with English language and did not modify any config file, then the default locale should be en_US.UTF-8. So for these uses, it should be nothing to do with the locale.

For IIIMF, if you are a native Chinese speaker, then you may know that the IIIMF Chinese Language Engines shipped in FC3 are very naive, they are very hard to be used in real work.

Quote:
Originally posted by kngharv
Best or not, it's up to users to decide. I've been using IIIMF for a while and I really don't see much of difference.

The original thread was "Using IIIMF Chinese in English locale." I know that you are author of SCIM and you are proud of your work. But there is no need to bash other technology in this forum for sake of promoting yours and Novell's agenda.

The main problem which these user are having is the fact that few differenciate the language they use and the encoding they are using. The key to this "Using IIIMF Chinese in English locale" is to make sure he/she uses unicode encoding. Replacing IIIMF with SCIM, but kept locale to "posix" or "ascii" will not resolve the problem. There is no need to decieve naive user to think that only way to input Chinese in English locale is to install SCIM.

I am sure many users are interested in comparing SCIM and IIIMF. You are more than welcome to post such article in some other thread.
 
Old 01-28-2005, 10:08 AM   #60
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,687

Rep: Reputation: 55
Quote:
Originally posted by awtoc123
Hi using redhat enterprises 3 or redhat 9 you basicly don't need to do anything other than installing three scim RPM's

1 ) scim-0.99.2.1.i586.rpm
2 ) scim-chinese-0.4.0.1.i586
3 ) scim-tables-zh-0.4.0.1.i586.rpm

You can find those packages at sf - But I'm not sure if those RPM's are still there, but if not let me know, and I will give you another link to download from.
Hi awtoc123,

I just drop-in this thread. I'm searching the whole World for a solution of inputing Chinese on kedit, OOoWriter, Mozilla, etc. other than gedit. Please advise where can I download the abovmentioned 3 rpms. I'm running FedoraCore2

TIA

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to check English spell within a Chinese environment wuqso Linux - Software 0 01-06-2005 02:07 AM
Input Chinese in English environment qyzlp Linux - General 1 01-04-2005 08:00 PM
English / Danish Locale settings TroelsSmit Linux - Newbie 2 05-21-2004 02:26 AM
Chinese locale support eaglegst Debian 1 02-08-2004 02:23 AM
Can I have english menu with chinese/english/spanish input? codec Linux - General 9 10-04-2003 07:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration