LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 08-24-2008, 06:54 AM   #1
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Rep: Reputation: 30
cannot play MP3s in rythmbox / gstreamer


Slight problem playing MP3s... rhythmbox complains with a window saying

"Couldn't start playback (null)"

Muine complains with

"Audio backend error:

You do not have a decoder installed to handle this file. You might need to install the necessary plugins."

So, I installed various gstreamer package (having searched these forums) ..
gstreamer-tools-0.10.15-1.fc8
gstreamer-plugins-base-0.10.15-4.fc8
gstreamer-0.10.15-1.fc8
gstreamer-ffmpeg-0.10.3-5.lvn8
gstreamer-python-0.10.11-1.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
gstreamer-plugins-good-0.10.6-7.fc8


no joy.

So then, I installed livna fedora 8 rpm release package then ..
Code:
# yum install gstreamer-plugins-ugly gstreamer-plugins-bad
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-bad.i386 0:0.10.5-14.lvn8 set to be updated
--> Processing Dependency: libfusion-1.0.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libdirect-1.0.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libtimidity-0.1.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libWildMidi.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libmpeg2encpp-1.9.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libdirectfb-1.0.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libcdaudio.so.1 for package: gstreamer-plugins-bad
--> Processing Dependency: libmms.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libmodplug.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libmjpegutils-1.9.so.0 for package: gstreamer-plugins-bad
--> Processing Dependency: libneon.so.27 for package: gstreamer-plugins-bad
---> Package gstreamer-plugins-ugly.i386 0:0.10.6-5.lvn8 set to be updated
--> Processing Dependency: libmpeg2.so.0 for package: gstreamer-plugins-ugly
--> Processing Dependency: libsidplay.so.1 for package: gstreamer-plugins-ugly
--> Processing Dependency: libmad.so.0 for package: gstreamer-plugins-ugly
--> Running transaction check
---> Package directfb.i386 0:1.0.0-3.fc8 set to be updated
---> Package wildmidi-libs.i386 0:0.2.2-5.fc8 set to be updated
--> Processing Dependency: timidity++-patches for package: wildmidi-libs
---> Package neon.i386 0:0.27.2-2 set to be updated
---> Package libmms.i386 0:0.4-1.lvn8 set to be updated
---> Package libmad.i386 0:0.15.1b-6.lvn8 set to be updated
---> Package libsidplay.i386 0:1.36.57-14 set to be updated
---> Package libcdaudio.i386 0:0.99.12p2-8.fc7 set to be updated
---> Package mjpegtools-libs.i386 0:1.9.0-0.4.rc2.lvn8 set to be updated
--> Processing Dependency: libquicktime.so.0 for package: mjpegtools-libs
--> Processing Dependency: libquicktime >= 0.9.8 for package: mjpegtools-libs
---> Package libtimidity.i386 0:0.1.0-4.fc8 set to be updated
---> Package mpeg2dec.i386 0:0.4.1-3.lvn8 set to be updated
---> Package libmodplug.i386 1:0.8.4-2.fc8 set to be updated
--> Running transaction check
---> Package libquicktime.i386 0:1.0.1-1.lvn8 set to be updated
---> Package timidity++-patches.i386 0:2.13.2-4.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 gstreamer-plugins-bad   i386       0.10.5-14.lvn8   livna             529 k
 gstreamer-plugins-ugly  i386       0.10.6-5.lvn8    livna             260 k
Installing for dependencies:
 directfb                i386       1.0.0-3.fc8      fedora            1.0 M
 libcdaudio              i386       0.99.12p2-8.fc7  fedora             46 k
 libmad                  i386       0.15.1b-6.lvn8   livna              84 k
 libmms                  i386       0.4-1.lvn8       livna              40 k
 libmodplug              i386       1:0.8.4-2.fc8    fedora            167 k
 libquicktime            i386       1.0.1-1.lvn8     livna             387 k
 libsidplay              i386       1.36.57-14       fedora             84 k
 libtimidity             i386       0.1.0-4.fc8      fedora             47 k
 mjpegtools-libs         i386       1.9.0-0.4.rc2.lvn8  livna             271 k
 mpeg2dec                i386       0.4.1-3.lvn8     livna             102 k
 neon                    i386       0.27.2-2         fedora            109 k
 timidity++-patches      i386       2.13.2-4.fc8     fedora            8.5 M
 wildmidi-libs           i386       0.2.2-5.fc8      updates            47 k

Transaction Summary
=============================================================================
Install     15 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Installed no probs but still the same errors when trying to play any MP3 I have.

The MP3s are on a CD and play on other O/S just fine so I know its not the MP3s.

Any ideas please.
 
Old 08-24-2008, 11:52 PM   #2
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Hrm, according to this post on fedoraforum.org (http://forums.fedoraforum.org/showthread.php?t=106220), the codec should have been in gstreamer-ugly. Are you sure that one is installed?
 
Old 08-25-2008, 04:25 AM   #3
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Original Poster
Rep: Reputation: 30
Yes..It is installed.

Strange!

I erased all gstreamer*, rythmbox, all dependencies etc and rebooted then reinstalled everything I had before.

Its working now.

How bizzare.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gstreamer playbin can't play mp3 files dracolich Linux - Software 5 09-11-2014 03:58 AM
Problems playing mp3s with gstreamer apps sharkus Linux - Software 4 10-06-2007 04:15 AM
Using Gstreamer-totem to play .mov files Fegenbush Linux - Software 2 03-14-2007 12:55 AM
I cannot play MP3s spiffytech Fedora 7 04-27-2006 08:53 PM
how to get totem-gstreamer to play dvds Simon Bridge Linux - Software 4 10-18-2005 12:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration