LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2007, 12:55 PM   #1
sharkus
Member
 
Registered: Aug 2006
Distribution: openSUSE 10.3
Posts: 63

Rep: Reputation: 15
Problems playing mp3s with gstreamer apps


I seem to be having problems playing mp3s with any gtk apps such as banshee or exaile. I looked and all the codecs are installed. Lame even shows up in the preferences to the rip format. I looked on my laptop which is fine, and it has the same configuration.
I then ran both in the terminal and I get similar error messages. They are:
(exaile.py:7411): GStreamer-CRITICAL **: gst_parse_bin_from_description: assertion `bin_description != NULL' failed
(Banshee:7306): GStreamer-CRITICAL **: gst_parse_bin_from_description: assertion `bin_description != NULL' failed

Any help with this would be greatly appreciated. Thanks in advance.
 
Old 09-29-2007, 06:36 AM   #2
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Rep: Reputation: 30
Have you tried audacious? Just to see if another app would work?
 
Old 09-29-2007, 01:27 PM   #3
sharkus
Member
 
Registered: Aug 2006
Distribution: openSUSE 10.3
Posts: 63

Original Poster
Rep: Reputation: 15
I did try and see with another app. I tried exaile. I tried audacious. It works, but it seems as if it does not use gstreamer at all and has its own plugin framework. I could just use amarok as well. It would just be nice to use banshee.
 
Old 10-05-2007, 08:34 AM   #4
Jukka Pekkavuori
LQ Newbie
 
Registered: Oct 2007
Location: Oldenburg, Germany
Distribution: OpenSUSE 11,1
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by sharkus View Post
It would just be nice to use banshee.
I had the same problem with banshee and solved it by installing helix-banshee instead. Check, if you have installed gstreamer-plugins-ugly. It contains the mp3-support.
 
Old 10-06-2007, 04:15 AM   #5
sharkus
Member
 
Registered: Aug 2006
Distribution: openSUSE 10.3
Posts: 63

Original Poster
Rep: Reputation: 15
Yeah, that's what I ended up doing. I did have the gstreamer-ugly packages installed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound When Playing MP3s? JockVSJock Ubuntu 4 06-27-2005 12:17 PM
Playing mp3s dangerousdave Linux - Newbie 4 02-14-2005 01:00 PM
playing mp3s pcdebb Linux - Newbie 12 12-03-2003 09:36 AM
playing MP3s from an NTFS partition newhopekenny Linux - Software 2 04-24-2003 08:07 PM
playing mp3s over a network thinguy10 Linux - Networking 2 01-12-2002 06:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration