LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-10-2011, 07:36 PM   #16
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311

When you boot your computer from a power-off state, you are shown the debian grub2 menu with a spacefun-grub background.

When you select the first entry you boot into your debian-6 install.

The second entry is for debian recovery mode.

The third entry is for your windows recovery partition.

When you select the last entry you should then get another menu enabling you to choose to boot windows or your Ubuntu wubi install.

I don't see anything wrong here.

Could you post the contents of the /etc/default/grub file on your debian install?
 
Old 03-10-2011, 08:11 PM   #17
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
I think it may have installed the first grub into the small 100mb partition that Windows 7 calls the loader then switches to the C: where Windows is and gives the graphical choice for grub. Once there I see the 4 choices. Does that explain what I am seeing? Hope so
Scroll down to wins os to boot wins.
 
Old 03-10-2011, 09:42 PM   #18
lonniec
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 10.10 Debian 6.0
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by EDDY1 View Post
Scroll down to wins os to boot wins.
Booting into Windows not the problem. The problem seems to be that if I choose restart from Debian it doesn't go through POST it just restarts Debian. I would rather it went through post so I can choose Windows or Ubuntu.
 
Old 03-11-2011, 12:59 AM   #19
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Ok you have grub2 & wubi, at boot which are you seeing?
 
Old 03-11-2011, 07:35 AM   #20
lonniec
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 10.10 Debian 6.0
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by EDDY1 View Post
Ok you have grub2 & wubi, at boot which are you seeing?
At boot I see grub2. Wubi if I am not mistaken shows up when I select windows then I see Windows or Ubuntu its part of the Windows boot menu - used to be in boot.ini file.
 
Old 03-11-2011, 08:16 AM   #21
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Quote:
Originally Posted by andrewthomas View Post
Could you post the contents of the /etc/default/grub file on your debian install?
It would help to see this.
 
Old 03-11-2011, 05:08 PM   #22
lonniec
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 10.10 Debian 6.0
Posts: 17

Original Poster
Rep: Reputation: 0
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Here it is.
Quote:
Originally Posted by andrewthomas View Post
It would help to see this.
 
Old 03-11-2011, 08:26 PM   #23
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I would have to think that maybe wubi is allowing the restart to go back to OS instead of computer. Maybe you can check your wubi configuration. I myself would prefer to have 1 bootloader handling job. Having to make a selection from 2 boot menu's would drive me crazy.

Last edited by EDDY1; 03-11-2011 at 08:28 PM.
 
Old 03-11-2011, 10:32 PM   #24
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Quote:
Originally Posted by EDDY1 View Post
I would have to think that maybe wubi is allowing the restart to go back to OS instead of computer.
If this were the case, it would be happening when using Ubuntu, not when using Debian.

I would reinstall grub-pc from Debian and see if that helps.
 
Old 03-11-2011, 11:42 PM   #25
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
At boot I see grub2.
When selects wins another boot menu
Quote:
Wubi if I am not mistaken shows up when I select windows then I see Windows or Ubuntu its part of the Windows boot menu
I may be mistaken though.

Last edited by EDDY1; 03-11-2011 at 11:44 PM.
 
Old 03-21-2011, 06:26 AM   #26
hex_messer
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 3
Oh, guys, don't touch grub! The bootloader is not the case here. I've just tried Debian 6 live, install os from it. Live and real installation have the same behavior - command "reboot", also from Gnome menus -- does something (stop gnome, X manager, stop and start some daemons as I can catch on screen), but not the real hardware reboot. I've recall the Win3.11/95 option "reload windows" - windows was reloading, but whole PC was not. I guess, it's some optimizing idea of developers.
For now I'll try to dig into it.
 
Old 03-21-2011, 07:09 AM   #27
hex_messer
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 3
Ha! in Debian 6 reboot is "RapidReboot", done with kexec. It's really fast reboot of kernel (into running or new). So let's reading...
 
Old 03-21-2011, 08:00 AM   #28
hex_messer
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 3
So, the described behavior is because of kexec-tools. It's init.d script executed (by design) just before the reboot script, so only the kernel is rebooted.
In first look I can't figure out how to configure kexec to be optional, so for now I've just uninstall package kexec-tools.

Try it out! It's your solution.
 
Old 03-21-2011, 10:20 AM   #29
hex_messer
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 3
And one more: kexec-tools seems to be installed by default while installing from Debian 6 Live disks. Installation from basic DVD set with two options "Graphical environment" and "basic utilities" does not install kexec-tools.
 
Old 03-22-2011, 03:22 PM   #30
lonniec
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu 10.10 Debian 6.0
Posts: 17

Original Poster
Rep: Reputation: 0
What is kexec-tools and do I need it?

Quote:
Originally Posted by hex_messer View Post
And one more: kexec-tools seems to be installed by default while installing from Debian 6 Live disks. Installation from basic DVD set with two options "Graphical environment" and "basic utilities" does not install kexec-tools.
I have not tried this yet as I have been on vacation all of last week. Will try soon and let you know. However what is kexec-tools and do I need it? Thanks for seeing my original post and pointing to something that sounds like a solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
samba needs restart on reboot johnh10000 Linux - Networking 2 01-20-2011 05:42 AM
Restart networking without reboot. patufet99 Linux - Networking 6 10-15-2009 01:55 PM
Debian Etch+Networking restart problem kirby76 Linux - Networking 2 05-08-2007 02:06 AM
Cannot restart, reboot, or shutdown slimfadey Linux - Newbie 3 04-28-2005 07:07 PM
reboot and restart problem Fedora Dannydy Linux - Hardware 3 10-13-2004 07:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration