LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-26-2007, 05:16 AM   #1
kirby76
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
Debian Etch+Networking restart problem


Hi all!

i've been start useing Debian Etch 4.0r0 and find an interesting thing.
When i type the command: /etc/init.d/networking restart
the networking restart, but there is no networking anymore, until the next reboot. When i check with ifconfig, the eth0 is not appears.
Anybody met with this? I should greatly appreciate for any ideas.

Kirby
 
Old 05-07-2007, 09:42 PM   #2
ultrasawblade
LQ Newbie
 
Registered: Apr 2007
Distribution: Debian
Posts: 15

Rep: Reputation: 0
try (as root):
# ifup eth0
to bring your interface back up.

alternatively you can restart an interface with these commands:
# ifdown eth0
and then:
# ifup eth0
 
Old 05-08-2007, 03:06 AM   #3
kirby76
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Original Poster
Rep: Reputation: 0
hello ultrasawblade!

thanks for the reply. yes, i tried these commands and are working. But it's not a solution, think about it:
you're connected to a remote host with ssh and do a networking restart, you will be immediately disconnected.
In the meantime i find the solution. Need to edit /etc/network/interfaces file.
By default there is the line: allow-hotplug eth0. Change this to: auto eth0, as in the 3.1r1 version as well.
Hope this helps to others too.

Regards: Kirby
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KVpnc Problem in Debian Etch richinsc Debian 4 06-08-2008 07:02 AM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 11:02 PM
WPA_Supplicant problem on Debian Etch JaseP Linux - Wireless Networking 7 07-25-2006 02:44 AM
Debian etch GUI problem AaronKupen Linux - Software 3 06-16-2006 03:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration