Download your favorite Linux distribution at LQ ISO.
Go Back > Blogs > Caysho
User Name


Rate this Entry

Dual boot with Windows 2000 and Kubuntu 6.06 on Intel D815EPEA2 motherboard

Posted 10-01-2007 at 08:46 AM by Caysho
Updated 12-25-2008 at 06:29 AM by Caysho

I get a 160 GB hard drive, and figured "this should be easy".

First attempt.
Windows installs ok, I had it create an 70 GB NTFS partition (slow to format).
When it asked me about partitioning, it sees 137 GB which it lists at the top of the screen, and also when showing the partitions created.
This is strange, but I don't think much of it - I figure if it can see up to and past 70 GB, then it doesn't matter.
Installed SP4 and other updates.

I install Kubuntu, and it asks to install GRUB to the MBR. Ok, that's always worked before.

Reboot, and I get GRUB Error 18.

A bit of hunting, and support forums indicate LBA needs to be enabled.
It is enabled, but more searching keeps turning up this same tip. Maybe a BIOS update will fix it, so I check Intel's site.
There's an update, and it mentions LBA-48 (PDF, 94.2 KB)
I wasn't aware there were different variants, and the BIOS doesn't give any indication.
The BIOS was at revision P17.

So I get the update, and it occurs to me that there's no floppy drive installed.
I end up using a floppy image from that has support for a CD drive ("Need To Flash Your BIOS On A PC With No 1.44").
Burn the ISO, and also burn the update to another CD.

Boots up, updates ok.

Second attempt.
I nuke the partitions and do it all again, including SP4 for windows.
This time, the Windows 2000 installer still sees 137 GB (listed at the top of the screen), but the partitioner does see the correct size.

GRUB is installed again on the MBR.

Reboot, and GRUB runs fine.
I run Windows 2000, and it gets to the second stage of the boot process before a BSOD:

STOP 0x0000007B.
Some more searching, and I come across Dual Boot, Win2K Won't Boot, BSOD: Inaccessible Boot Device Error
This leads me to the MS support site.
SP4 "adds" support for drives > 137 GB, but the support isn't actually *turned on* by default.
Even though the partition in question starts and ends below 137 GB, Windows 2000 still panics part way through it's boot up.

Third attempt.
I blow the partitions away again, though I probably could have used the Windows CD to "fix" the partition - I wanted to check the process can be done from scratch.
After SP4 is installed, I add the registry key.

I reboot, and it's ok, so install Kubuntu again.
GRUB goes onto the MBR, and I reboot. Windows is available in the list as it was after the second attempt.

It boots up all the way this time. Finally.
Posted in Uncategorized
Views 1364 Comments 0
« Prev     Main     Next »


All times are GMT -5. The time now is 03:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration