Download your favorite Linux distribution at LQ ISO.
Go Back > Blogs > Caysho
User Name


Rate this Entry

Debian on NSLU2

Posted 12-04-2010 at 09:54 PM by Caysho

I have a spare NSLU2 (no longer sold) which I had originally intended to use as a backup to one I use as a fileserver (running OpenSlug).
I have been wanting to put a torrent client on it as well.

Ubuntu has an installer, but support has since been removed.

Initial install.
So I go with debian. The device has 32 MB RAM, so the oom killer kills the disk formatter.
Partition the drive separately - I have a 4 GB USB stick:
  • Primary partition 3 GB ext3
  • Extended partition 1 GB swap
If the swap is on the primary partition boot failure will result.

The installer components I chose were:
  • kernel image
  • usb modules
  • parted
I ran the normal debian installer. In another terminal, run a tail on syslog to get the disk devices when the Detect Disks part is run.

Select manual partitioning and pick the formatted partition as the root filesystem, keeping data.

The rest will take a while.

After the initial install is done, there are some tips:
Moving to debian squeeze.
I found further problems when I installed samba, then transmission-daemon. The daemon is only available in squeeze (testing), and there is a conflict with the naming of a library that both packages depend on.

I figured it would be simpler to upgrade the install from lenny to squeeze.
One problem with sysv-rc came up later in the process, but I was able to reboot and the device came back ok.

I decided to do a tar backup of the file system to ensure I have a snapshot I can recover from, as installing takes a long time. Full Hard Drive Backup with Linux Tar contains details.

After that, I ran
aptitude install samba cups transmission-daemon dropbear
and there were no conflicts reported.

Mounting the data drive
I created a mount point owned by the user account.
In /etc/fstab I have the following entry
UUID=16ccf6f3-9bb2-4677-afef-49dc6a049f6f /media/storage auto
Samba configuration
When samba was installed, it configured samba users from those in the users group.
My smb.conf file looks like this:
 workgroup = XXXXX
 netbios name = FILESERVER
 security = SHARE
 local master = yes
 guest account = fsuser
 log file = /media/storage/data/%m.log

 comment = Data
 path = /media/storage
 force user = fsuser
 force group = users
 read only = No
 guest ok = Yes
I added other read only shares as needed.

Mythbuntu connection (10.04.1)
I have entries like this in my /etc/fstab
//server/SHARENAME /var/lib/mythtv/videos/FSMOUNTPOINT cifs uid=pvruser,noauto,credentials=/home/pvruser/.smbpasswd 0 0
The .smbpasswd file contains:
and mounting must be done as root due to a samba change upstream (user mounting is now considered a security hole).

transmission-daemon start up configuration
I had problems getting the daemon to pick the configuration file when run as a non-root user.
The daemon also overwrites json settings.
I found an ubuntu forum thread that describes a fix for the transmission-daemon start up.

There is a transgui ubuntu ppa. I have found transgui to be better than the web interface provided by the transmission-daemon.
Posted in Uncategorized
Views 2391 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 09:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration