LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2007, 01:24 PM   #1
divine18e
LQ Newbie
 
Registered: Oct 2007
Posts: 15

Rep: Reputation: 0
Cool speakers and headphone both play together


when i plugin my headphone then i speakers also keep on playing as usual
what to do?
 
Old 10-18-2007, 02:09 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,788

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
That depends on what external speaker system you are using. I'm using a Logitech surround sound system which has a switch I can use to turn off the external speakers and keep headphone active.

Tell us more about your external speaker system.
 
Old 10-20-2007, 12:46 PM   #3
Paul_Vandenberg
LQ Newbie
 
Registered: Nov 2003
Location: Canada
Distribution: Kubuntu
Posts: 16

Rep: Reputation: 0
If you go to your volume control tool, Kmix for me, there should be a tab or something for switches. Make sure the headphone jack sense switch is on. Also, if you use external speakers, but have internal ones as well, activating line jack sense will silence the internal speaker(s). My internal ones aren't as good and I don't want to hear them.

Regards....Paul
 
Old 10-20-2007, 04:19 PM   #4
divine18e
LQ Newbie
 
Registered: Oct 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Smile u got it wrong

i m using AMD 64 bit laptop and the speakers are inbuilt.
now when i play a song then the inbuilt speakers start working.
now when i plugin the headphone,the speakers should stop working.
but it's not so.
both the speakers and the headphone outputs the sound
now plz tell me what to do?
how can i control all this functionality
 
Old 10-20-2007, 05:14 PM   #5
Paul_Vandenberg
LQ Newbie
 
Registered: Nov 2003
Location: Canada
Distribution: Kubuntu
Posts: 16

Rep: Reputation: 0
Make sure headphone jack sense is activated. Other than that, I don't know.
 
Old 10-26-2007, 06:51 AM   #6
divine18e
LQ Newbie
 
Registered: Oct 2007
Posts: 15

Original Poster
Rep: Reputation: 0
what is that jack sense???????
 
Old 10-26-2007, 06:49 PM   #7
Paul_Vandenberg
LQ Newbie
 
Registered: Nov 2003
Location: Canada
Distribution: Kubuntu
Posts: 16

Rep: Reputation: 0
Bring up volume control settings. In GNOME, click on Edit | Preferences. Select 'Line In Jack Sense' and 'Headphone Jack Sense'. You should have a tab called switches visible now. Select that tab and check off the two 'Sense' settings. Now when the system detects anything in the headphone jack, all other speakers will be silent. When it detects anything in the sound card jack, any built-in speakers will be silent.

Regards....Paul
 
Old 01-25-2008, 03:53 AM   #8
Jordan&&&&
Member
 
Registered: Mar 2006
Location: Bulgaria
Distribution: OpenSuse
Posts: 70

Rep: Reputation: 15
What about KDE? I am having the same problem with a laptom MSI VR610X. I am using the latest alsa package 1.0.14-31.2.x86_64.

There are only three switches in kmix - IEC958, Caller ID, Off-hook.
 
Old 08-10-2008, 06:17 PM   #9
gjmsreddy
LQ Newbie
 
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
How to make headphone and external speakers work at same time

Hi, I have a Dell Inspiron 530s with UBuntu. I have external speakers connected to it and also headphone connected to FM transmitter. I want to be able to listen to songs through external speakers(It is connected to Front in the volume control items) and at the same time broadcast using FM transimitter. As soon as I connect FM transmitter to head phone, the external speakers stop working. Is there a way to make both of them work together?

When I bring Volume Control, it shows HDA Intel ( Alsa Mixer), I see a switches tab with a checkbox (HeadPhone). If I uncheck the box, Headphone jack stops workings. If I check it, Headphone jack works but if I connect anything to Headphone Jack, the external speakers Jack (Front) stops working.

Any help is greatly appreciated. Thanks.
 
Old 08-23-2008, 07:44 AM   #10
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Rep: Reputation: 15
Same with Jordan&&&&
My laptop is fujitsu-siemens amilo pa2510 , amd64
There are only three switches in aslamixer.
Please help!
thx
 
Old 11-03-2008, 03:07 PM   #11
mattjohnstone22
Member
 
Registered: Jan 2007
Posts: 65

Rep: Reputation: 15
I have the same problem listed above. It is now beyond annoying. I have spent well over 8 months in the hope of a solution from various sites, and none have achieved so. This needs reporting. Nobody is EVER given a solution to the problem of headphone and in-built speakers running at the same time. In terms of standard sound equipment, this causes a problem. In terms of dual sound systems, such as a mixer with two inputs, the problem is multiplied ten fold.

I don't know whether or not this is just an opensuse issue, or a grand linux issue with certain laptops, but I do know for sure that a google search for "headphones play at same time" is a big deal; without any solution. Attach any linux distro you wish to that criteria.

It needs sorting.

Matt.
 
Old 01-08-2009, 03:32 PM   #12
Piraja
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
This is a very common issue, as it seems. And very frustrating. Previously I fixed it by installing GNOME-Alsamixer and checking the "Headphone jack sense" box (there was no such option in GNOME Volume Control which comes packed in as default in Ubuntu 8.10), but after some new updates (Pulse Audio?) the "Headphone jack sense" box has disappeared and nothing seems to bring it back now...

EDIT: No, this probably had nothing to do with Pulse udpates, but rather some update from the Ubuntu-proposed repo. I reverted from kernel 2.6.27-11 back to 2.6.27-9 and I'm no longer getting simultaneous sound from loudspeakers and headphones. Yet, the Headphone jack sense option still does not appear in either GNOME volume control applet or Alsamixer now.

Last edited by Piraja; 01-08-2009 at 04:34 PM.
 
Old 08-06-2010, 07:48 AM   #13
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
i want to have headphones and speakers at the same time because my inbuilt laptop spkers are superb and so are my externals im using opensuse 11.3 kde and i have a realtek alc268 souundcard so if i do this i can have 4.1 speaker system oh and i have 2 headphone jacks i would like this to work for both
 
Old 10-14-2010, 04:28 AM   #14
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Rep: Reputation: 15
This problem fixed for my by the newer versions of Ubuntu Linux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in speakers and headphone purimanu2000 Linux - Hardware 1 09-18-2007 12:11 AM
Play the same music on all speakers in the house rewtedesco Linux - Networking 2 01-20-2007 01:55 AM
no sound from speakers or headphone jack in ibm 600e donnyb General 4 03-27-2006 11:37 AM
Dell B120 Headphone jack now switches off speakers, thanks ALSA people cmetelko Linux - Laptop and Netbook 2 03-26-2006 03:33 PM
Headphone plugged in, sound still comes out of speakers tbraun Linux - Hardware 3 01-18-2005 03:36 PM


All times are GMT -5. The time now is 03:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration