LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   speakers and headphone both play together (http://www.linuxquestions.org/questions/ubuntu-63/speakers-and-headphone-both-play-together-592807/)

divine18e 10-18-2007 02:24 PM

speakers and headphone both play together
 
when i plugin my headphone then i speakers also keep on playing as usual
what to do?

bigrigdriver 10-18-2007 03:09 PM

That depends on what external speaker system you are using. I'm using a Logitech surround sound system which has a switch I can use to turn off the external speakers and keep headphone active.

Tell us more about your external speaker system.

Paul_Vandenberg 10-20-2007 01:46 PM

If you go to your volume control tool, Kmix for me, there should be a tab or something for switches. Make sure the headphone jack sense switch is on. Also, if you use external speakers, but have internal ones as well, activating line jack sense will silence the internal speaker(s). My internal ones aren't as good and I don't want to hear them.

Regards....Paul

divine18e 10-20-2007 05:19 PM

u got it wrong
 
i m using AMD 64 bit laptop and the speakers are inbuilt.
now when i play a song then the inbuilt speakers start working.
now when i plugin the headphone,the speakers should stop working.
but it's not so.
both the speakers and the headphone outputs the sound
now plz tell me what to do?
how can i control all this functionality

Paul_Vandenberg 10-20-2007 06:14 PM

Make sure headphone jack sense is activated. Other than that, I don't know.

divine18e 10-26-2007 07:51 AM

what is that jack sense???????

Paul_Vandenberg 10-26-2007 07:49 PM

Bring up volume control settings. In GNOME, click on Edit | Preferences. Select 'Line In Jack Sense' and 'Headphone Jack Sense'. You should have a tab called switches visible now. Select that tab and check off the two 'Sense' settings. Now when the system detects anything in the headphone jack, all other speakers will be silent. When it detects anything in the sound card jack, any built-in speakers will be silent.

Regards....Paul

Jordan&&&& 01-25-2008 04:53 AM

What about KDE? I am having the same problem with a laptom MSI VR610X. I am using the latest alsa package 1.0.14-31.2.x86_64.

There are only three switches in kmix - IEC958, Caller ID, Off-hook.

gjmsreddy 08-10-2008 07:17 PM

How to make headphone and external speakers work at same time
 
Hi, I have a Dell Inspiron 530s with UBuntu. I have external speakers connected to it and also headphone connected to FM transmitter. I want to be able to listen to songs through external speakers(It is connected to Front in the volume control items) and at the same time broadcast using FM transimitter. As soon as I connect FM transmitter to head phone, the external speakers stop working. Is there a way to make both of them work together?

When I bring Volume Control, it shows HDA Intel ( Alsa Mixer), I see a switches tab with a checkbox (HeadPhone). If I uncheck the box, Headphone jack stops workings. If I check it, Headphone jack works but if I connect anything to Headphone Jack, the external speakers Jack (Front) stops working.

Any help is greatly appreciated. Thanks.

serafimg 08-23-2008 08:44 AM

Same with Jordan&&&&
My laptop is fujitsu-siemens amilo pa2510 , amd64
There are only three switches in aslamixer.
Please help!
thx

mattjohnstone22 11-03-2008 04:07 PM

I have the same problem listed above. It is now beyond annoying. I have spent well over 8 months in the hope of a solution from various sites, and none have achieved so. This needs reporting. Nobody is EVER given a solution to the problem of headphone and in-built speakers running at the same time. In terms of standard sound equipment, this causes a problem. In terms of dual sound systems, such as a mixer with two inputs, the problem is multiplied ten fold.

I don't know whether or not this is just an opensuse issue, or a grand linux issue with certain laptops, but I do know for sure that a google search for "headphones play at same time" is a big deal; without any solution. Attach any linux distro you wish to that criteria.

It needs sorting.

Matt.

Piraja 01-08-2009 04:32 PM

This is a very common issue, as it seems. And very frustrating. Previously I fixed it by installing GNOME-Alsamixer and checking the "Headphone jack sense" box (there was no such option in GNOME Volume Control which comes packed in as default in Ubuntu 8.10), but after some new updates (Pulse Audio?) the "Headphone jack sense" box has disappeared and nothing seems to bring it back now...

EDIT: No, this probably had nothing to do with Pulse udpates, but rather some update from the Ubuntu-proposed repo. I reverted from kernel 2.6.27-11 back to 2.6.27-9 and I'm no longer getting simultaneous sound from loudspeakers and headphones. Yet, the Headphone jack sense option still does not appear in either GNOME volume control applet or Alsamixer now.

theacerguy 08-06-2010 08:48 AM

i want to have headphones and speakers at the same time because my inbuilt laptop spkers are superb and so are my externals im using opensuse 11.3 kde and i have a realtek alc268 souundcard so if i do this i can have 4.1 speaker system oh and i have 2 headphone jacks i would like this to work for both

serafimg 10-14-2010 05:28 AM

This problem fixed for my by the newer versions of Ubuntu Linux


All times are GMT -5. The time now is 09:48 PM.