Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 07-30-2010, 03:28 PM   #1
Registered: Jun 2008
Posts: 405

Rep: Reputation: 30
grub error 17, but 'sudo grub' = command not found

I have a guy in my office who was using an old version of ubuntu and he tried upgrading to 10 but now he's getting grub error 17. I Google this and everyone suggests reinstalling grub starting with opening a shell and typing 'sudo grub'. However, I get 'command not found' in response to that. I've tried looking for the location of grub so I could try 'sudo /sbin/grub' and such, but I don't see it anywhere.

Also, I'm using a version 9.10 Live CD at the moment because I can't find out how to disable the drmraid option on the version 10 CD (necessary to detect the hard drives which, although they are on a raid controller are not configured as an array but separate drives).

Any ideas short of starting over from scratch?
Old 07-31-2010, 10:53 AM   #2
Senior Member
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 289Reputation: 289Reputation: 289
Originally Posted by davidstvz View Post
I have a guy in my office who was using an old version of ubuntu and he tried upgrading to 10 but now he's getting grub error 17.
How old is this old version??
Note: You can only do a dist-upgrade to 10.04 from 9.10; or, because 10.04 is a LTS version, you can also do a dist-upgrade from 8.04.
In any case, for what it is worth, I always do clean installs of Ubuntu.
Old 08-02-2010, 09:09 AM   #3
Registered: Jun 2008
Posts: 405

Original Poster
Rep: Reputation: 30
'cat /etc/issue' shows

'Ubuntu 8.04.4 LTS \n \l'

He may not have actually succeeded in updating anything, only breaking the existing system's bootloader.

I guess I'll probably just install from scratch. It's just a little weird that there are so many resources online telling me to use 'sudo grub' but I'm not saying a 'grub' command anywhere.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] grub-install command not found ! debianD Gentoo 3 04-30-2015 12:05 AM
[SOLVED] When I type "sudo grub" it says "command not found" in Ubuntu 9.10 Live CD. msbstar Linux - Newbie 7 01-30-2010 11:05 AM
grub fdisk command not found pavankonka Linux - Laptop and Netbook 3 02-08-2006 05:06 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 08:13 PM

All times are GMT -5. The time now is 04:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration