LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2004, 07:53 PM   #31
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31

Come on!!!! I am the inly one that uses a Nvidia Card here. Out of this entire forum the only one that even tries to hel is someone who stopped using SUSE?
I am sorry for the frustration but it is there.
Thank you Slacker for all your help.
 
Old 12-29-2004, 07:59 PM   #32
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
If you did not succed first, then you're a programmer
and if really, why SuSE? So many distros to choose from. And why do you think I, personally, stopped using Suse?
I would really recommend after so many years of using *nix "Slackware"
 
Old 12-29-2004, 08:02 PM   #33
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
"why SuSE"

I wish I hadn't just paid 80 dollars for this os.

That is why right now, but the reason is fading fast
 
Old 12-29-2004, 08:05 PM   #34
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Are you Serious!!!????
Here is one best link for you
http://distrowatch.com
Choose distro, download and use for pleasure
 
Old 12-29-2004, 08:08 PM   #35
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I though those books it came with would be usefull
 
Old 12-29-2004, 08:12 PM   #36
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Wisdom comes from bumps on the road and on the head
Fly with Air Slackware, your best Airline

 
Old 12-29-2004, 11:52 PM   #37
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I am sorry for venting. I am just frustrated.
 
Old 12-30-2004, 02:55 AM   #38
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Rep: Reputation: 15
Take a look at the README file that came with the nVidia drivers, in /usr/share/doc/NVIDIA_GLX-1.0. Specifically, Appendix D, "X Config Options":

"Option "RenderAccel" "boolean"
Enable or disable hardware acceleration of the RENDER extension. THIS OPTION IS EXPERIMENTAL. ENABLE IT AT YOUR OWN RISK. There is no correctness test suite for the RENDER extension so NVIDIA can not verify that RENDER acceleration works correctly. Default: hardware acceleration of the RENDER extension is disabled."

They also have an example XF86Config with sections for various types of cards there.

The video card section of my XF86Config file looks like this:
Code:
Section "Device"
  BoardName    "GeForce4 MX440SE"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  VendorName   "NVidia"
  Option       "NoLogo" "1"
  Option       "RenderAccel" "1"
EndSection
I used YaST to try to enable 3D acceleration and adjust the position of the display after installing the nVidia driver, and it reset XF86Config to use the default "nv" driver (and also reset my screen resolution to what it thought it should be, which is not my choice). So I won't use YaST for that any more. But it did back up my original config file to "/etc/X11/XF86Config.YaST2save".
 
Old 12-30-2004, 03:24 AM   #39
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I added the Option "RenderAccel" "1"

Should yast recognize that this has been enabled because it is not
 
Old 12-30-2004, 03:35 AM   #40
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Rep: Reputation: 15
Yes, YaST should see that 3D acceleration is enabled. Please make sure you are using the "nvidia" driver and not the "nv" driver.
 
Old 12-30-2004, 04:21 AM   #41
Sabicas
Member
 
Registered: Aug 2004
Distribution: Slackware 10
Posts: 110

Rep: Reputation: 15
Yeah, it sounds like you might be using the nv driver. Are you sure you installed the NVIDIA driver, because if memory serves me correctly it enables 3D by default when it's installed.

If you're not sure try this.

(KDE start menu)

Find (system) on that menu (expand system)

Find (yast) (click on yast)

(enter your root password)

(select software)

(select online update)

you should just be able to (click next)

:this step might take a second:

scroll down the list and you should see that the update list is black and is marked optional

(check nvidia driver) not exact name, you'll know it when you see it

select (accept)

sit back and wait for the download

after it downloads restart x or restart your computer it doesn't matter

you should see an nvidia splash screen before your window manager loads, if not come back to the forum.

if you do see the screen you should be able to go into SaX2 and change your resolution.

Sorry if this is sloppy I'm tired. Good luck buddy.
 
Old 12-30-2004, 06:34 PM   #42
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
I have been following this thread off and on for the last few days and I think you were mislead by SlackerLX from the beginning. Editing your /etc/X11/XF86Config (or xorg.conf) may be the way you would tackle this problem in Slackware, but it's not the way I have had success with SUSE. I'm assuming that SUSE has recognized your new GeForce card.

First, download the latest nvidia driver from here to your home directory.

Then exit the gui by typing ctrl > alt > F1. This should take you to a text screen asking you to log in as user. Do so. Then log in as root and type init 3.

You may have to press enter again to get back your prompt.

Type sh NVIDIA-Linux-x86-1.0-6629-pkg1.run -q

Follow the nvidia installer through the steps. It will have to build a module for your kernel. Don't worry about the riva module warning.

When the installer is through, type sax2 -m 0=nvidia (0 is a digit, not a letter!) You'll probably need to undo any other edits you did to /etc/X11/XF86Config. Save this file and log back in as regular user. Type startx.

The NVIDIA HOWTO for this is available at the suse/novell website and there are many threads on this forum about it.

Edit: 1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source', 'make' and 'gcc' packages with YaST2.
Update it - if not already done - via YaST2 Online Update (YOU).



HTH

Last edited by pilotgi; 12-30-2004 at 06:46 PM.
 
Old 12-30-2004, 07:47 PM   #43
Sabicas
Member
 
Registered: Aug 2004
Distribution: Slackware 10
Posts: 110

Rep: Reputation: 15
Don't try to manually install the driver unless you really need to. You shouldn't have to edit your xorg at all unless you install it manually. Follow my Yast directions above. Hopefully your xorg is still working properly.
 
Old 12-30-2004, 08:21 PM   #44
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
i tried typing over the nv with nvidia, but that just lost my gui (is that the x-server?)
Also Sabicas, I did try with yast first but it never changed anything.
When I open the Device Hardware Manager it shows to devices under Display. It shows nVidia 0x0322 and under that it shows Trigem i845)
I have disabled the onboard video on the bios and window no longer finds it. Actually for what it is worth I have not been to windows now for 2 days. (A new record for me)
Is it possible that SUSE is dectecting the onboard vidio card and that is the problem, or is Trigem the generic video driver that Linux uses in the begining - I asume it has to use some kind of driver since for whatever legal readons exist it can't use the Nvidia driver during installtion or until I later download it via YAST?
 
Old 01-01-2005, 01:04 AM   #45
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I don't know if this log helps?

/*************
SaX2 log : SaX2 version 4.8 - CVS Release: 1.49 2003/03/17
**************
CVS BUILD : 26443
:
DESCRIPTION : X11 configuration log file to collect information
: about detection, startup and configuration.
: There are three parts of logging:
: ---
: 1) INIT ( detection, 3D )
: 2) STARTUP ( XF86Config, X11 log, glxinfo )
: 3) CONFIG ( config actions )
: ---
:
VERSION : SaX2 compiled for: [SuSE Linux 9.2 (i586)]
PARAMETER : -m 0=nvidia
:
LOG DATE : Sat Jan 1 00:54:10 CST 2005
*************/
============================
Framebuffer Info:
----------------------------

mode "1280x1024-77"
# D: 131.096 MHz, H: 80.328 kHz, V: 76.649 Hz
geometry 1280 1024 1280 1024 16
timings 7628 160 32 16 4 160 4
rgba 5/11,6/5,5/0,0/0
endmode

Frame buffer device information:
Name : VESA VGA
Address : 0xe0000000
Size : 10485760
Type : PACKED PIXELS
Visual : TRUECOLOR
XPanStep : 0
YPanStep : 0
YWrapStep : 0
LineLength : 2560
Accelerator : No

01-Jan 00:54:11 <I> Initializing...
01-Jan 00:54:14 <I> [ Sysp: Mouse detection data
Mouse0 => Protocol : explorerps/2
Mouse0 => Device : /dev/input/mice
Mouse0 => Buttons : 5
Mouse0 => Wheel : 1
Mouse0 => Emulate : 0
Mouse0 => Name : Logitech Optical Mouse
]
01-Jan 00:54:14 <I> [ Sysp: Keyboard detection data
Keyboard0 => XkbModel : pc104
Keyboard0 => XkbLayout : us
]
01-Jan 00:54:37 <I> [ Sysp: Server detection data
Card0 => BusId : 0x2
Card0 => SlotId : 0x09
Card0 => FuncId : 0x0
Card0 => Vendor : NVidia
Card0 => Device : 0x0322
Card0 => VID : 0x10de
Card0 => DID : 0x0322
Card0 => Module : nv
Card0 => BusType : AGP
Card0 => Detected : 2
Card0 => Flag : DEFAULT
Card0 => SUB-VID : 0x0000
Card0 => SUB-DID : 0x0000

Card1 => BusId : 0x0
Card1 => SlotId : 0x02
Card1 => FuncId : 0x0
Card1 => Vendor : Intel
Card1 => Device : i845
Card1 => VID : 0x8086
Card1 => DID : 0x2562
Card1 => Module : nvidia
Card1 => BusType : PCI
Card1 => Detected : 2
Card1 => Flag : DEFAULT
Card1 => SUB-VID : 0x109f
Card1 => SUB-DID : 0x3186
]
01-Jan 00:54:38 <I> [ Sysp: XStuff detection data
SaX: ups lost card during probing... abort
]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant enable 3d acceleration ghostlkp Linux - Newbie 6 09-03-2005 02:37 PM
Can't enable 3D hardware acceleration. daedalusonlinux Suse/Novell 20 03-20-2005 09:42 PM
How do I enable 3d Acceleration in SUSE 9.1? Ray Finkel Linux - Newbie 2 08-19-2004 07:02 PM
I want to Enable my 3D Acceleration... mir_sheely Linux - Hardware 1 06-07-2004 05:32 AM
How do you enable 3d acceleration ultravox Linux - Hardware 2 04-05-2003 06:17 PM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration