LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 06-07-2004, 05:16 AM   #1
mir_sheely
Member
 
Registered: Mar 2004
Location: KARACHI
Distribution: WIN 98, WIN XP Pro, Mandrake 9.2
Posts: 166

Rep: Reputation: 30
I want to Enable my 3D Acceleration...


Hi everybpdy
I am using SIS 650/740 with an AMD duron processor. I am using Mandrake 9.2. The 3D acceleration of my VGA card is not available in LINUX. The same problem was occuring in Redhat 9.0.
Here is the content of my "/etc/X11/XF86Config-4" file


------------------------------------------------
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
#DontZap # disable <Crtl><Alt><BS> (server abort)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 60 Hz"
HorizSync 31.5-48.5
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "Silicon Integrated System"
BoardName "SiS 650"
Driver "sis"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 15
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 16
Virtual 800 600
EndSubsection

Subsection "Display"
Depth 24
Virtual 800 600
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection
----------------------------------------------------------

Now what is the problem? I think that the DRI is not installed and if it is installed then it is not loading. If it is not installed then can I find it in my Distro CD? if so then in which package it will be available?
If not then Kindly please give me few links here for DRI rpm packege
I shall be thankful.
Help me please.
 
Old 06-07-2004, 05:32 AM   #2
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
Your only hope is to use the proprietary driver from SIS. It's available on their website www.sis.com.

I've heard that it's buggy, but I have also heard of at least one person using it successfully. If you're using a notebook then forget it - it won't work.

If you can't get the SIS proprietary driver to work then you won't have 3d acceleration. Linux XFree drivers for SIS chipsets are provided by Thomas Winischhofer www.winischhofer.net but his drivers only provide DRI support for the older 300-series chipsets. Your SIS650 is a 315-series and there is no DRI support for that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant enable 3d acceleration ghostlkp Linux - Newbie 6 09-03-2005 02:37 PM
Can't enable 3D hardware acceleration. daedalusonlinux Suse/Novell 20 03-20-2005 09:42 PM
How do I enable 3d acceleration? JackieBrown Suse/Novell 65 01-05-2005 03:29 PM
How do I enable 3d Acceleration in SUSE 9.1? Ray Finkel Linux - Newbie 2 08-19-2004 07:02 PM
How do you enable 3d acceleration ultravox Linux - Hardware 2 04-05-2003 06:17 PM


All times are GMT -5. The time now is 11:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration