LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 06-29-2013, 03:43 PM   #1
MCDewy
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Rep: Reputation: Disabled
Slackware 14.0: Realtek ALC887-VD -> No Sound


Starting a new thread per Forums Rules.
1. Other thread not answered.
2. My issue, although on topic, would detract from efforts to fix the other gentleman's issue.
3. My hardware setup and issue is slightly different.
* Trying suggestions in the other thread also.

Code:
bash-4.2# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f10000 irq 46
 1 [Camera         ]: USB-Audio - USB Camera
                      OmniVision Technologies, Inc. USB Camera at usb-0000:00:1a.0-1.4, full speed
 2 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf7e40000 irq 48
Code:
bash-4.2# cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
Codec: Intel PantherPoint HDMI
Codec: ATI R6xx HDMI
Code:
bash-4.2# cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_usb_audio
 2 snd_hda_intel
Code:
bash-4.2# rmmod snd-hda-intel
Error: Module snd_hda_intel is in use
Code:
bash-4.2# alsactl init 0
Found hardware: "HDA-Intel" "Intel PantherPoint HDMI" "HDA:10ec0887,10280545,00100302 HDA:80862806,80860101,00100000" "0x1028" "0x0545"
Hardware is initialized using a generic method
Code:
bash-4.2# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB05a9:8519" "" ""
Hardware is initialized using a generic method
Code:
bash-4.2# alsamixer -c 0 <-Works
bash-4.2# alsamixer -c 1
invalid card index: 1
 
Old 06-29-2013, 03:55 PM   #2
MCDewy
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
I performed the first step in the other thread:

Code:
~# touch /etc/modprobe.d/alsa-base.conf 
~# echo "options snd-hda-intel model=generic" >> /etc/modprobe.d/alsa-base.conf
It originally didn't work.

I noticed it had found a little USB Camera, (I couldn't get it to work in Windows 7, forgot it was plugged in). I removed that then restarted after the previous command it it appears to be working now.

Thanks guys!
 
Old 06-29-2013, 03:59 PM   #3
MCDewy
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Disregard Solved Status.

I had performed those steps logged in as root, (I don't know how to run File Manager or KEdit as root, and I was trying to modify files and it wouldn't let me as user).

Anyway, Logged back on as my user account and it can't find any sound cards now. sigh..
 
Old 06-29-2013, 04:24 PM   #4
MCDewy
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Per the other thread, I tried adding the following to /etc/modprobe.d/sound.conf

Code:
options snd-hda-intel enable=1 index=0
options snd-hda-intel enable=0 index=1
I restarted, and still no change.

If I haven't said so already, I am new to linux. The following files were also in /etc/modprobe.d:

Code:
bash-4.2$ cd /etc/modprobe.d
bash-4.2$ ls -l
total 16
-rw-r--r-- 1 root root 511 Jul  8  2012 README
-rw-r--r-- 1 root root 108 Jun 29 14:44 alsa-base.conf
-rw-r--r-- 1 root root  33 Jun 26 17:18 snd-hda-intel.conf
-rw-r--r-- 1 root root  43 Jun 29 15:15 sound.conf
Added:
Code:
options snd_hda_intel index=0 model=auto
To sound.conf (replaced the other line actually, rebooting to see.

And, nope. No sound still.

Last edited by MCDewy; 06-29-2013 at 04:30 PM.
 
Old 06-29-2013, 04:39 PM   #5
MCDewy
LQ Newbie
 
Registered: Jun 2013
Posts: 15

Original Poster
Rep: Reputation: Disabled
Talking

Following other thread still: I have...

Code:
bash-4.2# cat /etc/modprobe.d/alsa.conf
cat: /etc/modprobe.d/alsa.conf: No such file or directory
Code:
bash-4.2# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
bash-4.2# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f10000 irq 47
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf7e40000 irq 48
I tried changing:

Code:
options snd_hda_intel index=0 model=auto

TO

options snd_hda_intel index=1 model=auto
In cound.conf with no change. I am lost now. Any help would be greatly appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14.0: Realtek ALC887-VD -> no sound slacksam Slackware - Installation 17 11-23-2013 02:16 PM
No Sound - ALC887 on a Gigabyte GA-E350N with AMD E-350D APU bdoremus Linux - Hardware 7 03-02-2013 05:46 AM
[SOLVED] No sound or bad sound card with Codec: Realtek ALC888 ludger Linux - Hardware 3 02-16-2011 04:20 AM
relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card deepclutch Linux - Hardware 3 09-29-2010 02:54 PM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-19-2006 12:44 AM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration