LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
LinkBack Search this Thread
Old 11-28-2012, 03:57 PM   #1
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Rep: Reputation: 1
Unhappy Slackware 14.0: Realtek ALC887-VD -> no sound


Using Slackware 14.0, I can't get no sound from my new mainboard.

Here are the outputs of some commands:
Code:
$ cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe020000 irq 40
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
Code:
$ cat /proc/asound/card*/codec* | grep Codec
Codec: ATI R6xx HDMI
Codec: Realtek ALC887-VD
Code:
$ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
Code:
# rmmod snd-hda-intel
# modprobe snd-hda-intel model=auto
Code:
# alsactl init 0
Found hardware: "HDA-Intel" "ATI R6xx HDMI" "HDA:1002aa01,00aa0100,00100200" "0x1458" "0x1314"
Hardware is initialized using a generic method
Code:
# alsactl init 1
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found
Code:
# alsamixer -c 0  # works
# alsamixer -c 1
cannot load mixer controls: Invalid argument
I also tested if sound works in some live cd/dvd distributions, and it does.
But what can I do to make it work with Slackware?
 
Old 11-29-2012, 11:03 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,203

Rep: Reputation: 229Reputation: 229Reputation: 229
The realtek ALC887 chip mixer contends with the alsa mixer, this often happens if the KDE environment is not run and configured at first boot after install.

Try create a file:

Code:
~# touch /etc/modprobe.d/alsa-base.conf 
~# echo "options snd-hda-intel model=generic" >> /etc/modprobe.d/alsa-base.conf
Restart.

Mplayer and all other audio apps should play this time.

Hope that helps.

Good luck.

Last edited by malekmustaq; 11-29-2012 at 11:08 AM.
 
Old 11-29-2012, 11:48 AM   #3
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
Thank you, malekmustaq.
But still no success.

Now with
Code:
$ alsamixer -c 0
AlsaMixer starts but shows the message
Code:
This sound device does not have any controls.
and still I get
Code:
$ alsamixer -c 1
cannot load mixer controls: Invalid argument
Moc also quits with an error message
Code:
$ mocp
Running the server...
Trying ALSA...
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Trying OSS...

FATAL_ERROR: No valid sound driver


FATAL_ERROR: Server exited

Last edited by slacksam; 11-29-2012 at 12:21 PM.
 
Old 12-22-2012, 08:26 AM   #4
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 82

Rep: Reputation: 14
RealTek ALC887-VD work for me:
Code:
$ cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xf9ff4000 irq 16
Code:
$ cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
you must setting one device:
http://docs.slackware.com/howtos:har...s_on_slackware

Last edited by kkady32; 12-22-2012 at 08:52 AM.
 
Old 01-09-2013, 03:06 PM   #5
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
@kkady32: Thanks for your reply, but that didn't work for me.

To make it work, I first had to make the following entry into a /etc/modprobe.d/*.conf file (I used sound.conf):
Code:
options snd-hda-intel enable=1 index=0
options snd-hda-intel enable=0 index=1
After rebooting my machine, now I get the following outputs:
Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16

$ cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
Sound generally works with moc and vlc, but alsamixer still doesn't work.
I get the following output:
Code:
$ alsamixer
cannot load mixer controls: Invalid argument
How I can make alsamixer work?
 
Old 01-10-2013, 01:52 AM   #6
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 82

Rep: Reputation: 14
put in /etc/modprobe.d/sound.conf:
Code:
options snd_hda_intel index=0 model=auto
 
Old 01-10-2013, 04:27 AM   #7
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
Thank you kkady32, but that changes nothing.

Alsamixer still quits with the error messages above, and using alsaclt I get the following output:
Code:
# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found
Here's the content of my sound.conf:
Code:
$ cat /etc/modprobe.d/sound.conf
options snd-hda-intel enable=1 index=0 model=auto
options snd-hda-intel enable=0 index=1
 
Old 01-10-2013, 04:33 AM   #8
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 82

Rep: Reputation: 14
i have :
Code:
cat /etc/modprobe.d/alsa.conf
options snd_hda_intel index=0 model=auto
Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xf9ff4000 irq 16
 1 [F1020          ]: USB-Audio - FaceCam 1020
                      KYE Systems Corp. FaceCam 1020 at usb-0000:00:12.2-2, high speed
and change in your /etc/modprobe.d/sound.conf the "-" with "_"(snd_hda_intel not snd-hda-intel)

Last edited by kkady32; 01-10-2013 at 04:39 AM.
 
Old 01-10-2013, 04:57 AM   #9
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
That doesn't work for me.
With this sound.conf:
Code:
$ cat /etc/modprobe.d/sound.conf
options snd_hda_intel index=0 model=auto
sound doesn't work and I get the same outputs like in my first post and the following:
Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ cat /proc/asound/cards
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe020000 irq 40
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
 
Old 01-10-2013, 04:59 AM   #10
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 82

Rep: Reputation: 14
ok then try to put :
Code:
options snd_hda_intel index=1 model=auto
 
1 members found this post helpful.
Old 01-10-2013, 06:01 AM   #11
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
Thank you, that brings a little progress:
Code:
$ cat /proc/asound/cards
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe024000 irq 16
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfe020000 irq 40

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Sound works in moc and vlc.
But the output with alsamixer is still the same:
Code:
$ alsamixer
cannot load mixer controls: Invalid argument
(btw: It doesn't matter if I use "-" or "_" in the sound.conf. The results are the same.)

Last edited by slacksam; 01-10-2013 at 06:08 AM.
 
Old 01-10-2013, 07:09 AM   #12
kkady32
Member
 
Registered: Dec 2010
Distribution: Slackware64
Posts: 82

Rep: Reputation: 14
try to remove /var/lib/alsa/asound.state and reboot after
i found this ,maybe help....

Last edited by kkady32; 01-10-2013 at 07:37 AM.
 
Old 01-13-2013, 03:51 AM   #13
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
That didn't work for me. After removing the asound.state I get no sound at all.

Stupib me, I didn't make a backup of the asound.state.
Is there a way to generate a new one? I tried to copy it from an installation on another computer, but it looks like that one doesn't work on this system.

btw.: Is there a way to reset alsa (or make alsa use changes in the configuration) without rebooting my machine?
 
Old 01-13-2013, 05:28 PM   #14
slacksam
Member
 
Registered: Oct 2012
Location: Germany
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 1
After using
Code:
# amixer -c0 cset numid=2 100%
sound works. But after rebooting my machine it mutes again, so I have to use amixer again to raise the volume.

Saving the settings doesn't work:
Code:
# alsactl store
alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument

# alsactl -f /var/lib/alsa/asound.state store 0
alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument
 
Old 01-13-2013, 05:53 PM   #15
Darth Vader
Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 553

Rep: Reputation: 103Reputation: 103
@OP: Just a note. Looks like in your setup, the HDMI "sound card" is activated first, and your system believe that there is the sound output.

If I will have your problem, I will try first to disable the HDMI audio, i.e. in case of Radeon, I will load the radeon module with audio=0 as parameter.

Last edited by Darth Vader; 01-13-2013 at 05:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No sound or bad sound card with Codec: Realtek ALC888 ludger Linux - Hardware 3 02-16-2011 03:20 AM
relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card deepclutch Linux - Hardware 3 09-29-2010 01:54 PM
Realtek alc660 no sound at all ASTRAPI Linux - Hardware 2 10-17-2009 01:04 PM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-18-2006 11:44 PM
Realtek Sound and Ubuntu Linux - No Sound meindl007 Linux - Hardware 22 10-05-2005 02:16 PM


All times are GMT -5. The time now is 10:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration