LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Slackware 14.0: Realtek ALC887-VD -> No Sound (http://www.linuxquestions.org/questions/slackware-installation-40/slackware-14-0-realtek-alc887-vd-no-sound-4175467843/)

MCDewy 06-29-2013 03:43 PM

Slackware 14.0: Realtek ALC887-VD -> No Sound
 
Starting a new thread per Forums Rules.
1. Other thread not answered.
2. My issue, although on topic, would detract from efforts to fix the other gentleman's issue.
3. My hardware setup and issue is slightly different.
* Trying suggestions in the other thread also.

Code:

bash-4.2# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f10000 irq 46
 1 [Camera        ]: USB-Audio - USB Camera
                      OmniVision Technologies, Inc. USB Camera at usb-0000:00:1a.0-1.4, full speed
 2 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf7e40000 irq 48

Code:

bash-4.2# cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
Codec: Intel PantherPoint HDMI
Codec: ATI R6xx HDMI

Code:

bash-4.2# cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_usb_audio
 2 snd_hda_intel

Code:

bash-4.2# rmmod snd-hda-intel
Error: Module snd_hda_intel is in use

Code:

bash-4.2# alsactl init 0
Found hardware: "HDA-Intel" "Intel PantherPoint HDMI" "HDA:10ec0887,10280545,00100302 HDA:80862806,80860101,00100000" "0x1028" "0x0545"
Hardware is initialized using a generic method

Code:

bash-4.2# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB05a9:8519" "" ""
Hardware is initialized using a generic method

Code:

bash-4.2# alsamixer -c 0 <-Works
bash-4.2# alsamixer -c 1
invalid card index: 1


MCDewy 06-29-2013 03:55 PM

I performed the first step in the other thread:

Code:

~# touch /etc/modprobe.d/alsa-base.conf
~# echo "options snd-hda-intel model=generic" >> /etc/modprobe.d/alsa-base.conf

It originally didn't work.

I noticed it had found a little USB Camera, (I couldn't get it to work in Windows 7, forgot it was plugged in). I removed that then restarted after the previous command it it appears to be working now.

Thanks guys!

MCDewy 06-29-2013 03:59 PM

Disregard Solved Status.

I had performed those steps logged in as root, (I don't know how to run File Manager or KEdit as root, and I was trying to modify files and it wouldn't let me as user).

Anyway, Logged back on as my user account and it can't find any sound cards now. sigh..

MCDewy 06-29-2013 04:24 PM

Per the other thread, I tried adding the following to /etc/modprobe.d/sound.conf

Code:

options snd-hda-intel enable=1 index=0
options snd-hda-intel enable=0 index=1

I restarted, and still no change.

If I haven't said so already, I am new to linux. The following files were also in /etc/modprobe.d:

Code:

bash-4.2$ cd /etc/modprobe.d
bash-4.2$ ls -l
total 16
-rw-r--r-- 1 root root 511 Jul  8  2012 README
-rw-r--r-- 1 root root 108 Jun 29 14:44 alsa-base.conf
-rw-r--r-- 1 root root  33 Jun 26 17:18 snd-hda-intel.conf
-rw-r--r-- 1 root root  43 Jun 29 15:15 sound.conf

Added:
Code:

options snd_hda_intel index=0 model=auto
To sound.conf (replaced the other line actually, rebooting to see.

And, nope. No sound still.

MCDewy 06-29-2013 04:39 PM

Following other thread still: I have...

Code:

bash-4.2# cat /etc/modprobe.d/alsa.conf
cat: /etc/modprobe.d/alsa.conf: No such file or directory

Code:

bash-4.2# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code:

bash-4.2# cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7f10000 irq 47
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf7e40000 irq 48

I tried changing:

Code:

options snd_hda_intel index=0 model=auto

TO

options snd_hda_intel index=1 model=auto

In cound.conf with no change. I am lost now. Any help would be greatly appreciated.


All times are GMT -5. The time now is 03:39 AM.