LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-18-2005, 09:58 AM   #1
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Rep: Reputation: 30
xine is very slow and mplayer does not run the fs mode


Hi,

What is wrong with xine and mplayer?
I have tried both the xine package from the CD and compiling from source but it is still slow. MPlayer plays fine but it does not toggle the full screen mode. I have tried using -fs and -vm for MPlayer, the first has no effect while the second won't display nicely.

I am currently running Slackware 10.1 and a 32MB ATI card.

Thanks,

Basel Mahdi
 
Old 06-18-2005, 10:10 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
sounds like you either just have a wholly pants PC, or you're not using a decent video output mode. on mplayer use "mplayer -vo xv file.avi" for example, to force the use of XVideo extensions. if it doesn't work, then you don't have xv suport, which would be why it's not done automatically for you.
 
Old 06-18-2005, 10:16 AM   #3
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
I have just tried what you suggested and mplayer gave the same error you mentioned. But why on Slackware? both of the application were working fine on SuSE 9.1-9.3
 
Old 06-18-2005, 10:33 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
your xorg / XFree86 configuration is the most likely cause. run "xvinfo" and you'll presmuably see "no adaptors present" or similar. if so, you can presumably enable this per video card. I thought is was an option in xorg.conf but i can't see one.
 
Old 06-18-2005, 01:42 PM   #5
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
Thanks acid_kewpie for your help.
xvinfo gives "no adapters present" as you said. I will take a look at xorg configuration file later and I will let you know what happens.

Edit: I forget to mention that mplayer started to behave like this after I compiled kernel-2.6.11.11 but xine behaves the same on 2.4.29 and 2.6.11.11

Last edited by Basel; 06-18-2005 at 01:45 PM.
 
Old 06-19-2005, 06:32 AM   #6
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
What should I do now to enable the Xvideo support?

running mplayer -vo xv does not display anything as you can see from the code:
Code:
bash-3.00$ mplayer -vo xv Naruto_-_134_AonE.avi
MPlayer 1.0pre7-3.3.4 (C) 2000-2005 MPlayer Team
CPU: Intel  (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Playing Naruto_-_134_AonE.avi.
AVI file format detected.
VIDEO:  [DIVX]  640x480  12bpp  23.976 fps  880.8 kbps (107.5 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.1 (build 2439/release)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
It seems there is no Xvideo support for your video card available.
Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
Error opening/initializing the selected video_out (-vo) device.


Exiting... (End of file)
Code:
bash-3.00$ xvinfo
X-Video Extension version 2.2
screen #0
 no adaptors present
However, using mplayer -vo x11 will play the file but in normal mode:
Code:
bash-3.00$ mplayer -vo x11 Naruto_-_134_AonE.avi
MPlayer 1.0pre7-3.3.4 (C) 2000-2005 MPlayer Team
CPU: Intel  (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Playing Naruto_-_134_AonE.avi.
AVI file format detected.
VIDEO:  [DIVX]  640x480  12bpp  23.976 fps  880.8 kbps (107.5 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.1 (build 2439/release)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
AF_pre: 44100Hz/2ch/s16le
AO: [oss] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [x11] 640x480 => 640x480 Planar YV12
SwScaler: using unscaled Planar YV12 -> BGRA special converter
[mpeg4 @ 0x85d1660]frame skip 8t:  0.000   1/  1 ??% ??% ??,?% 0 0
A:   1.1 V:   1.1 A-V:  0.028 ct:  0.095  27/ 27 44% 52%  2.0% 1 0
Here are my flag and graphical device sections from /etc/X11/xorg.conf
Code:
bash-3.00$ grep xvi /etc/X11/xorg.conf
# Uncomment this to disable tuning with the xvidtune client. With
# Uncomment this to enable the use of a non-local xvidtune client.
Code:
# Uncomment this to disable tuning with the xvidtune client. With
# it the client can still run and fetch card and monitor attributes,
# but it will not be allowed to change them. If it tries it will
# receive a protocol error.

#    Option     "DisableVidModeExtension"

# Uncomment this to enable the use of a non-local xvidtune client.

#    Option     "AllowNonLocalXvidtune"

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection
 
Old 06-19-2005, 11:21 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
ACK!!! you're using the vesa output??? good christ, that'll kill any half decent card. vesa 2.0 is thae standard that framebuffer use, it's an extemely basic fool proof method to display something graphical on any card less than 10 years old. it's a absolute last reosrt for X, and will never support XV at all. Even a 32mb card should run xv just fine. you need to find the right drivers for your card right away. I've never had anythign to do with ATI cards, but i'd assume that the radeon driver is what you want.
 
Old 06-19-2005, 02:40 PM   #8
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
As I said earlier , this problem appeared only after I compiled kerner-2.6.11.11. Do you think I missed some modules? What do I need to do in this case?
 
Old 06-19-2005, 02:49 PM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
well you're explictly using the vesa driver. installing a new kernel won't change your xorg.conf.... again i don't know about ATI's drivers, but NVidia's own kernel drviers need to be reinstalled after any new kernel is added.
 
Old 06-19-2005, 03:12 PM   #10
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
Thanks again acid_kewpie for your help.
Do you know the location where the drivers are stored? Maybe I can get the drivers from SuSE 9.3 if I know their location on the file system.
 
Old 06-19-2005, 04:32 PM   #11
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
what graphics card do you use ?

egag
 
Old 06-20-2005, 09:21 AM   #12
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
I am currently running Slackware 10.1 with a 32MB ATI card.
 
Old 06-20-2005, 09:32 AM   #13
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i read that in your first post, but i meant the name ?
i think you've gotto choose another driver for X instead of the vesa.

---------
Section "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection
---------

maybe try to change 'Driver "vesa" ' to ' Driver "ati" '
, and logout of X and restart it.
then see if it's any better...

egag
 
Old 06-20-2005, 09:44 AM   #14
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
How do I restart X?
 
Old 06-20-2005, 09:47 AM   #15
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
From SuSE 9.3 xorg.conf
Code:
Section "Device"
  BoardName    "Rage 128 PF"
  BusID        "1:0:0"
  Driver       "r128"
  Identifier   "Device[0]"
  VendorName   "ATI"
EndSection
Should I just update Slackware xorg.conf? Do I need to do anything else?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help On Mplayer And Xine cleverashwin Linux - General 1 07-18-2005 01:58 AM
Xine says sysem too slow: It isn't Draylath Linux - Newbie 1 08-30-2004 05:48 PM
xine vs mplayer Aeiri Linux - General 21 06-21-2004 02:41 PM
Help with Xine and Mplayer chupacabra Linux - Software 7 12-07-2003 10:11 AM
help!!!! how to exit full screen mode in xine littlecap Linux - Software 7 03-10-2003 08:54 AM


All times are GMT -5. The time now is 05:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration