LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2012, 05:02 AM   #1
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 832

Rep: Reputation: 167Reputation: 167
Question Xfce4.10 automount disk on desktop on login


Hi hope some one can help.

I've got a small but annoying problem with xfce4.10, when I login the usb disks I have plugged in appear on the desktop but unmounted which means I have to open nautilus to make them available, not a major problem but I have a launcher in the task bar that goes to a number of places on the disk which I use frequently, if the disk is unmounted I get an error.

I have tried adding the disk to fstab but then it doesn't appear on the desktop!

I can live with this problem but a solution would be nice
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 05-28-2012, 01:01 PM   #2
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 832

Original Poster
Rep: Reputation: 167Reputation: 167
Is there anybody out there?
 
Old 05-28-2012, 06:18 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,323

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
Yes, but not with any easy solutions. I haven't updated to xfce-4.10 so can't give you any advice on it as I simply don't know how it works yet, but one possible solution would be to look at setting up automount/autofs, but that might be slightly more involved than you may be looking for.


BTW, wasn't ignoring you, just didn't want to take you off the zero reply list as I didn't have a solid answer.
 
Old 05-28-2012, 06:58 PM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,217

Rep: Reputation: 176Reputation: 176
A right click on the icon doesn't show you a mount option?
 
Old 05-28-2012, 09:59 PM   #5
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
There's a GUI utility called palimpsest in the gnome-disk-utility package that can set this up. The only problem is that it requires GTK3, which you might not have installed. Give me an hour and I'll build it and see what you can add to your /etc/fstab to do what you want.

If you do want the SlackBuild for it, I'll post it.
 
Old 05-28-2012, 11:07 PM   #6
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
Hmm.. It doesn't appear to be working correctly. This is what should do what you're asking:
Code:
/dev/sdb1    /mnt/sdb1    auto    nosuid,nodev,comment=x-gvfs-show    0 0
It doesn't want to work for me though. Maybe that'll at least give you a starting point? I'll keep messing with it and see if I can find a solution.

Sorry.

Oh, and the application I was talking about is extremely buggy/incomplete, so I'm not going to post a link to it.
 
Old 05-29-2012, 06:34 AM   #7
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 832

Original Poster
Rep: Reputation: 167Reputation: 167
Quote:
Originally Posted by cwizardone View Post
A right click on the icon doesn't show you a mount option?
Mounting via clicking on the icon is not the problem - As I said in my 1st post the icon is there on the desktop but greyed out ( ie not mounted ) if I try to goto to a folder via the launcher in the panel I get an error message saying the disk is not mounted (obviously) , what I want is the disk mounted at login so I can either double click on the icon OR select the launcher.

Quote:
Originally Posted by apeitheo View Post
... /dev/sdb1 /mnt/sdb1 auto nosuid,nodev,comment=x-gvfs-show 0 0 ...
Mounting in fstab as I stated works , the disk gets mounted in the right place and can be accessed via the launcher but does NOT appear on the desktop so is not an option.

I'm trying to get AWAY from gnome not add more gnome dependencies so please no suggestions that include gtk3/gnome.
This has to be a xfce native solution
apeitheo thanks for the offer but I am quite capable of compiling/installing my own software , please don't take that the wrong way

P.S.
I'm NOT anti gnome ( I use nautilus and gedit ) I just don't want to add loads of gnome dependencies.

Last edited by Keith Hedger; 05-29-2012 at 07:00 AM.
 
Old 05-29-2012, 09:16 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,217

Rep: Reputation: 176Reputation: 176
I know you said you don't want anymore Gnome dependencies, but... the gnome-disk-utility-whatever-version might be the answer to your problem.

It can be found here,

http://connie.slackware.com/~rworkma...s/x86_64/deps/

Go back a few directories to find the i486 version.

Also, if you haven't already done so, be sure to properly setup "removeable drives and media" in the settings menu.

Last edited by cwizardone; 05-29-2012 at 09:21 AM.
 
Old 05-29-2012, 09:39 AM   #9
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 832

Original Poster
Rep: Reputation: 167Reputation: 167
Quote:
Originally Posted by cwizardone View Post
I know you said you don't want anymore Gnome dependencies, but... the gnome-disk-utility-whatever-version might be the answer to your problem.

It can be found here,

http://connie.slackware.com/~rworkma...s/x86_64/deps/

Go back a few directories to find the i486 version.

Also, if you haven't already done so, be sure to properly setup "removeable drives and media" in the settings menu.
Please don't take this the wrong way as I am asking for help but do you not read the posts? or the info about the poster? it quite clearly states that I am using slackware64 so why would I want to use a i486 version? and I have clearly stated that I wish to get away from gnome.
I have also stated that mounting the drives is NOT the problem so yes I do have "removeable drives and media" set up properly.
 
Old 05-29-2012, 10:23 AM   #10
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,217

Rep: Reputation: 176Reputation: 176
Yes. I read your post and you said,

Quote:
Originally Posted by Keith Hedger View Post
...appear on the desktop but unmounted which means I have to open nautilus to make them available...
I'm not a fan of gnome either and thought it odd that you would use nautilus. Isn't nautilus the Gnome default file manager? That has to require more gnome dependencies than the their simple disk utility?
Whatever. Good luck.
 
Old 05-29-2012, 03:01 PM   #11
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
Quote:
Originally Posted by Keith Hedger View Post
Mounting in fstab as I stated works , the disk gets mounted in the right place and can be accessed via the launcher but does NOT appear on the desktop so is not an option
The fstab option comment=x-gvfs-show is supposed to show it on the desktop regardless if it's already mounted or not. However, it doesn't seem to work for whatever reason.

That's all the gnome-disk-utility does--modify the fstab.
 
Old 05-29-2012, 03:06 PM   #12
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
Read monitor/udisks2/what-is-shown.txt in the gvfs-1.13.0 package. It explains the options to fstab to do exactly what you want to do.
 
Old 05-29-2012, 07:00 PM   #13
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
I've been working on this on and off all day, and it seems that it's not going to work no matter what I do. I've tried various fstab configurations, udev rules, and so on--all without success. The closest I've gotten is that it shows up on the desktop, mounted, at boot, but when you try to access it, you get "permission denied."

This is the closest I've gotten:
Code:
/etc/udev/rules.d/90-memorex.rules:

SUBSYSTEM=="block", ENV{ID_VENDOR}=="Memorex", ENV{UDISKS_SYSTEM}="1", ENV{UDISKS_IGNORE}="0", ENV{UDISKS_NAME}="USB"

/etc/rc.d/rc.local:

udisks --mount /dev/sdc1
There is a --mount-options flag for the udisks command, but selecting the option of 'user' isn't allowed apparently. udisksctl works but then the icon doesn't appear on the desktop.

I don't know what else to try. Sorry I couldn't help any further. I don't know if it's possible without patching the code.
 
Old 05-29-2012, 10:29 PM   #14
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
I think I finally figured it out. Make sure your /etc/fstab doesn't have an entry for the USB device and add this command to start when XFCE loads (in settings->session and startup->application autostart):
Code:
udisks --mount /dev/sdb1
Replace /dev/sdb1 with whatever your USB device is, and it should work on restart (hopefully).

While not necessary, if you want to change the names/icons of the USB devices that show up on your desktop, you can create a udev rule for each device. For example, in /etc/udev/rules.d/90-random-rules.rules:
Code:
SUBSYSTEM=="block", ENV{ID_VENDOR}=="Memorex", ENV{UDISKS_NAME}="USB Hard drive"
Good luck. If the above works, please mark this as solved.
 
Old 05-30-2012, 07:39 AM   #15
apeitheo
LQ Newbie
 
Registered: Apr 2006
Distribution: Slackware
Posts: 26

Rep: Reputation: 8
I also just found out why x-gvfs-show wasn't working. You need to recompile util-linux (>= 2.21.1) with the --enable-new-mount flag. Otherwise 'mount' doesn't like the x-* fstab options. Once you do this, it's as simple as adding this to your fstab:
Code:
/dev/sdc1    /mnt/hd    vfat    users,auto,x-gvfs-show,x-gvfs-name=USB    0  0
Make sure the mount point exists, and it should mount and show up on the desktop at boot. This is the "proper" way of doing what you want.

rworkman (a Slackware dev) figured this one out, so thank him
 
2 members found this post helpful.
  


Reply

Tags
disks, mount usb, xfce4 desktop


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automount in xfce4 or gnome2 chiendarret Linux - Software 8 07-13-2011 10:48 AM
xfce4 desktop crashed mjalalynia Linux - Desktop 7 08-12-2008 02:25 AM
how can i have xfce4 in my session when i login? mjalalynia Linux - Desktop 14 07-21-2008 12:27 AM
XFCE4 Hang at login. Megatog615 Linux - Software 1 05-12-2006 12:03 PM
XFCE4 or other As Desktop roadrash-uk Mandriva 4 03-28-2005 07:38 AM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration