LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 07-08-2008, 05:38 AM   #1
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Rep: Reputation: 15
Question how can i have xfce4 in my session when i login?


hello..
I install xfce4 by tar.gz file but i can not run it .i use GDM .how can i have xfce in my session?
tanks
 
Old 07-08-2008, 07:09 AM   #2
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
You should put info on what distribution you are using into your profile for questions like this - or give this very relevant detail along with your question - as well as a more detailed description of what exactly you did.

Almost every distribution uses some package-management system (apt, yum, synaptic...) - did you check the documentation that your distribution surely provides to find out what system it uses - and how to use it?

Typically you don't install software the way you described.
You did not really describe it - nobody here knows what kind of tar.gz it was that you installed, nor how you did it.
It could well be a source archive which you would need to compile fist - probably not what you wanted.
 
Old 07-08-2008, 03:03 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
This document will help you. Basically you need to find xfce44.desktop and copy it to /usr/share/xsessions.
 
Old 07-09-2008, 04:41 AM   #4
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
sorry for my bad English.
I use BLFS ( http://www.linuxfromscratch.org/blfs...le/x/xfce.html ) and compile&install xfce4.2.3.2 after unzip ,by this instruction:
./configure --prefix=/user --sysconfdir=/etc \--libexecdir=/usr/lib/xfce4 &&make
make install
i have a problem whith xffm4.2.3 .when i make it show this error:
-----------------------------------------------------------------
../libs/constants.h:27:37: error: xfce4-modules/constants.h: No such file or directory[/COLOR]
bookmarks.c: In function 'set_book_combo':
bookmarks.c:105: error: 'XFCE_RESOURCE_CACHE' undeclared (first use in this function)
bookmarks.c:105: error: (Each undeclared identifier is reported only once
bookmarks.c:105: error: for each function it appears in.)
bookmarks.c:105: warning: initialization makes pointer from integer without a cast
bookmarks.c: In function 'get_bookfile_path':
bookmarks.c:167: error: 'XFCE_RESOURCE_CACHE' undeclared (first use in this function)
bookmarks.c:167: warning: initialization makes pointer from integer without a cast
bookmarks.c: In function 'purge':
bookmarks.c:550: error: 'XFCE_RESOURCE_CACHE' undeclared (first use in this function)
bookmarks.c:550: warning: initialization makes pointer from integer without a cast
bookmarks.c: In function 'rememberbook':
bookmarks.c:623: error: 'XFCE_RESOURCE_CACHE' undeclared (first use in this function)
bookmarks.c:623: warning: initialization makes pointer from integer without a cast
make[2]: *** [libxffm_book_la-bookmarks.lo] Error 1
make[2]: Leaving directory `/media/program1/xfce-4.2.3.2/src/xffm-4.2.3/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/media/program1/xfce-4.2.3.2/src/xffm-4.2.3'
make: *** [all] Error 2
----------------------------------------
I understand from BLFS that no need to xffm for minimum XFce setup .
1-how can i do for this error?
2-can i have xfce in my login session?
tanks
 
Old 07-09-2008, 05:17 AM   #5
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
Completely ignoring your problem to compile xffm here:
I wondered about the name "xffm" - because I thought "thunar" is the filemanager for xfce.
It is so in every distribution I know about.
...and I found this
http://www.xfce.org/documentation/4.2/manuals/xffm

Maybe you should use thunar instead of xffm.
 
Old 07-09-2008, 07:54 AM   #6
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Maybe you should use thunar instead of xffm.
Yes, Thunar is now the file manager for XFCE. I would go with that instead of xffm.
 
Old 07-11-2008, 03:24 AM   #7
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
tanks. I install xffm and know it is not my problem.(some of directory in many of files was false).I install xfce4_session manager but i don't have "xfce" in my session in my log in page.
 
Old 07-19-2008, 07:32 AM   #8
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
is there any help?
i install xfce4-session package but it isn't "xfce" in session option in login page. i use init 4 for "startxfce4" from root.(if i type this command in gnome desktop terminal an error will be cased. /usr/bin/startxfce4: X server already running on display :0.0
xfce4-session: Another session manager is already running).so when i want logout from xfce only "close this session" option is active and can't restart or shutdown system. i googeld and
find must changed "sudoers" file .i use visudo -s command but i can't save my change.
am i wrong?
is there any way to haw xfce in my session in login page?
 
Old 07-19-2008, 07:44 AM   #9
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
Quote:
i install xfce4-session package but it isn't "xfce" in session option in login page.
What do you mean with "login page"?
What display-manager are you using? ...if you are using one at all - sounds like you start the xfce session directly?
 
Old 07-19-2008, 07:56 AM   #10
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
i use "gdm". login page=the page that you enter user name and password and select system language & session(kde or Gnome).
 
Old 07-19-2008, 08:36 AM   #11
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
On my Gentoo system the session files appear to be in /usr/share/xsessions/...
Code:
ls -al /usr/share/xsessions/
drwxr-xr-x   2 root root  4096 18. Jul 12:06 .
drwxr-xr-x 334 root root 12288 19. Jul 01:42 ..
-rw-r--r--   1 root root   202  8. Mär 22:50 fluxbox.desktop
-rw-r--r--   1 root root   212  3. Jul 22:40 gnome.desktop
-rw-r--r--   1 root root   200 17. Mai 03:02 IceWM.desktop
-rw-r--r--   1 root root   214 18. Jul 12:06 openbox.desktop
-rw-r--r--   1 root root   218 18. Jul 12:06 openbox-gnome.desktop
-rw-r--r--   1 root root   205 18. Jul 12:06 openbox-kde.desktop
-rwxr-xr-x   1 root root  1013  1. Jun 00:39 xfce.desktop
The xfce.desktop file looks like this (with anything but english removed):

cat xfce.desktop

Code:
[Desktop Entry]
Encoding=UTF-8
# The names/descriptions should really be better
Name=Xfce Session
Comment=Use this session to run Xfce as your desktop environment
Exec=startxfce4
Icon=
Type=Application
Does this help you?
 
Old 07-19-2008, 01:43 PM   #12
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
is there any help?
Did you look at the link I gave you? It has detailed the instructions to setup XFCE as a session in GDM or KDM.
 
Old 07-20-2008, 12:43 AM   #13
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
in my /usr/share/xsessions/ is:

[root@localhost ~]# ls -al /usr/share/xsessions/
total 52
drwxr-xr-x 2 root root 4096 2008-05-10 10:05 .
drwxr-xr-x 347 root root 12288 2008-03-15 16:44 ..
-rw-r--r-- 1 root root 4701 2008-02-16 09:11 gnome.desktop
-rw-r--r-- 1 root root 1280 2008-05-10 09:56 kde.desktop~
-rwxr-xr-x 1 root root 1246 2004-09-09 11:28 kde (نسخه).desktop

shoud i make a xfce.desktop file ??!! if no what can i do?
-----------------------------------------
dear reddazz. i can,t see your links (my server doesn't open them) tanks
 
Old 07-20-2008, 04:01 AM   #14
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
Read reddazz's post - and do what he suggests.
I too overlooked it because it was so far up - and recommended basically the same thing.
You don't have the needed file in /usr/share/xsessions/ - GDM does not know about your xfce-session.
copy it there - its all described....
 
Old 07-21-2008, 12:27 AM   #15
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Original Poster
Rep: Reputation: 15
tanks a lot!
i had xfce.desktop but it created in a bad directory .i find it and copy in /usr/share/xsessions/ and now i have xfce in my login page sessions option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting new X session in xfce4 Uruclef Debian 2 01-28-2007 03:28 AM
Starting a new X session from within Xfce4 cwwilson721 Slackware 15 07-30-2006 02:44 PM
XFCE4 Hang at login. Megatog615 Linux - Software 1 05-12-2006 12:03 PM
xfce4-session fails to save session ! OneManArmy Debian 0 12-10-2004 02:14 PM
Login session ust Linux - General 3 04-17-2003 07:41 AM


All times are GMT -5. The time now is 11:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration