LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2010, 01:12 PM   #1
sasser
Member
 
Registered: Apr 2010
Location: Bucharest
Distribution: Slackware13.37, OpenBSD5.1, FreeBSD9.0
Posts: 39

Rep: Reputation: 0
xfce keyboard layout problem


Hello,

Hardware and software: an old P3 "unbranded" laptop running Slackware 13
Me: linux newbie

During the installation, the setup notified me that I'm using a different keyboard layout, so I conducted some tests and finally found the keyboard match as QWERTZ/de_CH-latin1.map.

After finishing the installation I could login and use the system prety nice in text mode, but in XFCE GUI the keyboard map is set to default US.
I've found an old topic about a very similar problem here:
http://www.linuxquestions.org/questi...layout-322374/
Unfortunately the solution founded there doesn't work for me.. it seems that editing /etc/X11/xorg.conf or running xorgsetup doesn't have an effect in my xfce.
The only thing that works is setxkbmap command and GUI wizards.
To complicate things, the laptop physical keyboard layout has a key named "Alt GR" which allows me to type a 3rd character on some keys, for instance on key 3:
Key 3 only shows character: 3
Shif + key 3 show character: *
Alt Gr + key 3 show character: #

How can I change the keyboard layout for xcfe to de_CH-latin1.map?

Thanks
 
Old 04-11-2010, 07:19 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
ftp://ftp.gwdg.de/pub/linux/slackwar..._AND_HINTS.TXT has a section about non-US-keyboards, you will have to copy and edit a HAL fdi policy file, but it's not difficult
 
Old 04-11-2010, 04:01 PM   #3
sasser
Member
 
Registered: Apr 2010
Location: Bucharest
Distribution: Slackware13.37, OpenBSD5.1, FreeBSD9.0
Posts: 39

Original Poster
Rep: Reputation: 0
I manage to overcome the issue.. thus not completely.

I have to change the keyboard to swiss (ch) either by using GUI or typing the command setxkbmap ch

The problem now is apparently the xfce doesn't save this settings for the next login..so every time when I login in xfce GUI I have to set the keyboard layout. I set the same configuration in /etc/X11/xorg.conf and xfce doesn't care. Why?

Is there any configuration file for xfce where I can set the default keyboard to swiss (ch) and not US?
 
Old 04-11-2010, 04:18 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,898

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Hi,

Slackware uses hal to manage keyboard as titopoquito already said above.
Read /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi and if you want to use it, copy it to /etc/hal/fdi/policy/10-keymap.fdi and change
Quote:
<merge key="input.xkb.layout" type="string">us</merge>
to
Code:
<merge key="input.xkb.layout" type="string">ch</merge>
You have to restart hald:
Code:
/etc/rc.d/rc.hald restart
If you still want to use xorg.conf to configure your keyboard, you have to add/edit the following:
Code:
Section "ServerFlags"
    Option "AutoAddDevices" "0"
    Option "AllowEmptyInput" "0"
    Option "AutoEnableDevices" "0"
EndSection

Last edited by bathory; 04-11-2010 at 04:23 PM.
 
Old 04-12-2010, 07:32 AM   #5
sasser
Member
 
Registered: Apr 2010
Location: Bucharest
Distribution: Slackware13.37, OpenBSD5.1, FreeBSD9.0
Posts: 39

Original Poster
Rep: Reputation: 0
It works
I thing the best part in editing and copying the 10-keymap.fdi in /etc/hal/fdi/policy/ is changing the default for all users and all other GUI (fluxbox, blackbox, etc).

Thanks both.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XFCE: how to change the keyboard layout? athanatos Slackware 18 09-17-2008 01:37 AM
Keyboard Layout and XFCE rengo.Java Linux - Software 2 09-29-2007 02:10 PM
xfce change keyboard layout tramni1980 Slackware 1 07-12-2007 01:58 PM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 06:43 PM
Keyboard layout problem theonebeyond Linux - General 22 12-13-2004 01:38 AM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration