LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   xfce keyboard layout problem (http://www.linuxquestions.org/questions/slackware-14/xfce-keyboard-layout-problem-801081/)

sasser 04-09-2010 01:12 PM

xfce keyboard layout problem
 
Hello,

Hardware and software: an old P3 "unbranded" laptop running Slackware 13
Me: linux newbie

During the installation, the setup notified me that I'm using a different keyboard layout, so I conducted some tests and finally found the keyboard match as QWERTZ/de_CH-latin1.map.

After finishing the installation I could login and use the system prety nice in text mode, but in XFCE GUI the keyboard map is set to default US.
I've found an old topic about a very similar problem here:
http://www.linuxquestions.org/questi...layout-322374/
Unfortunately the solution founded there doesn't work for me.. it seems that editing /etc/X11/xorg.conf or running xorgsetup doesn't have an effect in my xfce.
The only thing that works is setxkbmap command and GUI wizards.
To complicate things, the laptop physical keyboard layout has a key named "Alt GR" which allows me to type a 3rd character on some keys, for instance on key 3:
Key 3 only shows character: 3
Shif + key 3 show character: *
Alt Gr + key 3 show character: #

How can I change the keyboard layout for xcfe to de_CH-latin1.map?

Thanks

titopoquito 04-11-2010 07:19 AM

ftp://ftp.gwdg.de/pub/linux/slackwar..._AND_HINTS.TXT has a section about non-US-keyboards, you will have to copy and edit a HAL fdi policy file, but it's not difficult :)

sasser 04-11-2010 04:01 PM

I manage to overcome the issue.. thus not completely.

I have to change the keyboard to swiss (ch) either by using GUI or typing the command setxkbmap ch

The problem now is apparently the xfce doesn't save this settings for the next login..so every time when I login in xfce GUI I have to set the keyboard layout. I set the same configuration in /etc/X11/xorg.conf and xfce doesn't care. Why?

Is there any configuration file for xfce where I can set the default keyboard to swiss (ch) and not US?

bathory 04-11-2010 04:18 PM

Hi,

Slackware uses hal to manage keyboard as titopoquito already said above.
Read /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi and if you want to use it, copy it to /etc/hal/fdi/policy/10-keymap.fdi and change
Quote:

<merge key="input.xkb.layout" type="string">us</merge>
to
Code:

<merge key="input.xkb.layout" type="string">ch</merge>
You have to restart hald:
Code:

/etc/rc.d/rc.hald restart
If you still want to use xorg.conf to configure your keyboard, you have to add/edit the following:
Code:

Section "ServerFlags"
    Option "AutoAddDevices" "0"
    Option "AllowEmptyInput" "0"
    Option "AutoEnableDevices" "0"
EndSection


sasser 04-12-2010 07:32 AM

It works :)
I thing the best part in editing and copying the 10-keymap.fdi in /etc/hal/fdi/policy/ is changing the default for all users and all other GUI (fluxbox, blackbox, etc).

Thanks both.


All times are GMT -5. The time now is 05:32 PM.