LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2005, 10:47 AM   #1
athanatos
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, OpenBSD 4.0
Posts: 58

Rep: Reputation: 15
XFCE: how to change the keyboard layout?


Hi!

I am using Slackware 10.1 and XFCE and I love it. The only thing to bother is that I don't know how to change the keyboard layout (i am using a german keyboard). The strange thing is, that when I exit XFCE, I am able to use the german keyboard in the konsole. So it is just XFCE where I can not use the german keyboard. I have been asked about the keyboard layout during the installation, and i have chosen the german keyboard. So please, help me, how can I use a german keyboard layout with XFCE? I have tried to go to Settings --> Keyboard, but there is just the options Default and Emacs. What file do I have to edit in order to gain support for my german keyboard in XFCE?

Thanks for any help!
 
Old 05-11-2005, 11:49 AM   #2
athanatos
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, OpenBSD 4.0
Posts: 58

Original Poster
Rep: Reputation: 15
Nevermind, I have the answere now. So, if someone has the same problem, here is what to do: you have to add a XkbLayout to the /etc/X11/xorg.conf file. Just open the file as root with your favourite editor and find the section "InputDevice" Identifier "Keyboard0". Then replace it with

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de,ru"
   EndSection
for example if you have a german or russian keyboard and a 105 key keyboard.

I just have a german keyboard so I simply did

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de"
   EndSection
and it works perfectly.

I have found that information on the XFCE-Wiki: http://www.myoo.de/xfce/index.php/Ti..._configure_Xkb

cheers, athanatos
 
Old 09-07-2007, 08:05 AM   #3
rengo.Java
Member
 
Registered: Apr 2007
Location: Argentina
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
Hi!
I have the same problem.
I change the xorg.conf and the layout changes ok, but there is a key that dont works in xfce, but it does in the console.
the key is the '>' and '<' (the same key).
In the console works fine, but in X dont.
Whith KDE dont happens this
The layout that i use is "latam".

Any idea?

Thank you!!

PD:Sorry my bad english
 
Old 09-07-2007, 09:13 AM   #4
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware, FreeBSD
Posts: 483

Rep: Reputation: 92
athanatos:>
In addition you may set keys combination that alter selected layouts.
In Input device section of xorg.conf
Code:
        ... 
        Option       "XkbOptions" "grp:alt_shift_toggle"
        ...
Alt+Shift combination switches between layouts. You may use instead of alt_shift_toggle many other options like ctrl_shift_toggle, shifts_toggle, ctrl_alt_toggle, lwin_toggle, rctrl_toggle etc. See documentation for more.

There is also a handy plugin for Xfce panel for graphical representation of the selected layout and allows to change it with mouse or other pointing device :-)
 
Old 09-29-2007, 03:08 PM   #5
rengo.Java
Member
 
Registered: Apr 2007
Location: Argentina
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
I solved my problem changing pc101 to pc105 option in xorg.conf.

Thanks!
 
Old 08-06-2008, 03:55 AM   #6
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Rep: Reputation: 15
layout problem

hi all
i have shch as this problem in xfce4 .i have 2 problem with my keyboard language.
there is a part of my /etc/X11/xorg.conf :
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ara"
Option "XkbOptions" "grp:alt_shifts_toggle,grp_led:scroll"
Option "XkbVariant" "azerty_digits"
EndSection
and in Settings --> Keyboard, there is just the options Default and Emacs
1-i select Arabic language from system-->keyboard but it didn't change and i can,t type Arabic (for example in word processor) . any suggestion?
2 -how can i add a new language? (i have my desired language in gnome and can select and use it, but not in xfce)
tanks for any help!

Last edited by mjalalynia; 08-06-2008 at 04:02 AM.
 
Old 08-06-2008, 05:01 AM   #7
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Click on the panel --> add new object --> and select the keyboard-layout-switcher to be added as a new panel-applet.
It is worth a try - althoug it only gives me the option to switch between german and US-english, but that might be because those two are the only two locales I have installed on my system and the only two I will ever need.

[edit]
I knew I was looking for something else that I had used before - and I found it:
http://www.sabayonlinux.org/forum/vi...p?f=53&p=82050
I don't now (now) how to acces it through any of the menus - but from a terminal:
xfkc
will launch it and give you the option to select any keyboard-layout you like.

I'm on Gentoo and there it is installed by:
emerge x11-misc/xfkc
The website is here:
http://gauvain.tuxfamily.org/code/xfkc.html

Last edited by jomen; 08-06-2008 at 05:21 AM.
 
Old 08-06-2008, 05:45 AM   #8
mjalalynia
Member
 
Registered: Jul 2008
Posts: 48

Rep: Reputation: 15
tanks jomen
i install xfce4-xkb-plugin from this link:
http://goodies.xfce.org/projects/pan...lugin#xfce-4.2
and i add XKB Layout Switcher to my panel as a new object.now my first problem solved .but what a bout second problem?
 
Old 08-06-2008, 05:56 AM   #9
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Quote:
but what a bout second problem?
Maybe someone else will know - give it some time...

Did you see my [edit] about xfkc ?

The availability of languages should not be the problem as you are able to use them in Gnome as you say.

[edit]
You also should consider opening a new thread instead (with a link to this) - since you took over this one which was almost one year old and posted in a slackware-specific forum. You might get more attention that way.

Last edited by jomen; 08-06-2008 at 06:05 AM.
 
Old 09-15-2008, 09:17 PM   #10
Espina
LQ Newbie
 
Registered: Sep 2008
Location: San Jose, Costa Rica
Distribution: Xubuntu
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by athanatos View Post
Nevermind, I have the answere now. So, if someone has the same problem, here is what to do: you have to add a XkbLayout to the /etc/X11/xorg.conf file. Just open the file as root with your favourite editor and find the section "InputDevice" Identifier "Keyboard0". Then replace it with

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de,ru"
   EndSection
for example if you have a german or russian keyboard and a 105 key keyboard.

I just have a german keyboard so I simply did

Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "de"
   EndSection
and it works perfectly.



cheers, athanatos

I have a problema: my text editor won't let me save any changes. Do you know why this happen? Any ideas on how to fix it?

Thanks!
 
Old 09-16-2008, 02:09 AM   #11
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Quote:
Originally Posted by Espina View Post
I have a problema: my text editor won't let me save any changes. Do you know why this happen? Any ideas on how to fix it?
Do you mean: while editing the file /etc/X11/xorg.conf?
Or generally any file?

In the former case: the editor has to be run as root to be able to save changes to the file.
In the latter: where do you want to save to? Check the permissions there. What editor is it?

This thread is pretty old - is this really related to the topic of it? Consider opening a new thread on your topic if you don't get help after a few days here.
 
Old 09-16-2008, 01:07 PM   #12
Espina
LQ Newbie
 
Registered: Sep 2008
Location: San Jose, Costa Rica
Distribution: Xubuntu
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by jomen View Post
Do you mean: while editing the file /etc/X11/xorg.conf?
Or generally any file?

In the former case: the editor has to be run as root to be able to save changes to the file.
In the latter: where do you want to save to? Check the permissions there. What editor is it?

This thread is pretty old - is this really related to the topic of it? Consider opening a new thread on your topic if you don't get help after a few days here.

I just fixed the problem. It seems that in order to make any changes in the xorg.conf file you must have sudo access (I don't know if its correct to say "sudo access").

That gave me another problem: I didn't know how to edit the file at all, because I'm new to Linux and I know nothing.

So, a friend told me to use this line in the terminal:

gksudo gedit /etc/X11/xorg.conf

The problem was that I was running xubuntu, and it doesn't come with gedit...it comes with mousepad, but I spent hours looking how to change the file and wondering why nothing happened when I typed the line above.

At the end, I just swapped the "gedit" part with "mousepad", making it possible for me to edit the xorg.config file.

And Voila! it ran perfectly, except for a little thing: In the spanish keyboard, the button on the right of the left-shift button is a bigger than/lesser than button, but that's not what it types whenever I hit it, it types this:
|

It's a little foolish thing, but if you could help me with that I'll be very grateful.


Oh, and thank you for the last post!!

Last edited by Espina; 09-16-2008 at 02:57 PM.
 
Old 09-16-2008, 03:26 PM   #13
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Did you read through the thread and tried the possible solutions given there?

There is a plugin for the panel in xfce - and also a way to configure it via the "Settings" menu.

An alternative solution could be:
Code:
sudo dpkg-reconfigure console-setup
and going through the menus you are presented with
 
Old 09-16-2008, 03:50 PM   #14
Espina
LQ Newbie
 
Registered: Sep 2008
Location: San Jose, Costa Rica
Distribution: Xubuntu
Posts: 7

Rep: Reputation: 0
So, Do I only change PC101 to PC105?
 
Old 09-16-2008, 03:58 PM   #15
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
I don't know through what menus you are asked exactly and what you have to answer to each question.
Count the keys and you have the answer to one question.
 
  


Reply

Tags
input, keyboard, language, second


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change keyboard layout in console danielfisica Slackware 10 08-05-2014 10:44 AM
how can I change tty keyboard layout? fmardones Linux - Software 0 01-15-2005 09:09 PM
how to change keyboard layout in gnome 2.6 kpachopoulos Linux - General 0 10-07-2004 01:34 PM
kde: change keyboard layout kpachopoulos Linux - Newbie 3 09-29-2004 04:01 PM
How do i change the keyboard layout? ArmedCoder Linux - Hardware 0 11-20-2003 07:25 PM


All times are GMT -5. The time now is 05:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration