LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-01-2012, 12:44 AM   #1
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Rep: Reputation: Disabled
wxWidgets not installed?


Hi there everyone.
I am a fresh newbie to Linux and just installed the Slackware(running xfce) in my laptop. It's running just perfect on it, and LOVE IT.

However, when I tried to install the software aMule in my machine, I got a message from slackbuild:

configure: error:
wxWidgets must be installed on your system but wx-config script couldn't be found. Please check that wx-config is in path or specified by --with-wx-config=path flag, the directory where wxWidgets libraries are installed (returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH or equivalent variable and wxWidgets version is 2.8.12 or above.

So, I downloaded the wxWidgets 2.9 and recompiled / ldconfiged it. And re-installed the aMule again. But still, I got the same error message! I am sure the wxWidgets has been installed because I could run wx-config command and it is in the $PATH!

What else should I do to fix it?

Thank guys.

Last edited by 688a; 10-01-2012 at 01:00 AM. Reason: Wrong spelling
 
Old 10-01-2012, 01:34 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,518

Rep: Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182Reputation: 1182
Hi,

welcome to LQ and this Slackware forum.

I suppose that you use a SlackBuild from slackbuilds.org, and that you are running Slackware 14, right?

Did you install the the dependencies mentioned on this page?

Also, Some SlackBuilds for 13.37 don't work for 14.0 and that could be the case for this one (I didn't try). Then better simply wait for the SlackBuilds intended for Slackware 14.0 to be released, this could take a few days.

Now if you are running Slackware 13.37, better inform the maintainer of the script or post in slackbuild.org's mailing list.
 
Old 10-01-2012, 03:24 AM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,593

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Use wxGTK 2.8.x instead of going with the development release of 2.9.x
 
1 members found this post helpful.
Old 10-01-2012, 10:15 PM   #4
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Hi,

welcome to LQ and this Slackware forum.

I suppose that you use a SlackBuild from slackbuilds.org, and that you are running Slackware 14, right?

Did you install the the dependencies mentioned on this page?

Also, Some SlackBuilds for 13.37 don't work for 14.0 and that could be the case for this one (I didn't try). Then better simply wait for the SlackBuilds intended for Slackware 14.0 to be released, this could take a few days.

Now if you are running Slackware 13.37, better inform the maintainer of the script or post in slackbuild.org's mailing list.
Thx dude. Yes mine is 14. I am pretty new and don't really understand how to set all these variables in the link you mentioned. And more questions are coming along when I start using it, such as no audio etc... I think I need to read the SlackDocs again more carefully.
Thx anyway.
 
Old 10-01-2012, 10:16 PM   #5
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by willysr View Post
Use wxGTK 2.8.x instead of going with the development release of 2.9.x
I got no luck on 2.8.x!
 
Old 10-01-2012, 10:22 PM   #6
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Oh.... btw, I've found that the amule installation is looking for wxWidgets in /user/bin. But the slackbuild put the wxWidgets in /usr/local/bin. How can I tell slackbuild to install the lib in the right place?

Thx.
 
Old 10-02-2012, 12:07 AM   #7
bnguyen
Member
 
Registered: Jul 2010
Distribution: Slackware
Posts: 125

Rep: Reputation: 32
Where did you get the SlackBuild for wxWidgets?
 
Old 10-02-2012, 12:42 AM   #8
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 930

Rep: Reputation: 96
You should pass the option --prefix=/usr to the configure script.
 
Old 10-02-2012, 01:16 AM   #9
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,593

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Quote:
Originally Posted by 688a View Post
I got no luck on 2.8.x!
what do you mean no luck?
it builds fine with SlackBuilds
 
Old 10-02-2012, 03:41 AM   #10
fgcl2k
Member
 
Registered: Jan 2011
Distribution: Slackware 14.1
Posts: 106

Rep: Reputation: 27
Quote:
Originally Posted by 688a View Post
But the slackbuild put the wxWidgets in /usr/local/bin. How can I tell slackbuild to install the lib in the right place?
Thx.
As others have already asked, are you using the wxGTK package from SlackBuild.org( http://slackbuilds.org/repository/13...braries/wxGTK/)? I have wxGTK 2.8.12 on 13.37; it installed flawlessly in /usr; I don't think that SlackBuilds from SlackBuild.org install using the /usr/local prefix.
Code:
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --enable-shared \
  --with-opengl \
  --${_do_unicode}able-unicode \
  --build=$ARCH-slackware-linux$ARCHQUADLET
 
Old 10-02-2012, 12:56 PM   #11
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ilgar View Post
You should pass the option --prefix=/usr to the configure script.
I'll try later.

Quote:
Originally Posted by bnguyen View Post
Where did you get the SlackBuild for wxWidgets?
I got mine from slackbuilds.org!


Quote:
Originally Posted by willysr View Post
what do you mean no luck?
it builds fine with SlackBuilds
Sorry about my English and it got you guys confused.
My problem isn't the wxWidgets installation. It installed just fine to me(I guess). But when I installed the application aMule from slackbuild, it said no wxWidgets installed. I think the problem should be aMule installation, not wxWidgets.



Quote:
Originally Posted by fgcl2k View Post
As others have already asked, are you using the wxGTK package from SlackBuild.org( http://slackbuilds.org/repository/13...braries/wxGTK/)? I have wxGTK 2.8.12 on 13.37; it installed flawlessly in /usr; I don't think that SlackBuilds from SlackBuild.org install using the /usr/local prefix.
Code:
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --enable-shared \
  --with-opengl \
  --${_do_unicode}able-unicode \
  --build=$ARCH-slackware-linux$ARCHQUADLET
I don't know. I didn't change any codes anything. I just followed the instruction and installed the software. I don't know why the slackbuild put the things in the /usr/local! When I used "which wx-config", it showed /usr/local/bin. Is that meant to be in there?!


Thx guys.

Last edited by 688a; 10-02-2012 at 01:04 PM.
 
Old 10-02-2012, 01:12 PM   #12
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,473

Rep: Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901
can it be you got a previous install of wxWidgets from sources laying around?

can you show us the content of the wx* package you have installed? Its file list is in /var/log/packages/wx*

Last edited by ponce; 10-02-2012 at 01:15 PM.
 
Old 10-02-2012, 02:06 PM   #13
bnguyen
Member
 
Registered: Jul 2010
Distribution: Slackware
Posts: 125

Rep: Reputation: 32
Quote:
Originally Posted by 688a View Post
I'll try later.
I got mine from slackbuilds.org!
Please be specific, did you use wxX11, wxGTK or wxPython?

Also, post the link on slackbuilds.org where you downloaded it from.
 
Old 10-02-2012, 07:55 PM   #14
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,593

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Quote:
Originally Posted by ponce View Post
can it be you got a previous install of wxWidgets from sources laying around?
I'm thinking the same idea, but even with source installation, the aMule should be able to find wxWidgets
Did you use the latest version of aMule?
 
Old 10-02-2012, 10:56 PM   #15
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bnguyen View Post
Please be specific, did you use wxX11, wxGTK or wxPython?

Also, post the link on slackbuilds.org where you downloaded it from.
I just did the searching on the SlackBuilds.org.
I installed the wxGTK this morning and things seemed ok for wxWidgets.



Quote:
Originally Posted by ponce View Post
can it be you got a previous install of wxWidgets from sources laying around?

can you show us the content of the wx* package you have installed? Its file list is sin /var/log/packages/wx*
Quote:
Originally Posted by willysr View Post
I'm thinking the same idea, but even with source installation, the aMule should be able to find wxWidgets
Did you use the latest version of aMule?
OK guys. I've got this through. I installed 14.0 verison of the wxGTK from SlackBuilds.org and it's now ok. (14.0 version can't be searched yesterday, must be newly added)

But there is another error:

checking for crypto++ version >= 5.1... no
configure: error:
Could not find crypto++ header file "cryptlib.h".
Please try again with --with-crypto-prefix=/my_crypto_prefix
(replace /my_crypto_prefix with a valid path to your crypto++
installation directory).


I googled the error message and it seems like something about GCC compiler. Should I install avr-gcc from SlackBuilds? Or should I apply the new gcc patch (and how to do it in Slackware)?

Thx guys.

Last edited by 688a; 10-02-2012 at 10:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] wxWidgets plotctrl not installed by Opensuse package manager. sniff Linux - Software 2 11-26-2010 08:05 AM
qt vs wxwidgets icecubeflower Linux - Newbie 2 03-19-2010 01:22 AM
WxWidgets icecubeflower Linux - Newbie 2 11-24-2009 11:44 AM
wxWidgets kornerr Programming 2 10-13-2005 11:05 AM
wxwidgets, anyone used it? acidjuice Programming 6 03-31-2005 04:28 AM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration